Messaggi di errore quando si tenta di stampare o visualizzare in anteprima un report personalizzato in Microsoft Dynamics SL: "Errore modulo di gestione stampa Crystal 536" o "sistema Messaage 7014"

Sintomi

Quando si stampa un report personalizzato o visualizzare in anteprima un report personalizzato prima di stamparlo in Microsoft Dynamics SL, si ricevono messaggi di errore seguenti:

Errore del motore di stampa Crystal: 536-errore nel File. Impossibile connettersi: parametri di accesso non corretto.

Messaggio di sistema 7014: Esecuzione del Report non riuscito con errore 536.

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Causa

Causa 1

Il parametro di Connessione Trusted nel file di report è impostato su 1. Vedere risoluzione 1.

Causa 2

La connessione Open Database Connectivity (ODBC) nella workstation è danneggiata. Vedere risoluzione 2.

Causa 3

Il report fa riferimento a due database diversi. Vedere Risoluzione 3.

Causa 4

L'account di accesso E7F575915A2E4897A517779C0DD7CE in SQL Server 2005 o SQL Server 2008 è disabilitata o ha una password non corretta. Vedere risoluzione 4.

Risoluzione

Risoluzione 1

Per risolvere questo problema, impostare il parametro di Connessione Trusted nel file di report su 0 (zero). A tale scopo, attenersi alla seguente procedura:

  1. Avviare Crystal Reports 10 per Salomone.

  2. Fare clic su Apri, selezionare il report personalizzato e quindi fare clic su Apri.

  3. Dal menu Database , fare clic su Imposta percorso di origine dati.

  4. Nella finestra di dialogo Imposta percorso di origine dati , espandere origine dati corrente: proprietà.

  5. In origine dati corrente: proprietà, individuare il Trusted Connection: 1 parametro.
    Nota: Se non è elencato il parametro di Connessione Trusted , l'opzione di Connessione Trusted non era selezionata quando è stato creato il rapporto e non è la causa dell'errore.

  6. Mouse Trusted Connection: 1, quindi scegliere Modifica.

  7. Digitare 0.

  8. Fare clic su Chiudi.

  9. Fare clic su Salva.

Risoluzione 2

Per risolvere questo problema, eliminare le connessioni ODBC di Microsoft Dynamics SL. Quindi consentire Microsoft Dynamics SL ricreare le connessioni. A tale scopo, attenersi alla seguente procedura:

  1. Fare clic su Start, scegliere Pannello di controllo, fare clic su Strumenti di amministrazionee quindi fare clic su Origine dati (ODBC).

  2. Nella scheda DSN utente , rimuovere tutti gli elementi che fanno riferimento ai database dell'applicazione Microsoft Dynamics SL.

  3. Nella scheda DSN di sistema , rimuovere tutti gli elementi che fanno riferimento ai database dell'applicazione Microsoft Dynamics SL.

  4. Eseguire nuovamente il report in Microsoft Dynamics SL. Le connessioni ODBC vengono nuovamente create automaticamente quando si esegue un report in Microsoft Dynamics SL.

Risoluzione 3

Per risolvere questo problema, reimpostare l'origine dati in Crystal Reports. A tale scopo, attenersi alla seguente procedura:

  1. Avviare Crystal Reports 10 per Salomone.

  2. Fare clic su Apri, selezionare il report personalizzato e quindi fare clic su Apri.

  3. Dal menu Database , fare clic su Imposta percorso di origine dati.

  4. Nella casella Sostituisci con espandere Crea nuova connessionee quindi espandere ODBC (RDO).

  5. Fare clic su database di Microsoft Dynamics SL e quindi fare clic su Avanti.

  6. Immettere le informazioni di accesso. Non selezionare la casella di controllo Connessione Trusted .

  7. Fare clic su Fine.

  8. Fare clic sul database nella casella Sostituisci con . Scegliere il database nella casella Origine dati corrente .

  9. Fare clic su Aggiorna.

  10. Se si dispongono di più database nella casella Origine dati corrente , ripetere i passaggi 8 e 9 per ogni database.

  11. Fare clic su Salvae quindi uscire da Crystal Reports.

Risoluzione 4

Per risolvere questo problema, attivare l'account di accesso E7F575915A2E4897A517779C0DD7CE in SQL Server 2005 o SQL Server 2008 e quindi eseguire lo scenario di aggiornamento di sicurezza e sincronizzare tutte le proprietà nella schermata di Manutenzione Database (98.290.00) in Microsoft Dynamics SL. A tale scopo, attenersi alla seguente procedura:

  1. Avviare SQL Server Management Studio e quindi connettersi al server che ospita i database di Microsoft Dynamics SL.

  2. Nel riquadro Esplora oggetti , espandere protezionee quindi espandere account di accesso.

  3. In account di accesso, fare E7F575915A2E4897A517779C0DD7CEe quindi scegliere proprietà.

  4. Nel riquadro Selezionare una pagina , fare clic su statoe quindi fare clic su attivata in account di accesso.

  5. Fare clic su OKe quindi chiudere SQL Server Management Studio.

  6. Nel Pannello di controllo, fare clic su Strumenti di amministrazionee quindi fare clic su Manutenzione di Database di Microsoft Dynamics SL.

  7. Connettersi all'istanza di SQL Server che ospita i database di Microsoft Dynamics SL.

  8. Fare clic sulla scheda Aggiorna Database .

  9. Nell'elenco di Scenari di aggiornamento , fare clic su Sincronizza tutte le proprietà e protezionee quindi fare clic su Aggiorna Database.

  10. Nella parte inferiore della schermata di Manutenzione Database (98.290.00) , verificare che la barra di avanzamento ha terminato e quindi fare clic su Chiudi.

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