Messaggio di errore quando si esamina il registro applicazioni nel computer in cui sono in uso i servizi AOS di Microsoft Dynamics AX 4,0: "eccezione RPC 1726 si è verificato nella sessione 10"

Sintomi

Quando si esamina il registro applicazioni in un computer in cui sono in uso i servizi Microsoft Dynamics AX 4,0 Application Object Server (AOS), potrebbe essere visualizzato un messaggio di errore simile al seguente:

Messaggio di errore 1

Tipo di evento: origine InformationEvent: Dynamics server 17Date: 7/4/2007Time: 12:30:14 PMEvent Categoria: NoneDescription: Object Server 01: errore RPC: eccezione RPC 1726 si è verificato nella sessione 10

Messaggio di errore 2

Tipo di evento: InformationEvent Source: Dynamics server 01Event Categoria: NoneEvent ID: 110Date: 7/4/2007Time: 12:30:33 più divertente: N/AComputer:nomecomputerDescrizione: Object Server 01: nessun ping da 10. Terminare la sessione.

Il primo messaggio di errore può essere associato al secondo messaggio di errore. Finché il server AOS non termina la sessione 10, ogni sessione che restituisce i messaggi di errore RPC smetterà di rispondere. Se troppe sessioni smettono di rispondere e restituiscono messaggi di errore RPC, il server AOS può arrestarsi.

Causa

Questo problema può verificarsi perché gli utenti escono da Microsoft Dynamics AX in modo inappropriato. Ad esempio, gli utenti terminano il processo di Microsoft Dynamics AX usando Gestione attività. RPC 1726 è un messaggio di errore di connessione generale. Tuttavia, il messaggio di errore RPC 1726 potrebbe essere associato al "No ping da 10. Messaggio di errore relativo alla terminazione della sessione. In questo caso, il problema è in genere causato dagli utenti che si escono da Microsoft Dynamics AX in modo inappropriato.

Risoluzione

Se si verifica questo problema nel client Microsoft Dynamics AX, non uscire dal client premendo CTRL + ALT + CANC. È consigliabile usare CTRL + INTERR e quindi attendere che il sistema risponda o contatti l'amministratore di Microsoft Dynamics AX o un altro utente che disponga dei diritti per il modulo utenti online. L'amministratore o l'altro utente può fare clic su Termina sessione per arrestare la sessione client.

Ulteriori informazioni

Se si verifica questo problema nel server AOS, è importante determinare quale sessione è la causa e cosa gli utenti stanno facendo per causare il problema. A tale scopo, eseguire lo script seguente:

select * from sysuserlog where logouttime = 0 and sessionid = <X> 

Nota Sostituire <X> con la sessione indicata nel messaggio di errore RPC. Dai risultati della query, nota le colonne userid e nomecomputer . I valori della colonna indicano chi effettua l'accesso e da dove. In genere, le eccezioni RPC sono causate da un'uscita non corretta dell'applicazione. Tuttavia, le eccezioni possono anche indicare che un processo aziendale è appeso o richiede molto tempo.

Riferimenti

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

953375 Come trovare un ID utente associato a un ID di sessione "errore RPC: eccezione RPC 1726 si è verificato in Session [SessionID]" messaggio di errore nel registro applicazioni nel server AOS in Microsoft Dynamics AX

953374 Viene visualizzato un messaggio di avviso nel registro applicazioni nel server AOS in Microsoft Dynamics AX: "SPID [SPID_number] per ID sessione [SessionID], è ancora presente nel database. Eliminare lo SPID dal database "

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