Errore "Si è verificato un errore durante l'eliminazione del database" quando un utente tenta di passare offline nel client Microsoft Dynamics CRM per Outlook

Questo articolo consente di risolvere il problema che si verifica quando si tenta di passare offline nel client Microsoft Dynamics CRM per Outlook.

Si applica a: Microsoft Dynamics CRM 2011
Numero KB originale: 2496443

Sintomi

Considerare lo scenario descritto di seguito:

  • Un computer client viene usato da più utenti o viene usato in un ambiente Terminal Server o Citrix.
  • Un utente passa offline. Quindi, un secondo utente fa clic su Vai offline.

In questo scenario, il secondo utente non può passare offline. In effetti, nessun altro utente può passare offline. e viene visualizzato un messaggio di errore analogo al seguente:

Errore durante l'eliminazione del database. Contattare l'amministratore Microsoft Dynamics CRM per assistenza e riprovare a passare alla modalità offline.

Importante

In questo articolo sono contenute informazioni relative alla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne una copia di backup e di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire backup, ripristino e modifiche al Registro di sistema, vedere Back up e ripristino del Registro di sistema in Windows.

Causa

È possibile configurare un solo utente per passare offline nel client Microsoft Dynamics CRM per Microsoft Office Outlook.

Risoluzione

Si tratta di un comportamento legato alla progettazione del prodotto. In Microsoft Dynamics CRM 2011 è possibile installare e configurare il client Microsoft Dynamics CRM per Outlook. È quindi possibile installare i componenti offline facendo clic sul pulsante Vai offline .

Se non si vuole che gli utenti possano fare clic sul pulsante Vai offline , è possibile usare una delle opzioni seguenti.

  • Opzione 1

    Rimuovere le autorizzazioni Vai offline per gli utenti che non si desidera visualizzare il pulsante Vai offline . A tal fine, attenersi alla seguente procedura:

    1. Per un utente che dispone delle autorizzazioni per modificare un ruolo di sicurezza CRM, fare clic su Impostazioni, su Amministrazione e quindi su Ruoli di sicurezza.

    2. Fare clic per aprire il ruolo di sicurezza che è necessario modificare. (Ad esempio, fare clic su Sales Manager)

    3. Fare clic sulla scheda Gestione aziendale e quindi fare clic per deselezionare la casella di controllo Vai offline nella sezione Privilegi vari .

    4. Fare clic su Salva e quindi su Chiudi.

      Nota

      Potrebbero essere necessari 5 minuti o più prima che il pulsante scompaia sulla barra degli strumenti del client se il client è già configurato.

  • Opzione 2

    Disabilitare il pulsante Vai offline per tutti gli utenti in ogni computer e quindi installare il client Microsoft Dynamics CRM per Outlook insieme usando l'opzione disableofflinecapability . A tal fine, attenersi alla seguente procedura:

    1. Fare clic su Start, fare clic su Esegui e quindi digitare il percorso del file Setupclient.exe.

    2. se l'opzione /disableofflinecapability per installare il client Microsoft Dynamics CRM per Outlook. Ad esempio, usare il C:\Client\i386\SetupClient.exe/disableofflinecapability comando .

    3. Fare clic su Installa ora o usare il /q commutatore per eseguire un'installazione non interattiva senza richieste dell'utente.

  • Opzione 3

    Avviso

    L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi. che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di tali problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

    Se è già stato installato il client Microsoft Dynamics CRM per Outlook, è possibile modificare le chiavi del Registro di sistema LightClient in modo che tutti i nuovi utenti che eseguono la configurazione non visualizzi il pulsante Vai offline. A tal fine, attenersi alla seguente procedura:

    1. Fare clic sul pulsante Start, scegliere Esegui, digitare Regedit e quindi fare clic su OK.

    2. Individuare la sottochiave del Registro di sistema: HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient.

    3. Fare clic con il pulsante destro del mouse sulla chiave del Registro di sistema LightClient e quindi scegliere Modifica.

    4. Modificare il valore in 1, selezionare Decimale e quindi fare clic su OK.

    5. Avviare il client Microsoft Dynamics CRM per Outlook.

      Nota

      Potrebbero essere necessari 5 minuti o più prima che il pulsante scompaia sulla barra degli strumenti del client se il client è già configurato.

    6. Individuare la sottochiave del Registro di sistema: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMClient.

      Nota

      Se si usa un computer client a 64 bit e è installata una versione a 3 bit di Microsoft Office, la sottochiave del Registro di sistema appropriata è la seguente:
      HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\MSCRMClient.

    7. Fare clic con il pulsante destro del mouse sulla chiave del Registro di sistema LightClient e quindi scegliere Modifica.

    8. Modificare il valore in 1, selezionare Decimale e quindi fare clic su OK. Quando viene eseguita una nuova configurazione, il pulsante Vai offline verrà rimosso.

    Nota

    Quando si modifica la voce del Registro di sistema in HKEY_CURRENT_USER, la modifica influirà solo sull'utente attualmente connesso. Per applicare la modifica a più utenti, individuare il record in HKEY_Users\. In alternativa, applicare la chiave usando un Criteri di gruppo a multiple/other users.

Ulteriori informazioni

Se un utente è già offline e un altro utente deve essere in grado di passare offline nello stesso computer, è necessario eliminare il database dall'utente precedente. Per altre informazioni su come eliminare un database SQL Express, vedere DROP DATABASE (Transact-SQL).