Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Il supporto per Windows Vista Service Pack 1 (SP1) termina il 12 luglio 2011. Per continuare a ricevere gli aggiornamenti della sicurezza per Windows, assicurarsi di utilizzare Windows Vista con Service Pack 2 (SP2). Per altre informazioni, consulta questa pagina Web Microsoft: Il supporto per alcune versioni di Windows sta per terminare.

Sintomi

Si consideri lo scenario seguente.

  • Si esegue un Windows XP Service Pack 3 (SP3), Windows Vista Service Pack 1 (SP1) o un computer basato su Windows 7

  • Si usa un nome utente che include un carattere set di caratteri a byte doppio (DBCS).

Quando si prova a installare un'applicazione che usa Microsoft Visual C++ 2005 Redistributable Package, viene visualizzato il messaggio di errore seguente:

Errore di sintassi dell'opzione della riga di comando. Comando Digita/? Per assistenza.

Causa

Questo problema si verifica perché lo strumento Self-Extractor Cab Win32 non è in grado di gestire i caratteri DBCS nel nome utente.

Risoluzione

Per risolvere il problema, passare alla sezione " Risolvereil problema per me". Se si preferisce risolvere autonomamente il problema, andare alla sezione "Correzione manuale".

Correzione automatica



Per risolvere il problema automaticamente, fare clic sul collegamento o sul pulsante Correggi. Quindi fare clic su Esegui nella finestra di dialogo Download file e seguire i passaggi della procedura guidata Correggilo.




Note

  • La soluzione Fix it non funziona se l'account non è un account di amministratore.

  • Questa procedura guidata è disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.

  • Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Mix IT su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.


Passare quindi alla sezione "Il problema è stato risolto?"



Correzione manuale del problema

Per risolvere questo problema, attenersi alla seguente procedura:

  1. Fare clic sul Pulsante Start , fare clic con il pulsante destro del mouse su Computere quindi scegliere Proprietà.

  2. Nell'area impostazioni nome computer, dominio e gruppo di lavoro fare clic su Modifica impostazioni.

     Autorizzazione Controllo dell'account utente  se viene richiesta una password amministratore o una conferma, digitare la password o fare clic su Continua.

  3. Fare clic su Cambia impostazioni e quindi selezionare la scheda Avanzate. Fare clic sul pulsante Variabili dell'ambiente

  4. Nell'area Variabili utente fare clic su TEMP e quindi su Modifica.

  5. Nella casella Valore variabile digitare C:\Temp e quindi fare clic due volte su OK.

  6. Fare clic su Applica, quindi su OK.

  7. Eseguire i passaggi da 4 a 6 anche per la variabile di ambiente TMP.

  8. Verificare che la cartella C:\Temp esista, se non crearne una.

  9. Riavviare il computer.

  10. Provare a installare di nuovo l'applicazione.


Il problema è stato risolto?

  • Verificare se il problema è stato risolto. Se il problema è stato risolto, non occorre leggere il resto della sezione. Se il problema persiste, è possibile contattare il supporto tecnico.

  • Inviare commenti e suggerimenti. Per inviare feedback o segnalare eventuali problemi con la soluzione, lasciare un commento nel blog "Correggi il problema perme"o inviarci un messaggio di posta elettronica.

Serve aiuto?

Amplia le tue competenze

Esplora i corsi di formazione >

Ottieni in anticipo le nuove caratteristiche

PARTECIPA AL PROGRAMMA MICROSOFT 365 INSIDERS >

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×