Il supporto per Windows Vista Service Pack 1 (SP1) termina il 12 luglio 2011. Per continuare a ricevere gli aggiornamenti della sicurezza per Windows, assicurarsi di utilizzare Windows Vista con Service Pack 2 (SP2). Per altre informazioni, consulta questa pagina Web Microsoft: Il supporto per alcune versioni di Windows sta per terminare.
Sintomi
Si consideri lo scenario seguente.
-
Si esegue un Windows XP Service Pack 3 (SP3), Windows Vista Service Pack 1 (SP1) o un computer basato su Windows 7
-
Si usa un nome utente che include un carattere set di caratteri a byte doppio (DBCS).
Quando si prova a installare un'applicazione che usa Microsoft Visual C++ 2005 Redistributable Package, viene visualizzato il messaggio di errore seguente:
Errore di sintassi dell'opzione della riga di comando. Comando Digita/? Per assistenza.
Causa
Questo problema si verifica perché lo strumento Self-Extractor Cab Win32 non è in grado di gestire i caratteri DBCS nel nome utente.
Risoluzione
Per risolvere il problema, passare alla sezione " Risolvereil problema per me". Se si preferisce risolvere autonomamente il problema, andare alla sezione "Correzione manuale".
Correzione automatica
Per risolvere il problema automaticamente, fare clic sul collegamento o sul pulsante Correggi. Quindi fare clic su Esegui nella finestra di dialogo Download file e seguire i passaggi della procedura guidata Correggilo.
Note
-
La soluzione Fix it non funziona se l'account non è un account di amministratore.
-
Questa procedura guidata è disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
-
Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Mix IT su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.
Correzione manuale del problema
Per risolvere questo problema, attenersi alla seguente procedura:
-
Fare clic sul
, fare clic con il pulsante destro del mouse su Computere quindi scegliere Proprietà. -
Nell'area impostazioni nome computer, dominio e gruppo di lavoro fare clic su Modifica impostazioni.
se viene richiesta una password amministratore o una conferma, digitare la password o fare clic su Continua. -
Fare clic su Cambia impostazioni e quindi selezionare la scheda Avanzate. Fare clic sul pulsante Variabili dell'ambiente
-
Nell'area Variabili utente fare clic su TEMP e quindi su Modifica.
-
Nella casella Valore variabile digitare C:\Temp e quindi fare clic due volte su OK.
-
Fare clic su Applica, quindi su OK.
-
Eseguire i passaggi da 4 a 6 anche per la variabile di ambiente TMP.
-
Verificare che la cartella C:\Temp esista, se non crearne una.
-
Riavviare il computer.
-
Provare a installare di nuovo l'applicazione.
Il problema è stato risolto?
-
Verificare se il problema è stato risolto. Se il problema è stato risolto, non occorre leggere il resto della sezione. Se il problema persiste, è possibile contattare il supporto tecnico.
-
Inviare commenti e suggerimenti. Per inviare feedback o segnalare eventuali problemi con la soluzione, lasciare un commento nel blog "Correggi il problema perme"o inviarci un messaggio di posta elettronica.