MMSSPP non esegue il deprovisioning di una cassetta postale di Exchange e di oggetti abilitati alla posta elettronica da Office 365 dedicato/ITAR

Sintomi

Microsoft Managed Services Service Provisioning Provider (MMSSPP) non esegue il deprovisioning di una cassetta postale di Microsoft Exchange o di oggetti abilitati alla posta elettronica da un ambiente Office 365 dedicato/ITAR.

Causa

Il deprovisioning ha più definizioni e nel contesto di Office 365 dedicato/ITAR, questi servizi possono significare uno dei seguenti:

  • Disconnessione di una cassetta postale in Office 365 e conversione dell'oggetto di Office 365 in un utente abilitato alla posta elettronica. Ciò è comune in uno dei seguenti scenari:

    • Una cassetta postale utente viene migrata in un ambiente diverso (ad esempio, dal cloud a locale).

    • Dove i servizi di posta sono disabilitati ma vengono mantenuti altri servizi cloud (ad esempio Lync o Skype for Business).

    • Dove è possibile visualizzare le informazioni di contatto nell'elenco indirizzi globale (GAL).

    • Dove l'utente può essere membro di un gruppo di sicurezza abilitato alla distribuzione o alla posta elettronica in Office 365.

  • Annullamento del provisioning di un utente abilitato alla posta elettronica o di un contatto. In questo modo vengono rimossi i permessi e gli attributi della posta (mail, mailNickname, legacyExchangeDN, proxyAddressese targetAddress) e l'utente viene rimosso da qualsiasi gruppo di distribuzione o di sicurezza abilitato alla posta elettronica in Office 365, ma mantiene l'oggetto Active Directory (AD) di cui è stato eseguito il provisioning.

  • Rimozione completa dell'oggetto dell'utente da Active Directory di Office 365.

  • Conversione di una cassetta postale attiva in conservazione per controversia legale in uno stato inattivo.

  • Rimozione di un gruppo abilitato alla posta elettronica da Office 365 Active Directory.

La mancata deprovisioning può verificarsi per uno o più dei seguenti motivi:

  • I processi corretti o le procedure consigliate per eseguire il deprovisioning degli oggetti non vengono seguiti.

  • Un valore di attributo non configurato correttamente riportato nel Rapporto errori di sincronizzazione MMSSPP giornaliero blocca il deprovisioning della cassetta postale o dell'utente di posta elettronica.

  • Una cassetta postale è in conservazione per controversia legale. Tale cassetta postale non può mai essere eseguito il deprovisioning fino a quando tale flag è impostato (anche se può essere messo in uno stato inattivo).

Procedure consigliate

Scenario 1

L'utente dispone di una cassetta postale in Office 365D/ITAR e la cassetta postale deve essere deprovisionata. Tuttavia, l'oggetto Office 365D/ITAR deve rimanere nell'elenco indirizzi globale come utente abilitato alla posta elettronica.

  1. Controllare il report degli errori di sincronizzazione MMSSPP giornaliero e correggere eventuali errori segnalati. Dopo la decompressione del file di segnalazione errori, è disponibile un file della Guida allegato e la procedura di correzione per ogni tipo di errore.

  2. Nell'attributo di deprovisioning designato, aggiungere il valore che attiva il deprovisioning delle cassette postali. Non apportare altre modifiche e attendere la rimozione della cassetta postale gestita dall'ambiente Office 365 (il valore dell'attributo homeMDB diventerà null). Questo viene in genere eseguito in uno o due cicli di sincronizzazione MMSSPP.

    1. L'attributo utilizzato per il deprovisioning è diverso per ogni cliente ed è in genere lo stesso valore utilizzato per i valori di provisioning delle cassette postali (ad esempio, una cassetta postale di solito di cui è stato eseguito il provisioning ha extensionAttribute9, MBX, 50 GB; Tipo: EP2D; REG-EU;).

    2. Il valore utilizzato per il deprovisioning è diverso per ogni cliente. Tuttavia, il valore è in genere RemoveMSOMbx (ad esempio, extensionAttribute9-RemoveMSOMbx).

  3. Dopo aver disabilitato la cassetta postale, modificare il valore dell'attributo targetAddress del cliente in modo che punti alla posizione desiderata all'esterno di Office 365D/ITAR (in genere, si tratta di SMTP:sameAsMailValue) e rimuovere l'attributo di deprovisioning. Dopo alcuni cicli di sincronizzazione, l'oggetto è abilitato alla posta elettronica e visibile nell'elenco indirizzi globale.

Scenario 2

Se l'utente dispone di una cassetta postale in Office 365D/ITAR, è necessario eseguire il deprovisioning della cassetta postale e gli oggetti di Office 365D/ITAR devono essere rimossi da Office 365 AD.

  1. Variazione 1: Cliente non dispone della funzionalità di riconnessione automatica dei servizi (ASR) che è abilitata per le riconnessioni delle cassette postali tra foreste. Uno qualsiasi dei seguenti metodi sono efficaci:

    • Spostare l'oggetto utente in un'unità organizzativa (OU) che non rientra nell'ambito di MMSSPP.

    • Impostare il valore appropriato per il filtro MMSSPP. Questo valore viene impostato per ogni cliente sia per l'attributo che per il valore, ma la sua struttura può essere simile a extensionAttribute1-NoSync.

    • Utilizzare il filtro universale per MMSSPP. Questo filtro cancella i valori da tutti gli attributi seguenti:This filter clears values from all the following attributes:

      • Posta

      • Mailnickname

      • Proxyaddresses

      • Targetaddress

    • Eliminare l'oggetto dall'AD del cliente.

  2. Variazione 2: Il cliente dispone della funzionalità Dir che è abilitata per le riconnessioni delle cassette postali tra foreste. In questo caso, gli oggetti che vengono filtrati, spostati o eliminati dal cliente AD causagli oggetti gestiti da spostare in un'unità organizzativa di conservazione (dove sono nascosti dall'elenco indirizzi globale ma ancora ricevere posta) per 1-3 giorni.

    1. Correggere eventuali errori di sincronizzazione.

    2. Aggiungere il valore DeleteNow all'attributo di provisioning delle cassette postali designato e abilitare il completamento di almeno un ciclo di sincronizzazione. Si tratta di un valore di sola gestione temporanea che non attiva il deprovisioning. Indica a MMSSPP che quando il filtro viene applicato per eliminare immediatamente l'oggetto AD gestito anziché mantenerlo nell'unità organizzativa PendingDeletions per 1-3 giorni.

    3. Apportare le modifiche indicate nellaVariante 1 (spostare, applicare il filtro personalizzato, applicare il filtro universale o eliminare).

Scenario 3

Cassetta postale dell'utente è in conservazione per controversia legale. In questo scenario, la cassetta postale di Office 365 è connessa e l'oggetto di Active Directory gestito viene mantenuto. Questo è il processo consigliato per mettere la cassetta postale in uno stato di conservazione per controversia legale inattivo:This is the recommended process for putting the mailbox into an Inactive Litigation Hold state:

  1. Se il processo del cliente consiste nell'eliminare l'oggetto AD dell'utente dopo un certo periodo di tempo, modificare i valori degli attributi mail, targetAddresse smtp proxyAddresses per aggiungere _old o _litHold al prefisso. Ciò consente all'utente di accedere agli indirizzi e-mail e proxy originali quando tornano al lavoro. Apportare queste modifiche all'attributo prima di eseguire i passaggi successivi.

  2. Se è necessario modificare altri servizi, ad esempio Lync, apportare le modifiche appropriate all'attributo.

  3. Aggiungere il valore Type-InHold; all'attributo utilizzato per i valori di provisioning delle cassette postali (questo è diverso per ogni cliente). Utilizzare questo esempio:MBX-50 GB; Tipo: InHold; REG-EU;

  4. Attendere almeno un ciclo di sincronizzazione.

  5. Dopo il tipo di InHold; valore viene sincronizzato con Office 365D/ITAR, l'utente non può più accedere alla cassetta postale. La cassetta postale è nascosta dall'elenco indirizzi globale e i mittenti di tale cassetta postale ricevono un rapporto di mancato recapito).

  6. Dopo aver completato i passaggi da 1 a 5, l'oggetto cliente può essere filtrato, spostato fuori dall'ambito o eliminato.

  7. Se il passaggio 6 viene completato prima di completare i passaggi da 1 a 5, la cassetta postale gestita è ancora inattiva. Tuttavia, ignorare questi passaggi può rendere le query più difficili e rendere più complesso il ripristino dei servizi quando l'utente torna al lavoro.

Scenario 4

È necessario eseguire il deprovisioning dei servizi dedicati/ITAR di Lync:

  1. È possibile eseguire il deprovisioning di Lync indipendentemente dallo stato della cassetta postale impostando un valore pari a 0 nell'attributo selezionato per il provisioning di Lync. Questo è diverso per ogni cliente.

  2. Se la cassetta postale dell'utente è in conservazione per controversia legale, il valore di deprovisioning di Lync pari a 0 deve essere impostato prima che l'oggetto cliente venga filtrato, rimosso dall'ambito o eliminato dall'AD del cliente.

Scenario 5

È necessario eseguire il deprovisioning di un utente abilitato alla posta elettronica (non di un utente abilitato alla cassetta postale) o di un contatto abilitato alla posta elettronica. Tenere presente che gli utenti abilitati alla posta elettronica sono in genere utenti che possono accedere alle risorse di dominio del cliente, ma che ricevono la posta in una cassetta postale esterna all'ambiente Office 365D/ITAR. Queste cassette postali possono trovarsi nell'ambiente locale del cliente o in un servizio esterno. Per disabilitare un utente abilitato alla posta elettronica, utilizzare uno dei seguenti metodi:

  • Spostare l'oggetto utente in un'unità organizzativa che non rientra nell'ambito di MMSSPP.

  • Impostare il valore appropriato per il filtro MMSSPP. Questo valore viene impostato per ogni cliente sia per l'attributo che per il valore, ma la sua struttura può essere simile a extensionAttribute1-NoSync.

  • Utilizzare il filtro universale per MMSSPP. Questo filtro cancella i valori da tutti gli attributi seguenti:This filter clears values from all the following attributes:

    • Posta

    • Mailnickname

    • Proxyaddresses

    • Targetaddress

  • Eliminare l'oggetto dall'AD del cliente.

Scenario 6

È necessario eseguire il deprovisioning di un gruppo abilitato alla posta elettronica. In questo caso, un gruppo di cui viene eseguito il provisioning in Office 365D/ITAR viene rimosso dall'elenco indirizzi globale e Active Directory. Inoltre, viene rimosso come membro di qualsiasi gruppo di cui è membro. Uno dei seguenti metodi è efficace:

  • Cancellare il valore di posta per il gruppo.

  • Eliminare l'oggetto gruppo dall'AD cliente.

Risoluzione

Dopo aver considerato gli scenari appropriati, è possibile correggere uno scenario di deprovisioning non riuscito in uno dei metodi seguenti.

Scenario 1

È necessario eseguire il deprovisioning di una cassetta postale di Office 365D/ITAR e l'utente deve essere abilitato alla posta elettronica (non abilitato alla cassetta postale) in Office 365D/ITAR.

  1. Restituire i valori degli attributi mail e targetAddress ai valori originali necessari per eseguire il provisioning di una cassetta postale di Office 365D/ITAR (ad esempio, il suffisso dell'attributo mail è incluso nell'elenco di inclusione SMTP e il suffisso dell'attributo targetAddress è simile a mgd.customerdomain.com).

  2. Impostare il valore dell'attributo di deprovisioning della cassetta postale (ad esempio, extensionAttribute9-RemoveMSOMbx).

  3. Dopo il deprovisioning della cassetta postale (il cmdlet get-recipient non trova nessuno o il cmdlet get-user restituisce un valore), impostare i valori degli attributi mail e targetAddress sullo stato desiderato per un utente abilitato alla posta elettronica.

Scenario 2

L'utente dispone di una cassetta postale in Office 365D/ITAR, la cassetta postale deve essere deprovisionata e gli oggetti di Office 365D/ITAR devono essere rimossi da Office 365 AD:

  1. Variazione 1: Cliente non dispone della funzionalità di ripristino automatico di sistema che è abilitata per le riconnessioni delle cassette postali tra foreste. Uno qualsiasi dei seguenti metodi è efficace:

    • Spostare l'oggetto utente in un'unità organizzativa che non rientra nell'ambito di MMSSPP.

    • Impostare il valore appropriato per il filtro MMSSPP. Questo valore viene impostato per ogni cliente che ha rispetto sia l'attributo che il valore, ma la sua struttura può essere simile a extensionAttribute1- NoSync.

    • Utilizzare il filtro universale per MMSSPP. Questo filtro cancella i valori da tutti gli attributi seguenti:This filter clears values from all the following attributes:

      • Posta

      • Mailnickname

      • Proxyaddresses

      • Targetaddress

    • Eliminare l'oggetto dall'AD del cliente.

  2. Variazione 2: Il cliente dispone della funzionalità Dir che è abilitata per le riconnessioni delle cassette postali tra foreste. In questo caso, gli oggetti che vengono filtrati, spostati o eliminati dal cliente AD causagli oggetti gestiti da spostare in un'unità organizzativa di conservazione (dove sono nascosti dall'elenco indirizzi globale ma ancora ricevere posta) per 1-3 giorni.

    1. Correggere eventuali errori di sincronizzazione.

    2. Aggiungere il valore DeleteNow all'attributo di provisioning delle cassette postali designato e abilitare il completamento di almeno un ciclo di sincronizzazione. Si tratta di un valore di sola gestione temporanea che non attiva il deprovisioning. Indica a MMSSPP che quando il filtro viene applicato per eliminare immediatamente l'oggetto AD gestito anziché mantenerlo nell'unità organizzativa PendingDeletions per 1-3 giorni.

    3. Apportare le modifiche indicate nella Variante 1 (spostare, applicare il filtro personalizzato, applicare il filtro universale o eliminare).

Scenario 3

Cassetta postale dell'utente è in conservazione per controversia legale.

  1. Non viene eseguito il deprovisioning di una cassetta postale, purché sia in conservazione per controversia legale.

  2. Vedere la sezione "Procedure consigliate" per suggerimenti relativi al processo di spostamento di una cassetta postale in uno stato di conservazione per controversia legale inattivo.

  3. Solo dopo la rimozione di una cassetta postale dal blocco per controversia legale, le azioni nello Scenario 1 o 2 comporteranno il deprovisioning della cassetta postale.

Scenario 4

Cassetta postale dell'utente è in conservazione per controversia legale, ma è in stato inattivo prima di Lync servizi vengono sottoposti a deprovisioning. È necessario eseguire il deprovisioning dei servizi Lync.

  1. Se l'oggetto cliente è ancora nell'ambito di MMSSPP e non è filtrato (la cassetta postale è stata resa inattiva aggiungendo il valore Type-InHold; all'attributo di provisioning), impostare il valore dell'attributo su 0 per l'attributo bitmask di provisioning di Lync. Questo valore comporta il deprovisioning dei servizi Lync dopo alcuni cicli di sincronizzazione. Ad esempio, l'attributodioestensione615 viene modificato in extensionAttribute6-0.

  2. Se la cassetta postale dell'utente è in conservazione per controversia legale e il cliente ha filtrato o rimosso l'oggetto dall'ambito prima del deprovisioning di Lync, è necessario eseguire ulteriori passaggi per eseguire il deprovisioning di Lync:

    1. Con l'oggetto cliente ancora filtrato o al di fuori dell'ambito dell'unità organizzativa, aggiungere il valore Type-InHold; all'attributo di provisioning della cassetta postale (se non è già impostato). Questo è molto importante se la cassetta postale è destinata a rimanere inattiva. Se il valore non viene aggiunto, la cassetta postale viene restituita allo stato attivo (abilitazione dell'accesso e del recapito della posta) non appena viene restituita all'ambito.

    2. Impostare il valore dell'attributo Maschera di bit di Lync su 0.

    3. Rimuovere il filtro o spostare nuovamente l'oggetto cliente nell'ambito dell'unità organizzativa.

    4. Dopo alcuni cicli di sincronizzazione, viene eseguito il deprovisioning dei servizi Lync.

    5. Quando il deprovisioning di Lync viene completato, l'oggetto cliente può essere lasciato invariato, filtrato, rimosso dall'ambito o eliminato in base ai criteri del cliente.

Scenario 5

È necessario eseguire il deprovisioning di un utente abilitato alla posta elettronica (non di un utente abilitato alla cassetta postale) o di un contatto abilitato alla posta elettronica. Per disabilitare un utente abilitato alla posta elettronica, è efficace uno dei seguenti metodi:

  • Spostare l'oggetto utente in un'unità organizzativa esterno all'ambito di MMSSPP.

  • Impostare il valore appropriato per il filtro MMSSPP. Questo valore viene impostato per ogni cliente che ha rispetto sia l'attributo che il valore, ma la sua struttura può essere simile a extensionAttribute1- NoSync.

  • Utilizzare il filtro universale per MMSSPP. Questo filtro cancella i valori da tutti gli attributi seguenti:This filter clears values from all the following attributes:

    • Posta

    • Mailnickname

    • Proxyaddresses

    • Targetaddress

  • Eliminare l'oggetto dall'AD del cliente.

Scenario 6

È necessario eseguire il deprovisioning di un gruppo abilitato alla posta elettronica. In questo caso, un gruppo di cui viene eseguito il provisioning in Office 365D/ITAR viene rimosso dall'elenco indirizzi globale e da Active Directory. Inoltre, viene rimosso come membro di qualsiasi gruppo di cui è membro. Una delle seguenti opzioni è efficace:

  • Cancellare il valore di posta per il gruppo.

  • Eliminare l'oggetto gruppo dall'AD cliente.

Note

  • Dopo aver eseguito il provisioning di un oggetto utente in Office 365D/ITAR, evitare di cancellare il valore dell'attributo mail. La cancellazione dell'attributo non esegue il deprovisioning di una cassetta postale e può rendere i risultati delle query ambigui e le attività di manutenzione di routine inutilmente complesse.

  • Questo documento ha lo scopo di fornire procedure consigliate e semplici procedure di correzione per il deprovisioning dei servizi di posta e Lync negli ambienti Office 365D/ITAR. Altre azioni intraprese dal cliente possono comportare il deprovisioning dei servizi. Per ulteriori informazioni, vedere il Manuale degli strumenti di provisioning di Office 365D/ITAR.

  • Quando viene eseguito il deprovisioning di una cassetta postale, indipendentemente dal metodo, non viene immediatamente eliminato da Office 365D/ITAR. Al contrario, viene mantenuto in uno stato disconnesso per il periodo di conservazione configurato (in genere 30 giorni), durante il quale può essere riconnesso automaticamente (se l'oggetto utente originale viene rimosso o spostato nuovamente nell'ambito MMSSPP) o riconnesso manualmente (tramite un'escalation al servizio di supporto tecnico Microsoft).

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