Risoluzione dei problemi di sincronizzazione Server-Side con Gmail

Importante

Come illustrato qui, a partire dal 30 maggio 2022 Gmail sta terminando il supporto per le app configurate per usare solo il nome utente e la password. Per usare la sincronizzazione lato server con Gmail, seguire la procedura descritta in Connettere gli account Gmail usando OAuth 2.0.

Questo articolo consente di risolvere il problema che si verifica quando una cassetta postale Dynamics 365 è configurata per l'uso della sincronizzazione Server-Side con Gmail.

Si applica a: Microsoft Dynamics 365 Customer Engagement Online
Numero KB originale: 4493342

Sintomi

Quando una cassetta postale Dynamics 365 è configurata per l'uso della sincronizzazione Server-Side con Gmail, la cassetta postale potrebbe non essere testata e abilitata correttamente oppure i messaggi di posta elettronica in arrivo non vengono ricevuti in Dynamics 365.

Causa

Se la cassetta postale non viene testata e abilitata, ciò può essere causato dal fatto che le porte in ingresso o in uscita non vengono configurate correttamente. È necessario configurare un profilo del server di posta elettronica Dynamics 365 per Gmail in modo da usare la porta 995 per l'ingresso e la porta 587 per la posta in uscita. Se la cassetta postale è stata testata e abilitata correttamente, ma i messaggi di posta elettronica non vengono creati in Dynamics 365, questo può verificarsi se non si usa la modalità recente.

Risoluzione

Verificare che il profilo del server di posta elettronica sia configurato per l'uso della porta 995 per l'ingresso e della porta 587 per la posta in uscita. Potrebbe anche essere necessario abilitare l'impostazione seguente:

App meno sicure & l'account Google

Se la cassetta postale viene testata e abilitata correttamente, ma la posta elettronica in arrivo non viene creata in Dynamics 365, provare a usare la modalità recente. Fare riferimento all'articolo seguente ed espandere la sezione: I messaggi di posta elettronica non vengono scaricati correttamente.

Leggere i messaggi Gmail in altri client di posta elettronica tramite POP

È possibile seguire i passaggi indicati nell'articolo precedente per aggiornare l'indirizzo di posta elettronica gmail in Dynamics 365 da includere recent: all'inizio. Esempio: recent:example@gmail.com.