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Sintomi

Si consideri lo scenario seguente:

  • Utilizzare Microsoft System Center Virtual Machine Manager (SCVMM) per creare un cluster di failover di Hyper-V. Gli host Hyper-V in cluster vengono installati con Windows Server 2012 R2 o Windows Server 2008 R2 Service Pack 1 (SP1).

  • Si assegna una risorsa di archiviazione di terze parti al cluster Hyper-V.

  • Creare una macchina virtuale che risiede sul volume di archiviazione di terze parti.

  • SCVMM consente di aggiornare la macchina virtuale.


In questo scenario, si ricevono i messaggi di errore seguente:

Percorso su disco "percorso volume" non è un percorso di archiviazione del cluster o di archiviazione che può essere aggiunto al cluster. È necessario assicurarsi di che questo archivio è disponibile per tutti i nodi del cluster per rendere questa macchina virtuale altamente disponibili.

Errore durante l'aggiunta di un nuovo richiesto di archiviazione per il ruolo della macchina virtuale. La chiave specificata non è presente nel dizionario.

Errore durante l'aggiornamento della configurazione di archiviazione per il ruolo di macchina virtuale "nome della macchina virtuale". La chiave specificata non è presente nel dizionario.

Causa

Questo problema si verifica perché la risorsa di archiviazione di terze parti non dispone di proprietà privata denominata "DiskSignature" o "DiskIdGuid". Pertanto, non viene aggiunto alla macchina virtuale automaticamente quando viene creato.

Risoluzione

Per risolvere questo problema in Windows Server 2012 R2, installare l'aggiornamento 2955164.
Per risolvere questo problema in Windows Server 2008 R2, installare l'hotfix descritto in questo articolo.

Aggiornare le informazioni per Windows Server 2012 R2

Per ulteriori informazioni su come ottenere l'aggiornamento di 2955164, fare clic sul numero seguente per visualizzare l'articolo della Microsoft Knowledge Base:

2955164 Windows RT 8.1, 8.1 di Windows e Windows Server 2012 R2 rollup di aggiornamento: maggio 2014

Informazioni sull'hotfix per Windows Server 2008 R2

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, vi è una sezione "Hotfix Download disponibile" nella parte superiore di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix Download disponibile" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario eseguire Windows Server 2008 R2 Service Pack 1 (SP1). Per ulteriori informazioni su come ottenere un service pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

976932 informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni del Registro di sistema

Per applicare questo hotfix, non è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Potrebbe essere necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.

Note di informazioni file di Windows Server 2008 R2Importante Aggiornamenti rapidi di Windows 7 e aggiornamenti rapidi di Windows Server 2008 R2 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 7 e Windows Server 2008 R2". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .

  • I file relativi a un prodotto, un'attività cardine (RTM, SPn) e un ramo (LDR, GDR specifici) del servizio possono essere identificati esaminando i numeri di versione del file come indicato nella tabella seguente:

    Versione

    Prodotto

    Attività cardine

    Ramo del servizio

    6.1.760
    1.22 xxx

    Windows Server 2008 R2

    SP1

    LDR

  • I rami del servizio GDR contengono solo correzioni rilasciate che risolvono problemi critici diffusi. I rami del servizio LDR contengono hotfix in aggiunta alle correzioni rilasciate.

  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori informazioni sui file per Windows Server 2008 R2". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono fondamentali per mantenere lo stato del componente aggiornato. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.

Per tutte le versioni basate su x64 supportate di Windows Server 2008 R2

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Failoverclusters.objectmodel.dll

6.1.7601.22492

830,976

24-Oct-13

5:31

x64

Clusres.dll

6.1.7601.22492

1,282,560

24-Oct-13

5:21

x64

Failoverclusters.wizards.dll

6.1.7601.22492

659,456

24-Oct-13

5:31

x86

Per tutte le versioni basate su IA-64 supportate di Windows Server 2008 R2

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Failoverclusters.objectmodel.dll

6.1.7601.22492

891,392

24-Oct-13

1:58

IA-64

Clusres.dll

6.1.7601.22492

2,128,896

24-Oct-13

1:51

IA-64

Failoverclusters.wizards.dll

6.1.7601.22492

659,456

24-Oct-13

1:58

x86


Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

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