Si verificano problemi in Outlook quando si tenta di configurare le informazioni sulla disponibilità o quando si tenta di delegare le informazioni

Sintomi

In Microsoft Outlook si verifica uno dei problemi seguenti quando si tenta di configurare le informazioni sulla disponibilità o quando si tenta di delegare le informazioni:

  • Quando si accetta una convocazione di riunione o quando si aggiunge un delegato alla cassetta postale, viene visualizzato il messaggio di errore seguente:

    Impossibile salvare le informazioni sulla disponibilità

  • Quando si usa l'opzione della outlook.exe /cleanfreebusy riga di comando per avviare Outlook, viene visualizzato il messaggio di errore seguente:

    Impossibile pulire le informazioni sulla disponibilità locale.

  • Quando si tenta di aggiungere un delegato, viene visualizzato uno dei messaggi di errore seguenti:

    Le impostazioni delegati non sono state salvate correttamente. Impossibile attivare le informazioni sulla disponibilità.

    Le impostazioni delegati non sono state salvate correttamente. Impossibile attivare l'elenco send-on-behalf-of. Non si dispone di autorizzazioni sufficienti per eseguire questa operazione su questo oggetto.

  • Quando si tenta di aprire un elemento del calendario condiviso, viene visualizzato il messaggio di errore seguente:

    Non è possibile aprire questo elemento. Impossibile aprire le informazioni sulla disponibilità

    Inoltre, l'evento seguente viene registrato nel registro applicazioni nel computer client di Outlook:

    Tipo evento: Avviso
    Origine evento: Outlook
    Categoria di eventi: Nessuna
    ID evento: 25
    Data: data
    Ora: ora
    Utente: N/D
    Computer: Computer_name
    Descrizione:
    Impossibile salvare le informazioni sulla disponibilità. Impossibile aprire le informazioni sulla disponibilità.

  • Quando un delegato tenta di creare un elemento nel calendario condiviso o nel calendario di gestione, il delegato riceve il messaggio di errore seguente:

    Impossibile aprire le informazioni sulla disponibilità

Causa

Questi problemi si verificano perché una proprietà della cassetta postale non fa riferimento correttamente a un messaggio nascosto nella cassetta postale. Il messaggio nascosto contiene informazioni correlate a una delle funzionalità seguenti:

  • pubblicazione della disponibilità
  • Delegato
  • prenotazione diretta

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti per forzare la rigenerazione delle informazioni nascoste sulla disponibilità nella cassetta postale.

I passaggi descritti in questa sezione devono essere applicati alla cassetta postale dell'utente proprietario della cartella Calendario. Si tratta della cassetta postale in cui si tenta di creare gli elementi del calendario, usare l'opzione /cleanfreebusy o configurare le impostazioni dei delegati.

Nota

L'opzione /cleanfreebusy non è disponibile in Outlook 2016 e versioni successive. È invece possibile usare l'opzione /cleanroamedprefs .

Dopo aver seguito questi passaggi, potrebbe essere necessario riconfigurare le impostazioni correlate ai delegati e alle funzionalità di prenotazione diretta.

Metodo 1: usare il cmdlet di PowerShell

È necessario disporre dell'autorizzazione di amministratore per eseguire i cmdlet di PowerShell per eliminare la configurazione della disponibilità nella cassetta postale e quindi aggiungere o ricreare le autorizzazioni delegate necessarie:

  1. Eseguire il cmdlet seguente per esportare le autorizzazioni correnti per la cartella Calendar, che potrebbero essere necessarie per ricreare le impostazioni di autorizzazione dei delegati:

    Get-MailboxFolderPermission -Identity <alias>:\Calendar
    
  2. Eseguire il cmdlet di PowerShell seguente sulla cassetta postale di destinazione:

    Remove-MailboxFolderPermission -Identity <alias>:\Calendar -ResetDelegateUserCollection
    

    Nota

    Per altre informazioni sul parametro ResetDelegateUserCollection, vedere Remove-MailboxFolderPermission.

  3. Eseguire il cmdlet seguente una o più volte, se necessario, per aggiungere o ricreare le autorizzazioni delegate necessarie:

    Add-MailboxFolderPermission -Identity <alias>:\Calendar -User <delegate alias> -SharingPermissionFlag Delegate
    

Metodo 2: Usare lo strumento MFCMAPI

attenersi alla seguente procedura:

  1. Chiudere Outlook.

  2. Assicurarsi che esista un profilo (preferibilmente configurato per la modalità online ) per la cassetta postale.

    Nota

    Se non esiste alcun profilo per la cassetta postale, usare l'elemento Posta in Pannello di controllo per crearlo.

  3. Scaricare lo strumento MFCMAPI.

  4. Avviare il programma MFCMapi.exe scaricato e quindi selezionare OK.

  5. Se il profilo è configurato per la modalità cache , seguire questa procedura per forzare temporaneamente la modalità online all'interno di MFCMAPI:

    1. Nel menu File, fare clic su Opzioni.
    2. Abilitare le due opzioni seguenti e quindi selezionare OK.
    • Utilizzare il contrassegno MDB_ONLINE quando si chiama OpenMsgStore.
    • Utilizzare il flag MAPI_NO_CACHE quando si chiama OpenEntry
  6. Nel menu Sessione, selezionare Accesso.

  7. Nell'elenco Nome profilo, selezionare il profilo per la cassetta postale e poi selezionare OK.

  8. 8Doppia clic sull'archivio messaggi di Microsoft Exchange appropriato.

  9. Nel riquadro di spostamento selezionare Contenitore radice.

  10. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su PR_FREEBUSY_ENTRYIDS, selezionare Elimina proprietà e quindi scegliere OK.

  11. Nel riquadro di spostamento espandere Contenitore radice, Espandere Top of Information Store e quindi selezionare Posta in arrivo

    Nota

    La parte superiore di Information Store potrebbe essere localizzata in un'altra lingua a seconda delle impostazioni internazionali della cassetta postale.

  12. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su PR_FREEBUSY_ENTRYIDS, selezionare Elimina proprietà e quindi scegliere OK.

  13. Eliminare il messaggio LocalFreeBusy attenendosi alla procedura seguente:

    1. Nel riquadro di spostamento espandere Contenitore radice.
    2. Fare doppio clic su Dati freebusy.
    3. Nel riquadro superiore trovare l'elemento con l'oggetto LocalFreebusy. Fare clic con il pulsante destro del mouse e quindi scegliere Elimina messaggio.
    4. Per Stile eliminazione selezionare Eliminazione permanente passando DELETE_HARD_DELETE (irrecuperabile) e quindi selezionare OK.
  14. Nel riquadro di spostamento selezionare Top of Information Store Inbox (Parte superiore dellaposta in arrivo dell'Archivio > informazioni).

  15. Scegliere Altre tabelle dal menu Azioni e quindi selezionare Tabella regole.

  16. Trovare la regola la cui opzione PR_RULE_PROVIDER è impostata su SCHEDULE+ EMS Interface e quindi eliminarla.

  17. Uscire da MFCMAPI.

Nota

Potrebbe essere necessario rimuovere manualmente e aggiungere nuovamente i delegati in Outlook usandole impostazioni> dell'account file>Delega accesso.

Riconfigurare le autorizzazioni dei delegati e la prenotazione diretta

Se si dispone di impostazioni personalizzate correlate alla funzionalità delegati o alla funzionalità di prenotazione diretta, seguire i passaggi appropriati.

Per la funzionalità delegati

  1. Avviare Outlook.
  2. Nella scheda File selezionare Impostazioni account e quindi selezionare Delega accesso.
  3. Selezionare il delegato da riconfigurare e quindi selezionare Autorizzazioni.
  4. Fare clic per selezionare le opzioni desiderate nella finestra di dialogo Delega autorizzazioni e quindi selezionare OK.
  5. Ripetere i passaggi 3 e 4 per tutti i delegati.
  6. Selezionare OK.
  7. Nella scheda File selezionare Esci.

Per la funzionalità di prenotazione diretta

  1. Avviare Outlook.
  2. Nella scheda File selezionare Opzioni e quindi selezionare Calendario.
  3. In Outlook 2016 o 2013 selezionare Accetta/Rifiuta automaticamente oppure in Outlook 2010 selezionare Pianificazione risorse.
  4. Fare clic per selezionare le caselle di controllo desiderate.
  5. Selezionare due volte OK.
  6. Nel menu File, selezionare Esci.