Si verificano problemi in Outlook quando si prova a configurare le informazioni sulla disponibilità o quando si prova a delegare le informazioni

Sintomi

In Microsoft Outlook si verifica uno dei problemi seguenti quando si prova a configurare le informazioni sulla disponibilità o quando si prova a delegare le informazioni:

  • Quando si accetta una convocazione di riunione o si aggiunge un delegato alla cassetta postale, viene visualizzato il messaggio di errore seguente:

    Non è possibile salvare le informazioni sulla disponibilità

  • Quando si usa l'outlook.exe della riga di comando /cleanfreebusy per avviare Outlook, viene visualizzato il messaggio di errore seguente:

    Non è possibile pulire le informazioni sulla disponibilità locali.

  • Quando si prova ad aggiungere un delegato, viene visualizzato uno dei messaggi di errore seguenti:

    Le impostazioni delegati non sono state salvate correttamente. Impossibile attivare le informazioni sulla disponibilità.

    Le impostazioni delegati non sono state salvate correttamente. Impossibile attivare l'elenco send-on-behalf-of. Non si hanno autorizzazioni sufficienti per eseguire questa operazione su questo oggetto.

  • Quando si prova ad aprire un elemento del calendario condiviso, viene visualizzato il messaggio di errore seguente:

    Non è possibile aprire questo elemento. Non è possibile aprire le informazioni sulla disponibilità

    Inoltre, l'evento seguente viene registrato nel log dell'applicazione nel computer client Outlook client:

  • Quando un delegato prova a creare un elemento nel calendario condiviso o nel calendario del responsabile, il delegato riceve il messaggio di errore seguente:

    Non è possibile aprire le informazioni sulla disponibilità

  • Viene visualizzato il messaggio di errore seguente quando si prova ad aggiungere un delegato in Outlook:

    Le impostazioni dei delegati non sono state salvate correttamente. Impossibile attivare le informazioni sulla disponibilità.


  • Viene visualizzato il messaggio di errore seguente quando si prova ad aggiungere un delegato in Outlook:

    Le impostazioni dei delegati non sono state salvate correttamente. Impossibile attivare le informazioni sulla disponibilità.



Causa

Questi problemi si verificano perché una proprietà della cassetta postale non fa correttamente riferimento a un messaggio nascosto nella cassetta postale. Il messaggio nascosto contiene informazioni correlate a una delle caratteristiche seguenti:

  • pubblicazione delle informazioni sulla disponibilità

  • delegato

  • prenotazione diretta


Risoluzione


Per risolvere il problema, forzare la rigenerazione delle informazioni sulla disponibilità nascoste nella cassetta postale.

Note

  • Dopo aver seguito i passaggi descritti in questa sezione, potrebbe essere necessario riconfigurare le impostazioni correlate alle caratteristiche seguenti:

    • Pubblicazione delle informazioni sulla disponibilità

    • Delegati

    • Prenotazione diretta

  • I passaggi descritti in questa sezione devono essere applicati alla cassetta postale dell'utente proprietario della cartella Calendario. Questa è la cassetta postale in cui si tenta di creare gli elementi del calendario, usare l'opzione /cleanfreebusy o configurare le impostazioni dei delegati.


Per forzare la rigenerazione delle informazioni sulla disponibilità nascoste nella cassetta postale, seguire questa procedura:

  1. Chiudere Outlook.

  2. Verificare che sia presente un profilo in modalità online per la cassetta postale.

    Nota Se non è presente alcun profilo in modalità online, usare l'elemento Posta nel Pannello di controllo per creare un profilo in modalità online per la cassetta postale.

  3. Scaricare lo strumento MFCMapi. A questo scopo, visitare il seguente sito Web Microsoft:

    https://github.com/stephenegriffin/mfcmapi

  4. Avviare il MfcMapi.exe scaricato e quindi fare clic su OK.

  5. Scegliere Opzioni dal menu Strumenti.

  6. Fare clic per abilitare le caselle di controllo le due opzioni seguenti e quindi fare clic su OK.

    • Usare il flag MDB_ONLINE quando si chiama Open MsgStore

    • Usare il contrassegno MAPI_NO_CACHE quando si chiama OpenEntry

  7. Nel menu Session (Sessione) fare clic su Logon (Accesso).

  8. Nell'elenco Nome profilo selezionare il profilo per la cassetta postale e quindi fare clic su OK.

  9. Fare doppio clic sull'archivio messaggi di Microsoft Exchange appropriato.

  10. Nel riquadro di spostamento fare clic su Contenitore radice.

  11. Nel riquadro dei dettagli fare clic con il pulsante destro del PR_FREEBUSY_ENTRYIDS,scegliere Elimina proprietàe quindi fare clic su OK.

  12. Nel riquadro di spostamento espandere Contenitore radice,Espandere La parte superiore dell'archivio informazioni e quindi fare clic su Posta in arrivo.

Nota:la parte superiore dell'archivio informazioni potrebbe essere localizzata in un'altra lingua a seconda delle impostazioni internazionali della cassetta postale.

  1. Nel riquadro dei dettagli fare clic con il pulsante destro del PR_FREEBUSY_ENTRYIDS,scegliere Elimina proprietàe quindi fare clic su OK.

  2. Pulire i dati sulla disponibilità locali. A questo scopo, seguire la procedura per la versione di Outlook.

    Outlook 2013 e versioni

    successive: Outlook 2010 e versioni precedenti:

    1. Nel riquadro di spostamento espandere Contenitore radice.

    2. Fare doppio clic su Freebusy Data.

    3. Nel riquadro superiore trovare l'elemento con Oggetto di LocalFreebusy. Fare clic con il pulsante destro del mouse su di esso e quindi scegliere Elimina messaggio.

    4. Per Stile di eliminazione, selezionare Elimina definitivamente DELETE_HARD_DELETE (non irreversibile)e quindi fare clic su OK.

    5. Premere Windows tasto + R per aprire una finestra di dialogo Esegui. Digitare outlook.exe /cleanfreebusy e quindi fare clic su OK.

  3. Chiudere tutte le finestre di MFCMapi.

Passaggi aggiuntivi

Outlook 2010 e versioni successive

Per la caratteristica di pubblicazione sulla disponibilità
  1. Avviare Outlook.

  2. Nella scheda File fare clic su Opzioni e quindi su Calendario.

  3. Fare clic su Opzioni disponibilità e quindi su Altre informazioni sulla disponibilità.

  4. Nella finestra di dialogo Opzioni disponibilità modificare l'impostazione Pubblica< x> mese/i delle informazioni sulla disponibilità del calendario su un valore diverso da quello corrente.

    NotaSe non si modifica il valore dell'impostazione Pubblica mese/i delle informazioni sulla disponibilità del calendario, Outlook non aggiorna le informazioni sulla disponibilità nascoste. 

  5. Fare clic tre volte su OK.

  6. Nella scheda File fare clic su Esci.

Per la funzionalità delegati
  1. Avviare Outlook.

  2. Nella scheda File fare clic su Account Impostazionie quindi su Delega accesso.

  3. Selezionare il delegato da riconfigurare e quindi fare clic su Autorizzazioni.

  4. Fare clic per selezionare le opzioni desiderate nella finestra di dialogo Autorizzazioni delegato e quindi fare clic su OK.

  5. Ripetere i passaggi 3 e 4 per tutti i delegati.

  6. Scegliere OK.

  7. Nella scheda File fare clic su Esci.

Per la funzionalità di prenotazione diretta
  1. Avviare Outlook.

  2. Nella scheda File fare clic su Opzioni e quindi su Calendario.

  3. In Outlook 2016 2013 fare clic su Accetta/Rifiutaautomaticamente oppure in Outlook 2010 fare clic su Pianificazione risorse.

  4. Fare clic per selezionare le caselle di controllo desiderate.

  5. Fare clic su OK due volte.

  6. Scegliere Esci dal menu File.

Outlook 2007 e Outlook 2003


Se si hanno impostazioni personalizzate correlate alla caratteristica di pubblicazione sulla disponibilità, alla funzionalità delegati o alla funzionalità di prenotazione diretta, seguire la procedura appropriata.

Per la caratteristica di pubblicazione sulla disponibilità
  1. Avviare Outlook.

  2. Nel menu Strumenti fare clic su Opzioni.

  3. Fare clic sulla scheda Preferenze e quindi su Opzioni calendarionell'area Calendario.

  4. Fare clic su Opzioni disponibilità nell'area Opzioni avanzate.

  5. Nell'area Opzioni modificare il valore di Pubblicazione mese/i delle informazioni sulla disponibilità del calendario nel server impostando un valore diverso da quello corrente.

    Nota Se non si modificano i mesi di pubblicazione delle informazioni sulla disponibilità del calendario nel server, Outlook non aggiorna le informazioni sulla disponibilità nascoste.

  6. Fare clic tre volte su OK.

  7. Scegliere Esci dal menu File.

Per la funzionalità delegati
  1. Avviare Outlook.

  2. Scegliere Opzioni dal menu Strumenti equindi fare clic sulla scheda Delegati.

  3. Selezionare il delegato da riconfigurare e quindi fare clic su Autorizzazioni.

  4. Fare clic per selezionare le caselle di controllo desiderate nella finestra di dialogo Autorizzazioni delegato.

  5. Ripetere i passaggi 3 e 4 per tutti i delegati.

  6. Fare due volte clic su OK.

  7. Scegliere Esci dal menu File.

Per la funzionalità di prenotazione diretta
  1. Avviare Outlook.

  2. Nel menu Strumenti fare clic su Opzioni.

  3. Fare clic sulla scheda Preferenze e quindi su Opzioni calendarionell'area Calendario.

  4. Nell'area Opzioni avanzate fare clic su Programmazione risorsee quindi fare clic per selezionare le caselle di controllo desiderate nella finestra di dialogo Pianificazione risorse.

  5. Fare clic tre volte su OK.

  6. Scegliere Esci dal menu File.

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