Un appuntamento viene annullato o eliminato in modo imprevisto durante la sincronizzazione sul lato server

Questo articolo fornisce una soluzione a un problema per cui un appuntamento viene annullato o eliminato in modo imprevisto quando si usa la sincronizzazione sul lato server.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4345686

Sintomi

Quando si usa la sincronizzazione lato server per sincronizzare gli appuntamenti tra Microsoft Dynamics 365 ed Exchange, un appuntamento viene annullato o eliminato in modo imprevisto.

Causa

Questo problema può verificarsi se l'appuntamento non soddisfa più le condizioni dei filtri di sincronizzazione dell'utente. Come indicato in Ignora elementi eliminati logicamente durante la sincronizzazione, esistono diversi motivi per cui un appuntamento potrebbe non corrispondere più ai filtri di sincronizzazione, ad esempio l'organizzatore dell'appuntamento da modificare, i filtri di sincronizzazione modificati o l'utente che non ha più accesso al record a causa di modifiche nei ruoli di sicurezza o nella condivisione. Per impostazione predefinita, la sincronizzazione lato server invia un'operazione di eliminazione a Exchange in questo scenario, con conseguente annullamento di un appuntamento.

Risoluzione

È stata introdotta un'impostazione configurabile per consentire di modificare questo comportamento. È possibile usare uno degli strumenti seguenti per modificare l'impostazione DistinctPhysicalAndLogicalDeletesForExchangeSync su True:

  1. Impostazioni organizzazione Editor
  2. Strumento OrgDBOrgSettings per Microsoft Dynamics CRM