Impossibile creare un messaggio di posta elettronica in Microsoft Dynamics 365 con un errore di sincronizzazione NoCorrelationMatch
Questo articolo fornisce una soluzione per il problema che non è possibile creare un messaggio di posta elettronica in Microsoft Dynamics 365 con un errore di sincronizzazione NoCorrelationMatch.
Si applica a: Microsoft Dynamics 365
Numero KB originale: 4339713
Sintomi
Quando si esaminano i messaggi di posta elettronica analizzati per la promozione automatica da Microsoft Dynamics 365, viene visualizzato un messaggio di posta elettronica che non è stato possibile creare in Microsoft Dynamics 365 con un errore di sincronizzazione NoCorrelationMatch.
Causa
Quando Microsoft Dynamics 365 valuta un messaggio di posta elettronica nella cassetta postale, vengono valutate più condizioni per determinare se il messaggio deve essere creato automaticamente come attività di posta elettronica in Microsoft Dynamics 365. Alcune delle condizioni valutate si basano sulle caratteristiche del messaggio di posta elettronica, ad esempio gli indirizzi di posta elettronica in From, To e Cc e se il messaggio di posta elettronica è una risposta a un messaggio di posta elettronica inviato inizialmente da Microsoft Dynamics 365. L'opzione personale per il rilevamento della posta elettronica influisce anche sui messaggi di posta elettronica monitorati automaticamente. Se la valutazione genera un errore NoCorrelationMatch , indica che non sono stati configurati utenti o code per alzare di livello automaticamente il messaggio di posta elettronica.
Ad esempio: un messaggio di posta elettronica viene ricevuto dall'utente Christoper Reed da uno dei contatti di Christoper. Se le opzioni personali di Christoper in Microsoft Dynamics 365 sono configurate con l'impostazione predefinita per tenere traccia solo dei messaggi Email in risposta al messaggio di posta elettronica di Microsoft Dynamics 365, il messaggio di posta elettronica verrà registrato automaticamente solo se il messaggio di posta elettronica è una risposta a un messaggio di posta elettronica inviato da Microsoft Dynamics 365.
Risoluzione
Esaminare le caratteristiche del messaggio di posta elettronica e l'opzione configurata nelle opzioni personali per il rilevamento della posta elettronica. Per visualizzare o modificare l'impostazione di rilevamento della posta elettronica:
- Accedere alle opzioni personali in Microsoft Dynamics 365 selezionando le impostazioni (l'icona a ingranaggio nell'angolo in alto a destra) e quindi selezionando Opzioni.
- Selezionare la scheda Email.
- Nella sezione Selezionare i messaggi di posta elettronica da tenere traccia in Microsoft Dynamics 365 individuare l'impostazione Traccia.
- Modificare l'opzione in base alle esigenze per controllare quali messaggi di posta elettronica devono essere registrati automaticamente in Microsoft Dynamics 365.
Ad esempio: se vuoi tenere traccia automaticamente di tutti i messaggi di posta elettronica inviati dai tuoi lead, contatti o account, seleziona l'opzione Email messaggi da Microsoft Dynamics 365 Lead, Contatti e Account. Se si desidera che ogni messaggio di posta elettronica ricevuto, indipendentemente dal mittente, venga creato automaticamente come attività di posta elettronica in Microsoft Dynamics 365, selezionare l'opzione Tutti i messaggi di posta elettronica.
Nota
Un risultato NoCorrelationMatch può anche essere causato dalla disabilitazione dell'opzione Usa correlazione per tenere traccia delle conversazioni di posta elettronica . È possibile visualizzare questa impostazione nella scheda Email in Impostazioni di sistema.
Per altre informazioni sulla correlazione tramite posta elettronica, vedere Email filtro e correlazione dei messaggi.
Commenti e suggerimenti
https://aka.ms/ContentUserFeedback.
Presto disponibile: nel corso del 2024 verranno dismessi i problemi di GitHub come meccanismo di feedback per il contenuto e verranno sostituiti con un nuovo sistema di feedback. Per altre informazioni, vedere:Invia e visualizza il feedback per