Sintomi
Dopo aver installato il servizio ruolo Server di stampa su un computer che esegue Windows Server 2008, è possibile utilizzare solo un account utente di amministratore per eseguire determinate operazioni che riguardano la stampa. Queste attività includono l'installazione delle code di stampa locale, delle porte di stampa locale e dei driver di stampante locale.
Causa
Un controllo a livello di codice impedisce che gli utenti del dominio utilizzando la maggior parte delle attività correlate alla stampa.
Risoluzione
Dopo avere installato questo hotfix, si dispone di un nuovo
Scheda di protezione nelle proprietà del Server di stampa. Su questo Scheda protezione , è possibile utilizzare l'account Administrator per assegnare l'autorizzazione utente di dominio per eseguire le attività correlate alla stampa. Dopo avere installato questo hotfix, esistono diverse limitazioni. Queste limitazioni sono i seguenti:-
Un utente delegato è possibile installare solo i driver di stampa che sono già nell'archivio driver.
-
Un utente delegato non può installare un driver di stampa dall'archivio driver in modalità remota.
-
Un utente delegato non può installare un driver di stampa dall'archivio driver in un cluster spooler.
-
Un utente delegato non può installare una coda di stampa in modalità remota e non è in grado di aggiungere una stampante in modalità remota da un computer che esegue Windows XP.
Nota: Se l'utente delegato utilizza un computer che esegue Windows 7 o Windows Vista, l'utente delegato può installare una coda di stampa in remoto e aggiunta una stampante in modalità remota.
Nota: Per impostazione predefinita, un utente delegato non dispone dell'autorizzazione per gestire le stampanti installate nel server di stampa. Tuttavia, dopo aver assegnato un'autorizzazione delegata al server di stampa, tale utente non richiede un'ulteriore autorizzazione per gestire tutte le stampanti che vengono aggiunti in un secondo momento.
Informazioni sull'hotfix
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.
Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix. Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:http://support.microsoft.com/contactus/? ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua. Importanti aggiornamenti rapidi di Windows Vista e Windows Server 2008 sono inclusi nel pacchetto stesso. Tuttavia, solo uno di questi prodotti può essere elencato nella pagina "Richiesta di aggiornamento rapido". Per richiedere il pacchetto di hotfix che si applica a Windows Vista e Windows Server 2008, è sufficiente selezionare il prodotto elencato nella pagina.
Prerequisiti
Per applicare questo hotfix, è necessario essere il computer sia in esecuzione uno dei seguenti sistemi operativi:
-
Windows Server 2008
-
Windows Server 2008 Service Pack 2 (SP2)
Richiesta di riavvio
Dopo avere applicato questo hotfix, è necessario riavviare il computer.
Informazioni del Registro di sistema
Non è necessario apportare modifiche al Registro di sistema.
Informazioni sui file
La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Per tutte le versioni basate su x86 supportate di Windows Server 2008
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
Requisiti SP |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6001.22467 |
637,440 |
10-Jul-2009 |
11:59 |
x86 |
SP1 |
Printui.dll |
6.0.6001.22467 |
873,472 |
10-Jul-2009 |
11:59 |
x86 |
SP1 |
Per tutte le versioni basate su x86 supportate di Windows Server 2008 SP2
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
Requisiti SP |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6002.22169 |
624,128 |
10-Jul-2009 |
11:48 |
x86 |
SP2 |
Printui.dll |
6.0.6002.22169 |
873,472 |
10-Jul-2009 |
11:49 |
x86 |
SP2 |
Per tutte le versioni basate su Itanium di Windows Server 2008 supportate
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
Requisiti SP |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6001.22467 |
1,624,576 |
10-Jul-2009 |
11:56 |
IA-64 |
SP1 |
Printui.dll |
6.0.6001.22467 |
1,648,640 |
10-Jul-2009 |
11:57 |
IA-64 |
SP1 |
Per tutte le versioni basate su Itanium di Windows Server 2008 SP2
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
Requisiti SP |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6002.22169 |
1,624,576 |
10-Jul-2009 |
11:40 |
IA-64 |
SP2 |
Printui.dll |
6.0.6002.22169 |
1,648,640 |
10-Jul-2009 |
11:42 |
IA-64 |
SP2 |
Per tutte le versioni basate su x64 supportate di Windows Server 2008
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
Requisiti SP |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6001.22467 |
793,088 |
10-Jul-2009 |
12:26 |
x64 |
SP1 |
Printui.dll |
6.0.6001.22467 |
987,136 |
10-Jul-2009 |
12:26 |
x64 |
SP1 |
Per tutte le versioni basate su x64 supportate di Windows Server 2008 SP2
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
Requisiti SP |
---|---|---|---|---|---|---|
Localspl.dll |
6.0.6002.22169 |
774,144 |
10-Jul-2009 |
11:54 |
x64 |
SP2 |
Printui.dll |
6.0.6002.22169 |
987,136 |
10-Jul-2009 |
11:55 |
x64 |
SP2 |
Ulteriori informazioni
Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
940724 i membri del gruppo Power Users e del gruppo Print Operators non possono installare stampanti locali su un server membro basato su Windows Server 2003 Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
Stato
Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".