Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Informazioni di supporto interne di Microsoft

BUG #: 56500 (manutenzione del contenuto)

Informazioni di supporto interne di Microsoft

BUG #: 183877 (WindowsSE)

Sintomi

Si consideri il seguente scenario. Utilizzare lo strumento di molte (Ktpass.exe) per creare un file di keytab di Kerberos in Microsoft Windows Server 2003 Service Pack 1 (SP1)-basata su computer. Quando si utilizza il protocollo Lightweight Directory Access Protocol (LDAP) tramite una connessione Security Sockets Layer (SSL), lo strumento molte non imposta la password dell'account correttamente in Active Directory. Quando si utilizzano quindi i file keytab che sono stati creati utilizzando lo strumento molte, si verificano errori di pre-autenticazione.

Causa

Questo problema si verifica a causa di un problema con lo strumento molte incluso in Windows Server 2003 SP1. Lo strumento molte non reimposta la password correttamente utilizzando LDAP su SSL.

Lo strumento molte sali la password in modo non corretto durante la generazione di keytabs per gli account computer. Lo strumento molte utilizza la parte del nome host dell'attributo servicePrincipalName invece dell'attributo samAccountName che utilizza il centro distribuzione chiave (KDC) per il salting della password. I file keytab generato in modo non corretto che vengono creati utilizzando sali non corretti causano l'errore di autenticazione.

Risoluzione

Informazioni sul Service pack

Per risolvere questo problema, procurarsi il service pack più recente per Windows Server 2003. Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Il computer deve essere in esecuzione Windows Server 2003 SP1 per installare questo hotfix.

Richiesta di riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di data e ora nel Pannello di controllo.

Windows Server 2003, versione basati su Itanium

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Ktpass.exe

5.2.3790.2732

320,000

23-Jun-2006

20:14

IA-64

Windows Server 2003, versione basata su x64

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Ktpass.exe

5.2.3790.2732

145,920

23-Jun-2006

20:13

x64

Windows Server 2003, versione basata su x86

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Ktpass.exe

5.2.3790.2732

91,136

23-Jun-2006

20:13

x86

Stato

Microsoft ha confermato che si tratta di un problema nei prodotti Microsoft elencati nella sezione "Si applica a". Il problema è stato risolto in Windows Server 2003 Service Pack 2.

Ulteriori informazioni

Per ulteriori informazioni sulla descrizione della terminologia utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×