Non è possibile accedere a Skype for Business Online perché il certificato non può essere acquisito o convalidato

Problema

Quando un utente di Microsoft 365 tenta di accedere a Skype for Business Online (in precedenza Lync Online) usando Lync 2010 o Lync 2013, l'utente riceve il messaggio di errore seguente:

There was a problem acquiring a personal certificate required to sign in. If the problem continues, please contact your support team.

Inoltre, quando si tenta di accedere a Lync dopo un'interruzione di rete o un'interruzione del servizio online Skype for Business, viene visualizzato il messaggio di errore seguente:

Cannot sign into Lync. There was a problem verifying the certificate from the server.

Causa

Questo problema può verificarsi se si verificano una o più delle condizioni seguenti:

  • Il software non è aggiornato.

    • Il client Lync non è aggiornato.
    • Microsoft Online Services Sign-In Assistant non è aggiornato.
  • I certificati non possono essere acquisiti o convalidati.

    • Il certificato personale Skype for Business Online o le credenziali memorizzate nella cache sono danneggiate o non aggiornate.
    • Parte della catena di certificati non è attendibile e la catena di certificati non riesce.

Soluzione

Risoluzione per Lync 2013

Eliminare le informazioni di accesso

Durante il processo di accesso, Lync 2013 memorizza nella cache le credenziali e altre informazioni sulla connessione a Skype for Business Online. Se si verificano problemi di accesso a Skype for Business Online, fare clic su Elimina le informazioni di accesso e Lync 2013 rimuove automaticamente eventuali password, certificati e impostazioni di connessione salvati per l'account utente.

Screenshot che mostra la pagina di accesso di Lync 2013 con l'opzione Elimina informazioni di accesso selezionata.

Risoluzione per Lync 2010

  1. Aggiornare il client Lync alla versione più recente disponibile nella pagina Download del portale di Microsoft 365.

  2. Assicurarsi che Microsoft Online Services Sign-in Assistant sia in esecuzione in Servizi Windows seguendo questa procedura:
    (Questi passaggi sono per Windows 10)

    1. Fare clic con il pulsante destro del mouse sul pulsante Start e scegliere Esegui.
    2. Digitare services.msc e selezionare OK.
    3. Nella finestra Servizi controllare se lo statodell'Assistente per l'accesso a Microsoft Online Services è elencato come In esecuzione.
  3. Cancellare i certificati, le credenziali e le connessioni memorizzati nella cache.

Procedura di risoluzione dei problemi aggiuntiva per Lync 2013 e Lync 2010

Nota

Seguire attentamente i passaggi in questa sezione. L'errata modifica del Registro di sistema può causare seri problemi. Prima di apportare le modifiche, eseguire il backup del Registro di sistema per il ripristino nel caso si verifichino dei problemi.

Se i passaggi precedenti in questo articolo non consentono di risolvere il problema, provare i metodi seguenti, in base alle esigenze specifiche:

  • Quando Lync si connette a un server front-end specifico, memorizza nella cache tale endpoint per velocizzare il processo di accesso in futuro. Tuttavia, a volte l'endpoint può essere modificato e può causare l'esito negativo dell'accesso. Per eliminare la cache degli endpoint, seguire questa procedura:

    1. Individuare la cartella dei dati dell'applicazione locale:
      • Windows Vista, Windows 7 e Windows 8 (escluso Windows 8 RT):

        %LOCALAPPDATA%\Microsoft\Communicator<sip_address@contoso.com>\

    • Windows XP:

      %USERPROFILE%\Local Settings\Application Data\Microsoft\Communicator<sip_address@contoso.com>\

    1. Eliminare la cartella associata all'indirizzo di accesso.
    2. Riavviare Lync e quindi provare ad accedere a Skype for Business Online.
  • Se si usa Lync 2010, eliminare il certificato personale Skype for Business Online e quindi scaricarne uno nuovo. Tenere presente che quando l'utente fa clic su Salva password in Lync 2010, questa azione salva anche il certificato in Gestione certificati Windows.

    Per eliminare un certificato personale, seguire questa procedura:

    1. Eliminare il certificato in Gestione certificati Windows. A tal fine, attenersi alla seguente procedura:
      1. Aprire Gestione certificati di Windows. A tale scopo, premere Windows + R, digitare certmgr.msc e quindi fare clic su OK.
      2. Espandere Personale e quindi Certificati.
      3. Ordinare in base alla colonna Emesso da e quindi cercare un certificato emesso da Communications Server.
      4. Verificare che il certificato sia presente e che sia ancora valido.
      5. Eliminare il certificato e provare ad accedere a Skype for Business Online. Se non è possibile accedere a Skype for Business Online, andare al passaggio 2.
    2. Se si esegue Windows 7, rimuovere le credenziali archiviate dall'utente in Windows Credential Manager. A tal fine, attenersi alla seguente procedura:
      1. Aprire Pannello di controllo e quindi fare clic su Gestione credenziali.

      2. Individuare il set di credenziali usato per connettersi a Skype for Business Online.

      3. Espandere il set di credenziali e quindi selezionare Rimuovi dall'insieme di credenziali.

      4. Provare di nuovo ad accedere a Skype for Business Online e quindi digitare il nuovo set di credenziali.

        Nota

        Questi passaggi non sono necessari in Lync 2013 perché i passaggi indicati in precedenza che eliminano le informazioni di accesso rimuove automaticamente i certificati.

  • Scaricare la cache DNS. A tal fine, attenersi alla seguente procedura:

    1. Premere Windows + R, digitare il comando seguente e quindi premere INVIO:

      Ipconfig /flushdns

  • Avviso È possibile che si verifichino problemi gravi se si modifica il Registro di sistema in modo errato usando l'editor del Registro di sistema o un altro metodo. che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di tali problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

    Nei computer interessati controllare la chiave del Registro di sistema seguente:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\MachineGuid

    Se il valore di MachineGuid contiene parentesi graffe intorno al GUID (ad esempio, {c1cbd94c-0d35-414c-89ef-dd092b984883}), rimuovere le parentesi graffe, riavviare Lync e quindi provare di nuovo ad accedere.

Risoluzione per gli amministratori di Skype for Business Online: convalidare la catena di certificati

Gli utenti finali possono ricevere un errore che indica che il certificato non può essere convalidato e questo accade in genere perché uno dei certificati nella catena non è attendibile e non può essere convalidato. Ciò si verifica in genere per i clienti che usano l'accesso Single Sign-On in Microsoft 365 o per i clienti con distribuzioni ibride di Lync.

Per altre informazioni sulla convalida del certificato con Lync, vedere Gli utenti di Lync Mobile non possono accedere dopo l'aggiornamento alla versione client 5.4.

Nota

Anche se questo articolo è scritto per i dispositivi mobili, gli stessi concetti si applicano ai client Lync.

Ulteriori informazioni

Se il problema persiste dopo aver eseguito questi passaggi di risoluzione dei problemi, contattare il supporto tecnico di Microsoft 365 o i forum della community di Microsoft 365. In alcuni casi, l'account utente Active Directory Domain Services potrebbe essere incompleto o danneggiato. Pertanto, Skype for Business Online non può generare un certificato personale. Questo potrebbe non influire su tutti gli account di un tenant perché l'effetto dipende dallo stato del server al momento della creazione dell'account utente.

Per limitare il problema, determinare se il problema si verifica per più account utente nello stesso computer. Provare quindi ad accedere a Skype for Business Online dallo stesso computer usando più account utente. Questo processo indica se il problema è correlato alla configurazione del computer o a un problema con l'account utente Skype for Business Online.

Il problema è stato risolto?

  • Verificare se il problema è stato risolto.
  • Apprezziamo il tuo feedback. Per fornire commenti e suggerimenti o segnalare eventuali problemi relativi a questa soluzione, inviare un messaggio di posta elettronica .

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