[XL] ベル曲線グラフを作成する方法

概要

ベル曲線は、指定されたデータ セットの正規分布を図示したものです。この資料では、Microsoft Excel でベル曲線のグラフを作成する方法について説明しています。

詳細

次の例では、分析ツールに用意されている乱数発生ツールを使用して Excel で生成されたデータのベル曲線を作成できます。Microsoft Excel で乱数のセットが生成されると、それらの乱数と、分析ツールに含まれるヒストグラム ツールを使用してヒストグラムを作成できます。このヒストグラムから、ベル曲線を示すグラフを作成できます。


ベル曲線のサンプルを作成するには、次の手順を実行します。

  1. Excel を起動します。
  2. 新しいワークシートに、次の列見出しを入力します。

    A1:元のデータ B1:平均 C1:データ区間 D1:ランダム E1:ヒストグラム G1:ヒストグラム
  3. 同じワークシートに、次のデータを入力します。

    A2: 23 B2:
    A3: 25 B3: STDEV
    A4: 12 B4:
    A5: 24
    A6: 27
    A7: 57
    A8: 45
    A9: 19
  4. 同じワークシートに、次の数式を入力します。


    B2: =AVERAGE(A2:A9)
    B3:
    B4: =STDEV(A2:A9)
    これらの数式によってそれぞれ、元のデータの平均と標準偏差が生成されます。
  5. ヒストグラムのデータ区間を生成するために、次の数式を入力します。


    C2: =$B$2-3*$B4
    この数式により、データ区間の下限が生成されます。この数値は、平均より標準偏差の 3 倍小さい値を表します。


    C3: =C2+$B$4
    この数式により、上記のセル内で計算された値に、標準偏差の値が加算されます。
  6. C3 セルを選択し、フィル ハンドルをクリックしてドラッグし、C3 セルから C8 セルにこの数式を入力します。
  7. ベル曲線の基となるランダム データを生成するには、次の手順を実行します。
    1. [ツール] メニューの [分析ツール] をクリックします。
    2. [分析ツール] ボックスで、[乱数発生] をクリックして、[OK] をクリックします。
    3. [変数の数] ボックスに、1 と入力します。
    4. [乱数の数] ボックスに、2000 と入力します。


      : この数字を変更すると、ベル曲線の精度が向上または低下します。
    5. [分布] ボックスで、[正規] をクリックします。
    6. [パラメータ] の [平均] ボックスに、セル B2 内で計算された数 (この例では 29) を入力します。
    7. [標準偏差] ボックスに、セル B4 内で計算された数 (14.68722) を入力します。
    8. [ランダム シード] ボックスは空白のままにします。
    9. [出力オプション] で、[出力先] をクリックします。
    10. [出力先] ボックスに、D2 と入力します。


      これで、正規分布に従った 2000 個の乱数が生成されます。
    11. [OK] をクリックします。
  8. ランダム データのヒストグラムを作成するには、次の手順を実行します。
    1. [ツール] メニューの [分析ツール] をクリックします。
    2. [分析ツール] ボックスで、[ヒストグラム] をクリックして、[OK] をクリックします。
    3. [入力範囲] ボックスに、D2:D2001 と入力します。
    4. [データ区間] ボックスに、C2:C8 と入力します。
    5. [出力オプション] で、[出力先] をクリックします。
    6. [出力先] ボックスに、E2 と入力します。
    7. [OK] をクリックします。
  9. 元のデータのヒストグラムを作成するには、次の手順を実行します。
    1. [ツール] メニューの [分析ツール] をクリックします。
    2. [ヒストグラム] をクリックし、[OK] をクリックします。
    3. [入力範囲] ボックスに、A2:A9 と入力します。
    4. [データ区間] ボックスに、C2:C8 と入力します。
    5. [出力オプション] で、[出力先] をクリックします。
    6. [出力先] ボックスに、G2 と入力します。
    7. [OK] をクリックします。
  10. 次のように入力して、グラフの凡例のラベルを作成します。

    E14: =G1&"-"&G2
    E15: =E1&"-"&F2
    E16: =G1&"-"&H2
  11. ワークシートのセル範囲 E2:H10 を選択します。
  12. [挿入] メニューの [グラフ] をクリックします。
  13. [グラフの種類] で、[散布図] をクリックします。
  14. [形式] で、中央の行の右側のグラフをクリックします。


    : 表示されている 5 つの形式のすぐ下に、"データ ポイントを平滑線でつないだマーカーなしの散布図です" という説明が表示されます。
  15. [次へ] をクリックします。
  16. [系列] タブをクリックします。
  17. [名前] ボックスで、セル参照を削除し、セル E15 を選択します。
  18. [X の値] ボックスで、範囲参照を削除し、範囲 E3:E10 を選択します。
  19. [Y の値] ボックスで、範囲参照を削除し、範囲 F3:F10 を選択します。
  20. [追加] をクリックし、別の系列を追加します。
  21. [名前] ボックスをクリックし、セル E14 を選択します。
  22. [X の値] ボックスをクリックし、範囲 E3:E10 を選択します。
  23. [Y の値] ボックスで、そこにある値を削除して、範囲 G3:G10 を選択します。
  24. [追加] をクリックし、別の系列を追加します。
  25. [名前] ボックスをクリックし、セル E16 を選択します。
  26. [X の値] ボックスをクリックし、範囲 E3:E10 を選択します。
  27. [Y の値] ボックスをクリックし、そこにある値を削除して、範囲 H3:H10 を選択します。
  28. [完了] をクリックします。


    グラフには、2 つの曲線と x 軸に沿った平坦な線が表示されます。
  29. 凡例で "- データ区間" というラベルの付いた 2 番目の曲線をダブルクリックします。
  30. [データ系列の書式設定] ダイアログ ボックスで、[軸] タブをクリックします。
  31. [第 2 軸] をクリックし、[OK] をクリックします。
これで、指定したデータ セットとベル曲線との比較を示すグラフが作成されます。

関連情報

グラフの作成の詳細については、[ヘルプ] メニューの [Microsoft Excel ヘルプ] をクリックします。次に、Office アシスタントまたはアンサー ウィザードにグラフを作成すると入力し、[検索] をクリックして表示されるトピックを参照してください。

プロパティ

文書番号:213930 - 最終更新日: 2006/02/27 - リビジョン: 1

フィードバック