Outlook オートコンプリート一覧についての情報

適用対象: Outlook 2016Outlook 2013Microsoft Office Outlook 2003 詳細

概要


この資料には、Microsoft Outlook オートコンプリート一覧 (Outlook オートコンプリート一覧とも呼ばれる) の概要が含まれています。 機能の説明に加えて、この資料には詳細情報と上級ユーザーが一覧を管理するための手順も含まれています。

詳細


Outlook ではオートコンプリート一覧が維持されます。 この一覧は、メッセージ送信前に宛先を確認する機能およびオートコンプリート機能の両方で使用されます。 オートコンプリート一覧はニックネーム キャッシュとも呼ばれ、Outlook からメール メッセージを送信するときに自動的に生成されます。 この一覧には、SMTP アドレス、LegacyExchangeDN エントリ、以前にメールを送信した人の表示名が含まれています。

注意 Outlook のオートコンプリートリストは Outlook に固有のもので、Outlook Web App(OWA)とは共有されません。 OWA では独自のオートコンプリート一覧が維持されます。

次に、オートコンプリート機能について説明します。
 

エントリ数を制限する

Outlook ではオートコンプリート一覧に保存できるエントリ数が制限されます。 この制限に達すると、Outlook では内部アルゴリズムを使用して、一覧から削除する最適な名前が判断されます。 これは使用頻度に基づきます。 したがって、ニックネーム キャッシュから予期せず削除された名前を見つけることができます。 この状況を回避するには、以下の 2 つの一般的なアプローチがあります。
  1. You can 必要でなくなったオートコンプリート一覧のエントリを積極的に削除できます。 これは推奨されるアプローチです。 これを実行する方法の詳細については、「オートコンプリート一覧のエントリを一度に削除する方法」セクションを参照してください。
  2. ニックネーム キャッシュの制限値を上げることができます。 この構成はテストされていないため、推奨されていません。 ニックネーム キャッシュが大きい場合、ニックネーム キャッシュが破損して使用できなくなると、大量のキャッシュされたエントリを失う可能性があります。 制限値を上げる方法の詳細については、「オートコンプリート一覧の制限値を変更する方法」を参照してください。
制限は以下のとおりです。
  • Outlook 2016: 1,000 エントリ
  • Outlook 2013: 1,000 エントリ
  • Outlook 2010: 1,000 エントリ
  • Outlook 2007: 2,000 エントリ
  • Outlook 2003: 1,000 エントリ
 

オートコンプリート機能を有効にする方法

このセクションでは、オートコンプリート機能を有効または無効にする方法について説明します。
Outlook 2010、Outlook 2013、および Outlook 2016
オートコンプリート 設定にアクセスするには、次の手順を実行します: 
  1. [ファイル] メニューの [オプション] をクリックします。
  2. [メール] タブを選択します。
  3. [メッセージの送信] が表示されるまで半分ほど下へスクロールします。 [[宛先]、[CC]、[BCC] に入力するときにオートコンプリートのリストを使用して名前の候補を表示する] チェック ボックスがオンになっていることを確認します。

Outlook 2003 および Outlook 2007
オートコンプリート設定にアクセスするには、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックします。
  2. [電子メール オプション] ボタンをクリックします。
  3. [メールの詳細オプション] ボタンをクリックします。
  4. [宛先、Cc、および Bcc フィールドの入力中に名前を提案する] チェックボックスがオンになっていることを確認します。 (この手順のスクリーン ショットを以下に示します)。この手順のスクリーン ショット
 

Outlook 2010、Outlook 2013、および Outlook 2016 に .nk2 ファイルをインポートする方法

Microsoft Office Outlook 2007 およびそれ以前のバージョンでは、ニックネーム (.nk2) ファイル内のオートコンプリート一覧がディスクに格納されます。 Outlook 2010、Outlook 2013、および Outlook 2016 では、オートコンプリート一覧がプライマリ メッセージ ストア内に非表示メッセージとして格納されます。 Outlook 2010、Outlook 2013、および Outlook 2016 では、以前のバージョンの .nk2 ファイルをインポートできます。

Outlook 2010 で .nk2 ファイルをインポートする方法の詳細については、以下のマイクロソフト Web サイトを参照してください。

オートコンプリート一覧をコピーする方法

オートコンプリート一覧をエクスポートしてインポートする手順は、お使いの Outlook のバージョンによって異なります。
Outlook 2010、Outlook 2013、および Outlook 2016
Outlook 2010、Outlook 2013、および Outlook 2016 でオートコンプリート一覧をコピーするには、以下の手順を実行します。

手順 1

オートコンプリート メールボックス メッセージをエクスポートするには、以下の手順を実行します。
  1. Outlook を終了し、メールボックスに接続されているすべてのワークステーションで Outlook Web Access または Outlook Web App (OWA) を終了します。
  2. http://mfcmapi.codeplex.com から MFCMAPI をダウンロードしてインストールします。
  3. mfcmapi.exe を実行します。
  4. [セッション] メニューの [ログオン] をクリックします。
  5. プロファイルの指定を求められたら、目的のプロファイル名を選択し、[OK] をクリックします。
  6. 一番上のウィンドウで、お使いのメールボックスに対応する行を見つけてダブルクリックします。
  7. 左側のナビゲーション ウィンドウで、[ルート コンテナー] を展開し、[インフォメーション ストアの先頭] または [IPM_SUBTREE] を展開します。
  8. [Inbox (受信トレイ)] フォルダーを右クリックして、[Open Associated Content Table (関連付けられたコンテンツ テーブルを開く)] をクリックします。 このアクションにより、さまざまなプロパティが含まれる新しい MFCMAPI ウィンドウが開かれます。
  9. [Subject (件名)] 列の下で、件名が IPM.Configuration.Autocomplete のアイテムを右クリックし、[Export Message (メッセージのエクスポート)] をクリックします。 このアクションにより、[Save Message To File (メッセージをファイルに保存)] ウィンドウが開かれます。
  10. ドロップ ダウン リストで [MSG file (UNICODE) (MSG ファイル (UNICODE))] をクリックし、[OK] をクリックします。
  11. メッセージを保存するフォルダーの場所を選択し、[保存] をクリックします。 この場所を記録しておきます。
手順 2

オートコンプリート メールボックス メッセージをインポートするには、以下の手順を実行します。
  1. Outlook を終了し、メールボックスに接続されているすべてのワークステーションで Outlook Web Access または Outlook Web App (OWA) を終了します。
  2. http://mfcmapi.codeplex.com から MFCMAPI をダウンロードしてインストールします。
  3. mfcmapi.exe を実行します。
  4. [セッション] メニューの [ログオン] をクリックします。
  5. プロファイルの指定を求められたら、目的のプロファイル名を選択し、[OK] をクリックします。
  6. 一番上のウィンドウで、お使いのメールボックスに対応する行を見つけてダブルクリックします。
  7. 左側のナビゲーション ウィンドウで、[ルート - メールボックス] を展開し、[インフォメーション ストアの先頭] または [IPM_SUBTREE] を展開します。
  8. [Inbox (受信トレイ)] フォルダーを右クリックして、[Open Associated Content Table (関連付けられたコンテンツ テーブルを開く)] をクリックします。 このアクションにより、さまざまなプロパティが含まれる新しい MFCMAPI ウィンドウが開かれます。
  9. 重複エントリを避けるために、既存のオートコンプリート メッセージを削除する必要があります。

    注: IPM.Configuration.Autocomplete メッセージを削除する前に、「オートコンプリート キャッシュをエクスポートする方法」セクションの手順を使用してメッセージをエクスポートする必要があります。

    既存のオートコンプリート メッセージを削除するには、以下の手順を実行します。
     
    1. [Subject (件名)] 列の下で、件名が IPM.Configuration.Autocomplete のアイテムを見つけます。
    2. アイテムを右クリックし、[削除] をクリックします。 これによって、[アイテムを削除する] ウィンドウが開かれます。
    3. ドロップ ダウン リストで [Permanent deletion (deletes to deleted item retention if supported) (完全な削除 (サポートされている場合、削除済みアイテムの保存期間まで削除する))] をクリックし、[OK] をクリックします。
  10. [フォルダー] メニューの [インポート] をクリックし、[From MSG (メッセージから)] をクリックします。
  11. 手順 11 の「オートコンプリート一覧をエクスポートする方法」で作成した .msg ファイルを見つけ、[OK] をクリックします。
  12. 表示される [Load MSG (メッセージの読み込み)] ウィンドウで、[Load style (読み込みスタイル)] 一覧の [Load message into current folder (メッセージを現在のフォルダーに読み込む)] を選択し、[OK] をクリックします。
IPM.Configuration.Autocomplete_<hexadecimal code>.msg からオートコンプリートの情報がインポートされます。プレースホルダー <hexadecimal code> は英数字の長い文字列を表します。
Outlook 2003 および Outlook 2007

Outlook 2003 と Outlook 2007 ではオートコンプリート一覧をコピーする手順が異なります。 これは、Outlook 2003 と Outlook 2007 ではオートコンプリート一覧が .nk2 ファイルに格納されるためです。

Outlook 2007 でオートコンプリート一覧をコピーするには、次のマイクロソフトの Web サイトを参照してください。

オートコンプリート一覧を別のコンピューターにコピーする

オートコンプリート一覧のエントリを 1 つずつ削除する方法

オートコンプリート キャッシュのエントリを 1 つずつ削除するには、以下の手順を実行します。
  1. 新しい電子メール メッセージを開きます。
  2. 削除するオートコンプリート一覧のエントリの最初の数文字を入力します。
  3. 表示されるエントリ候補の一覧で、目的のエントリの上にマウス ポインターを移動し、強調表示されるようにしますが、名前はクリックしないでください。
  4. 強調表示された名前の横に「X」アイコンが表示されたら、Xをクリックしてリストから名前を削除するか、キーボードの Delete キーを押します。

オートコンプリート一覧全体を消去する方法

このセクションでは、オートコンプリート一覧を削除する方法について説明します。
Outlook 2010、Outlook 2013、および Outlook 2016

Outlook 2010、Outlook 2013、および Outlook 2016 でオートコンプリート一覧を削除するには、以下のいずれかの方法を使用します。

方法 1

  1. Outlook を起動します。
  2. [ファイル] タブの [オプション] をクリックします。
  3. [メール] タブをクリックします。
  4. [メッセージの送信] で [オートコンプリートのリストを空にする] をクリックします。

  5. [はい] をクリックします。

方法 2

/CleanAutoCompleteCache スイッチを使用して Outlook を起動します。 これを行うには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. Outlook.exe /CleanAutoCompleteCache」と入力します。

    注: Outlook が既定の場所にインストールされていない場合は、Outlook.exe のパスを指定する必要があります。
Outlook 2003 および Outlook 2007
Outlook 2003 および Outlook 2007 でオートコンプリート一覧を削除するには、.nk2 ファイルを手動で削除する必要があります。 .nk2 ファイルを削除するには、次の手順を実行します。
  1. Outlook を終了します。
  2. [スタート] をクリックし、[コンピューター] をクリックします。
  3. [整理] をクリックし、フォルダと検索のオプションをクリックします。
  4. [表示] タブで、隠しファイル、フォルダ、およびドライブを表示するをクリックします。
  5. [OK] をクリックします。
  6. [スタート] をクリックし、[すべてのプログラム] をクリックし、[アクセサリ] をクリックしてから [実行] をクリックします。
  7. [ファイル名を指定して実行] ダイアログ ボックスで、次のコマンド (引用符を含む) を入力し、[OK] をクリックします:

    「C:\ Users\ユーザー名\AppData\Roaming\Microsoft\Outlook」


    注意このパスのユーザー名は、現在ログオンしている Windows ユーザーの名前です。
  8. リセットするプロファイルの名前が含まれている、.NK2 ファイルを右クリックし、[名前の変更] をクリックします。 
  9. ファイルの名前を profilename .bak に変更し、Enter キーを押します。
  10. Outlook を起動します。
 

オートコンプリート キャッシュの問題

このセクションでは、オートコンプリート キャッシュで発生する可能性のある既知の問題について説明します。 オートコンプリート キャッシュが時間の経過に伴って破損し、新しいエントリを保存できなくなる可能性があります。 これが発生した場合、一覧から個々のエントリの削除を試行できます。 これを実行するには、「オートコンプリート一覧のエントリを一度に削除する方法」セクションを参照してください。 この方法で問題が解決しない場合は、オートコンプリート一覧全体をリセットできます。 これを行うには、「オートコンプリート一覧全体を消去する方法」セクションを参照してください。
 

オートコンプリート一覧の制限値を変更する方法

この構成はテストされていないため、推奨されていません。 オートコンプリート一覧が大きい場合、オートコンプリート一覧キャッシュが破損して使用できなくなると、大量のキャッシュされたエントリを失う可能性があります。 この免責事項を前提として、Outlook で次のレジストリ データを使用してオートコンプリート一覧の制限値を変更できます。

重要: このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 万一に備えて、編集の前にレジストリをバックアップしてください。 問題が発生した場合でも、レジストリを復元できます。 レジストリのバックアップ方法および復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
 
322756 Windows でレジストリをバックアップおよび復元する方法
  1. Outlook を終了します。
  2. レジストリ エディターを起動します。
     
    • Windows 8.xでは、Windows キーを押し、「regedit」と入力して、Enter キーを押します。
    • Windows 7 および Windows Vista の場合は、[スタート] ボタンをクリックし、[検索の開始] ボックスに「regedit」と入力し、Enter キーを押します。
  3. 次のレジストリ サブキーを見つけてクリックします。
     
    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck

    注意 このレジストリ サブキーのプレースホルダ x.0 は、Microsoft Office のバージョンを表します。 次の一覧から適切な値を使用します。

    Outlook 2016 = 16.0
    Outlook 2013 = 15.0
    Outlook 2010 = 14.0
    Outlook 2007 = 12.0
    Outlook 2003 = 11.0
  4. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。
  5. 「MaxNickNames」と入力し、Enter キーを押します。
  6. [編集] メニューの [修正] をクリックします。
  7. 制限の新しい値を入力して [OK] をクリックします。

    注:
    • 数値は小数点表記で入力してください。 これが数値を入力する正しい表記です。
    • 制限値を少しだけ大きくして、新しい制限値をテストします。 たとえば、Outlook 2013で上限を 20 パーセント増やすには、MaxNickNames 値に1200を指定します。
  8. レジストリ エディターを終了します。
  9. Outlook を起動します。
注: MaxNickNames レジストリ値は単に既定以外の制限値を指定します。 したがって、この値を使用して、ニックネーム キャッシュの制限値を下げることもできます。