クリップボードのリダイレクト (コピーおよび貼り付け) を使用して、2 GB を超えるファイルをリモート デスクトップ サービスまたはターミナル サービス経由でコピーしようとすると、自動的に失敗します


現象


ある 2 GB を超えるリモート デスクトップ サービスまたはクリップボードのリダイレクト (コピーおよび貼り付け) をターミナル サービス セッション経由で RDP クライアント 6.0 またはそれ以降のバージョンを使用してファイルをコピーしようとすると、ファイルはコピーされません。エラー メッセージが表示されません。

原因


これは、既知の問題です。このメソッドを使用して、2 GB より大きいファイルのコピーはサポートされていません。

解決策


方法 1

2 GB より大きなファイルを転送する場合は、リモート デスクトップ サービスまたはターミナル サービス セッションを使用したドライブのリダイレクトを使用します。

方法 2

XCopyなどのコマンド ラインの代替を使用して、リモート デスクトップ サービスまたはターミナル サービス セッション経由で 2 GB を超えるファイルをコピーします。たとえば、次のコマンドを使用できます。

xcopy \\tsclient\c\myfiles\LargeFile d:\temp

詳細


コピーしてファイルに貼り付けます。
コピーし、コピーと貼り付けの機能を使用してリモート セッションと、ローカル コンピューターまたはローカル コンピューターとリモート セッションの間でファイルを貼り付けることができます。ただし、これは、2 GB より小さいファイルに限定します。

ドライブのリダイレクトを使用してファイルの転送
ファイルは、ローカル ホストとリモート コンピューター間で簡単に転送できるように、セッションでローカル コンピューター上のドライブをリダイレクトできます。この方法で使用できるドライブを以下に示します。
  • ローカルのハード ディスク
  • フロッピー ディスク ドライブ
  • マップされたネットワーク ドライブ


ユーザーはリモート デスクトップ接続の [ローカル リソース] タブで、デバイスとリモート コンピューターにリダイレクトするためのリソースの種類を指定できます。