IPv6 が有効になっている環境においてメールの送受信に失敗する現象の対処方法 (Outlook)

現象

Windows のネットワーク設定で IPv6 の機能が有効になっている場合に、POP3/IMAP4 を使っている Outlook でエラー番号 0x80042108、0x80042109 などが発生し、メールの送受信に失敗する場合があります。

原因

この現象は Outlook が接続しようとしたメール サーバーの IP アドレスとして IPv6 のアドレスが取得されたにもかかわらず、実際には IPv6 での接続ができないために発生します。

Outlook から指定されたホスト名のサーバーに POP、SMTP、または IMAP で接続する際には、まずホスト名から IP アドレスへの名前解決を行います。解決された結果が IPv6 のアドレスであれば IPv6 での接続を試みますが、IPv6 の接続に失敗した場合でも IPv4 アドレスでの再試行は行わないために、メール サーバーへの接続に失敗し、この現象が発生します。

解決方法

Outlook 2010 と Outlook 2007 を利用している場合、以下の修正プログラムを適用することでエラーを回避することが可能です。

・Outlook 2010 の場合
Outlook 2010 の修正プログラム パッケージ outlook-x none.msp: 2011 年 2 月 22日
http://support.microsoft.com/kb/2475877


・Outlook 2007 の場合
Office Outlook 2007 修正プログラム パッケージ (Outlook-x-none.msp) (2010 年 8 月 31 日) について
http://support.microsoft.com/kb/2276479

なお、Outlook 2007 の場合には、上記の修正を含むより新しい更新プログラムが公開されていますので、以下のいずれかの方法でも現象を回避することが可能です。

1. Microsoft Update を使用します。

2. 以下の URL より更新プログラムをダウンロードし、適用します。
Microsoft Office Outlook 2007 更新プログラム: KB2412171
http://www.microsoft.com/downloads/details.aspx?FamilyID=C5AB9C27-1953-424A-95F9-C589A73BFCA1&displayLang=ja


・Outlook 2003 の場合
Outlook 2003 の場合には、以下のサポート技術情報で案内している方法で回避します。

Windows で IPv6 が有効になっている場合、エラー番号 0x80042108 または 0x80042109 が表示されて Outlook 2003 でメールの送受信ができない
http://support.microsoft.com/kb/2445424/ja


詳細

修正プログラムの入手と適用方法の詳細については以下をご参照ください。

修正プログラムの入手と適用方法
http://support.microsoft.com/gp/HotfixHowto
プロパティ

文書番号:2518315 - 最終更新日: 2016/09/29 - リビジョン: 1

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