Outlook と Outlook Web App で発生する同期に関する問題

適用対象: Microsoft Business Productivity Online DedicatedMicrosoft Exchange Online DedicatedOutlook 2016 詳細

現象


Microsoft Outlook または Microsoft Outlook Web App (旧名称 Outlook Web Access) で同期に関する問題が発生すると、以下の現象が起こる場合があります。

現象 1

Microsoft Outlook で受信したメッセージと Microsoft Outlook Web App で受信したメッセージを比較すると、相違または不一致があります。

現象 2

Outlook で問題が発生している場合でも、キャッシュ モードを無効にするとその問題は発生しない。

現象 3

Outlook のオフライン フォルダーの .ost ファイルと Microsoft Exchange サーバーを実行しているサーバー上のメールボックスを同期すると、エラー メッセージが表示される場合がある。 以下のようなエラー メッセージが表示される場合があります。 


現象 4

.ost ファイルとメールボックスを同期した後、電子メール メッセージ、予定、連絡先、タスク、履歴、注、投稿されたアイテム、およびドキュメントなどの一部のアイテムが自身の .ost ファイルまたはメールボックスから紛失しています。

原因


これらの現象が発生する場合、またはその他の同期に関する問題が発生する場合、問題は破損した .ost ファイルに起因する場合があります。

解決方法


Outlook 2003 および Outlook 2007

OST 整合性チェック ツール (Scanost.exe) を使用して自身の .ost ファイルに矛盾がないか確認します。

Outlook 2010 およびそれ以降のバージョン

OST 整合性チェック ツール (Scanost.exe) は Outlook 2010 以降のバージョンに含まれていません。 本ツールは、以前の Outlook のバージョンで Outlook データ ファイル (.ost ファイル) のエラーを修正する場合に推奨されていました。 特定のフォルダーについて問題がある場合は、Outlook のフォルダーと再同期することができます。 このためには、次の手順に従います。
  1. フォルダを右クリックし、[プロパティ] をクリックします。
  2. [オフライン アイテムをクリア] をクリックし、続いて [OK] をクリックします。
  3. Outlook 2010 のリボンの [送受信] タブをクリックします。
  4. [フォルダーの更新] をクリックします。
上記の方法で問題を解決できない場合、.ost ファイルの再構築を推奨します。 これを実行するには、.ost ファイルを削除し、続いて Outlook で Exchange サーバーから情報を再度ダウンロードします。 詳細については、「詳細情報」セクションを参照してください。  

ただし、サーバー上に存在しないデータがローカル環境に存在する場合は例外です。 その場合、以下の手順に従うことを推奨します。
  1. データを Outlook データ ファイル (.pst) にエクスポートし、続いて .ost ファイルを削除します。
  2. サーバー データを再度ダウンロードし、続いて [重複したらインポートしない] オプションを使用して .pst ファイル データをインポートします。 このオプションにアクセスするには、[ファイル] タブをクリックし、続いて [開く] オプションをクリックします。

詳細情報


OST 整合性チェック ツールは .ost ファイルに対してのみ実行され、同期に関する問題の診断および修復に使用できます。 ローカル環境にコピーした .ost ファイルおよび Exchange サーバー上のメールボックスをスキャンします。 本ツールは当該ファイルと当該メールボックスのアイテムおよびフォルダーを比較し、同期時の相違について調整を試みます。 OST 整合性チェック ツールにより、Exchange サーバーのメールボックスが変更されることはありません。 また、このツールにより、発見され解決された相違点を確認できるようスキャン ログにはあらゆる相違点が記録されます。 また、このスキャン ログにより、本ツールで解決できなかったため手動による修正が必要な状況が特定されます。 スキャン ログは、[削除済みアイテム] フォルダーにあります。

Outlook を以下の場所にインストールすると、実行している Outlook のバージョンに応じて OST 整合性チェック ツール (Scanost.exe) がインストールされます。

Outlook 2003 の場合: ドライブ:\Program Files\Common Files\System\MSMAPI\LocaleID フォルダー。 この例にある LocaleID は、Microsoft Office をインストールする際のロケール ID (LCID) となります。 英語 (米国) の LCID は 1033 です。

Outlook 2007 の場合: ドライブ:\Program Files\Microsoft Office\OFFICE12

Scanost.exe を使用してエラーを修復する方法
  1. Outlook 2003 または Outlook 2007 を実行している場合は Outlook を終了します。
  2. [Scanost.exe] をダブルクリックします。
  3. プロファイルを選択するよう Outlook を設定している場合、本ツールでも同様にプロファイルを選択するよう表示されます。 [Profile Name] (プロファイル名) リストからチェックする .ost ファイルを含むプロファイルをクリックします。 [Connect] (接続) または [Work Offline] (オフラインで作業) のいずれかを選択するよう表示された場合は、[Connect] をクリックします。
  4. 適切なオプションを選択します。 ツールがスキャン中に相違点を検知した際に自動的に解決させる場合は、[Repair Errors] (エラーを修復) チェックボックスをオンにします。 このチェック ボックスがオフの場合でも本ツールにより問題は記録されます。 ただし、必要な修正は実行されません。
  5. [Begin Scan] (スキャンを開始) をクリックします。
注: スキャン ログを表示する場合は、Outlook を起動し、続いて [削除済みアイテム] フォルダーを開きます。 本ツールは [削除済みアイテム] フォルダーをスキャンしません。 “OST 整合性チェック” という件名のメッセージ内のあらゆる問題が確認できます。

.ost ファイルを開こうとした際に問題が発生した場合は、受信トレイ修復ツール (Scanpst.exe) を使用して .ost ファイル内のエラーを診断し修復します。 受信トレイ修復ツールは、.ost ファイルおよび個人用フォルダーの .pst ファイルのどちらにも使用できます。 受信トレイ修復ツールは .ost ファイルまたは .pst ファイルをスキャンし、ファイル構成が損傷していないかを確認します。 また、本ツールは必要に応じて内部データ構造を修復します。 本ツールは Exchange サーバーのメールボックスに対応していません。

.ost ファイルの再構築方法
  1. 実行しているオペレーティング システムに合わせて以下のフォルダーを検索します。 

    Windows XP の場合: C:\Documents and Settings\<alias>\Local Settings\Application Data\Microsoft\Outlook

    Windows Vista 以降のバージョン: C:\Users\<alias>\AppData\Local\Microsoft\Outlook
  2. フォルダーが表示されない場合は、フォルダーを表示します。 このためには、次の手順に従います。
    Windows 8 および Windows 10
    [表示] タブをクリックし、[隠しファイル] チェック ボックスおよび [ファイル名拡張子] チェック ボックスをオンにします。
    Windows 7
    • [整理] メニューから [フォルダーと検索のオプション] をクリックします。
    • [表示] タブをクリックし、[隠しファイル、隠しフォルダー、および隠しドライブを表示する] チェックボックスをオンにし、[登録されている拡張子は表示しない] チェック ボックスをオフにします。
    Windows XP
    • [ツール] メニューの [フォルダー オプション] をクリックします。
    • [表示] タブをクリックし、[隠しファイルおよびフォルダーを表示する] チェック ボックスを選択し、[登録されている拡張子は表示しない] チェック ボックスをオフにします。
  3. 既定では、Outlook によってユーザーのローカル キャッシュに Outlook.ost が作成されます。 Outlook.ost ファイルが既に存在する場合、Outlook によりファイル名の末尾に番号が挿入されます (例えば、Outlook0.ost または Outlook1.ost)。 .ost ファイルの名前をすべて変更します。 これを実行するには、.ost ファイルのファイル名拡張子を .old に変更します。 .ost ファイル名拡張子が表示されていない場合は、手順 2A と 2B で説明したとおり、[登録されている拡張子は表示しない] チェック ボックスをオフにします。
  4. “File is in use” (ファイルを使用中です) というエラー メッセージが表示された場合は、Ctrl+Alt+Delete キーを押下し、[タスク マネージャー] をクリックします。 [プロセス] タブをクリックし、Outlook.exe と Winword.exe がリストに表示されていないことを確認します。 リストの中にこれらのプロセスが表示されている場合は、各ファイルをクリックし、[タスクの終了] をクリックします。
  5. .ost ファイルの名前を変更後、Outlook を再起動します。 “Preparing for first use” (初めて使用するための準備をしています) メッセージが表示されます。 メールボックスが同期されるまで待機します。 この処理時間はユーザーのメールボックスのサイズにより異なります。
  6. メールボックスが同期されたら、問題がまだ発生しているか確認します。 問題がまだ発生している場合、問題の原因は .ost ファイルではありません。

別の問題が原因で発生する類似したエラーについては、https://support.microsoft.com/ja-jp/help/3068991 を参照してください。