複数のレイヤーを持つ CAD 図面を変換すると、図形の位置がずれる場合がある

現象

下記の条件が満たされる場合、CAD 図面 オブジェクトを Visio 図形へと変換したのちに、図形の位置がずれる現象が発生する場合があります。
  • Visio 図面上に AutoCAD などのアプリケーションの一般的な使用形式である .dwg ファイルや .dxf ファイルを挿入する
  • 挿入した .dwg ファイル、.dxf ファイルが、非表示レイヤーを含む、複数のレイヤーを持つ
  • 挿入した CAD 図面 オブジェクトを Visio 図形に変換し、非表示レイヤーを表示するように設定を変更する


回避策

下記の 2 通りのいずれかの方法を使用します。

方法 1. CAD 図面 ファイルを Visio 上で保存しなおす方法
  1. Visio 2010 を起動します。
  2. [ファイル]-[開く] をクリックします。
  3. [ファイルの種類] として [AutoCAD 図面 (*.dwg;*.dxf)] を選択し、現象が発生する CAD 図面 ファイルを開きます。
  4. 挿入した CAD 図面 オブジェクトを右クリックし、メニューの [CAD 図面 オブジェクト]-[プロパティ] をクリックします。
  5. [CAD 図面のプロパティ] ダイアログにて、[レイヤー] タブを選択し、[表示] が [いいえ] となっているレイヤーを選択して [可視性の設定] ボタンをクリックし、[表示] を [はい] に変更します。
  6. [OK] を押して [CAD 図面のプロパティ] ダイアログを閉じます。
  7. [ファイル]-[名前を付けて保存] をクリックします。
  8. [ファイルの種類] として [AutoCAD 図面 (*.dwg)]、または [AutoCAD 変換ファイル (*.dxf)] を選択し、適切な名前を付けて保存します。
  9. Visio 2010 にて新しい図面を開きます。
  10. [挿入] タブ内の [図]-[CAD 図面] をクリックし、8. にて作成した CAD 図面 ファイルを挿入します。
  11. 挿入した CAD 図面 オブジェクトを右クリックし、Visio 図形に変換するためにメニューの [CAD 図面 オブジェクト]-[変換] をクリックします。
  12. [CAD オブジェクトの変換] ダイアログにて、変換するレイヤーを選択します。
  13. [OK] をクリックして、[CAD オブジェクトの変換] ダイアログを閉じます。
結果
問題なく Visio 図形への変換が完了します。


方法 2. CAD 図面 ファイルを変換する前に、Visio 上にレイヤーを追加する方法
  1. Visio 2010 を起動します。
  2. [挿入] タブ内の [図]-[CAD 図面] をクリックし、非表示のレイヤーを含む CAD 図面 ファイルを挿入します。
  3. 挿入した CAD 図面を右クリックし、メニューの [CAD 図面 オブジェクト]-[プロパティ] をクリックします。
  4. [CAD 図面のプロパティ] ダイアログにて、[レイヤー] タブを選択し、[表示] が [いいえ] となっているレイヤーの [名前] と [色] をメモします。その後該当レイヤーを選択して [可視性の設定] ボタンをクリックし、[表示] を [はい] に変更します。
  5. [OK] を押して [CAD 図面のプロパティ] ダイアログを閉じます。
  6. [ホーム] タブ内の [編集]-[レイヤー]-[レイヤー プロパティ] をクリックします。
  7. [レイヤー プロパティ] ダイアログにて、[新規] をクリックします。[新しいレイヤー] にて、4.でメモした [名前] を入力します。
  8. 新規追加したレイヤーが選択されていることを確認し、[レイヤーの色] として、4. でメモした [色] を選択します。
  9. [OK] を押して [レイヤー プロパティ] ダイアログを閉じます。
  10. 挿入した CAD 図面を右クリックし、Visio 図形に変換するためにメニューの [CAD 図面 オブジェクト]-[変換] をクリックします。
  11. [CAD オブジェクトの変換] ダイアログにて、変換するレイヤーを選択します。この際、非表示となっているレイヤーも変換対象に加えます。
  12. [OK] をクリックして、[CAD オブジェクトの変換] ダイアログを閉じます。

結果
問題なく Visio 図形への変換が完了します。

詳細

問題の再現手順
  1. Visio 2010 を起動します。
  2. [挿入] タブ内の [図]-[CAD 図面] をクリックし、非表示のレイヤーを含む CAD 図面 ファイルを挿入します。
  3. 挿入した CAD 図面 オブジェクトを右クリックし、Visio 図形に変換するためにメニューの [CAD 図面 オブジェクト]-[変換] をクリックします。
  4. [CAD オブジェクトの変換] ダイアログにて、変換するレイヤーを選択します。この際、非表示となっているレイヤーも変換対象に加えます。
  5. [ホーム] タブ内の [編集]-[レイヤー]-[レイヤー プロパティ] をクリックします。
  6. [レイヤー プロパティ] ダイアログにて、4. にて変換した非表示レイヤーに対し、[表示] の部分のチェックを入れ、Visio 上で表示を行うように設定変更します。
結果
非表示レイヤー上に存在していた図形が、本来の位置とずれた位置に表示される場合があります。 

関連情報

関連する現象の情報を参照するには、次のサポート技術情報 をクリックしてください。

829240 A viewport is not visible when you open an AutoCAD file in Visio 2003 that you saved in Paperspace mode
プロパティ

文書番号:2530956 - 最終更新日: 2016/09/29 - リビジョン: 1

フィードバック