Windows Server 2003 ターミナル サーバー ポートがリッスンしないことがある

現象

Windows Server 2003 ターミナル サーバーにおいて、ターミナル サービスが起動中であるにもかかわらず TCP 3389 ポートがリッスンしないことがあります。
ターミナル サービス ポートがリッスンされていないため、クライアントからのリモート デスクトップ接続に失敗します。

原因

ターミナル サービス起動時の初期化処理においてリダイレクトされた TS Printer オブジェクトのパージ処理を行います。この時、プリンター オブジェクトが正しく削除できない場合にはサービスの初期化処理が失敗し、ターミナル サービス ポートをオープンできません。

根本的には以下のような要因が考えられます。
  • プリンター ドライバーから応答がない。
  • プリンター ドライバーがターミナル サーバーに対応していない。

解決方法

リダイレクトされたプリンター オブジェクトを削除してから、ターミナル サーバーを再起動します。

詳細

Netstat –ano コマンドなどを利用して、TCP 3389 ポートがリッスンされていることが確認できます。ターミナル サービスが起動しているにも関わらず、TCP 3389 ポートがリッスンされていない場合は本現象に該当している可能性があります。
プロパティ

文書番号:2571774 - 最終更新日: 2016/09/29 - リビジョン: 1

Microsoft Windows Server 2003 Service Pack 2

フィードバック