AD レプリケーション エラー 8240 のトラブルシューティング: サーバーにこのようなオブジェクトがありません
この記事では、Win32 エラー 8240 で失敗する AD 操作の現象、原因、解決策について説明します。"サーバーにこのようなオブジェクトはありません"。
注:
ホーム ユーザー: この記事は、テクニカル サポート エージェントと IT プロフェッショナルのみを対象としています。 問題のヘルプを探している場合は、 Microsoft コミュニティに問い合わせてください。
適用対象: Windows Server 2019、Windows Server 2016、Windows Server 2012 R2
元の KB 番号: 2680976
現象
現象 1
コマンドの Repadmin /ShowReps
出力:
RPC 経由の SiteName\DCName
objectGuid: <GUID>
最後の試行 @ <時間> が失敗し、結果 8240:
サーバーにこのようなオブジェクトはありません。
最後の成功 @ (なし)。
現象 2
[ 今すぐレプリケート ] オプションを使用して Active Directory サイトとサービス コンソール (dssite.msc) で強制的にレプリケーションしようとすると、次のエラー メッセージが表示されます。
ドメイン コントローラーの Source-DC-Name からドメイン コントローラー<の Destination-DC-Name>> に名前付けコンテキストの名前付けコンテキスト<>を<同期しようとしたときに、次のエラーが発生しました。
サーバーにこのようなオブジェクトはありません。 この操作は続行されません。
現象 3
ドメイン コントローラーから Active Directory を削除しようとすると、Active Directory インストール ウィザードで次のエラー メッセージが表示されます。
Active Directory は、ディレクトリ パーティション <Naming-Contentxt> 内の残りのデータをドメイン コントローラーのドメイン コントローラー><に転送できませんでした。サーバーにはこのようなオブジェクトはありません。
現象 4
ドメイン コントローラーのディレクトリ サービスで NTDS General イベント 1126 が発生し、エラー 8240 が発生します。
イベントの種類: エラー
イベント ソース: NTDS General
イベント カテゴリ: グローバル カタログ
イベント ID: 1126
Date: <DateTime>
時刻: <DateTime>
ユーザー: NT AUTHORITY\ANONYMOUS LOGON
コンピューター: ComputerName
説明:
Active Directory がグローバル カタログとの接続を確立できませんでした。追加データ
エラー値:
8240 サーバーにこのようなオブジェクトはありません。
内部 ID:
3200ba0
原因
エラー 8240 (0x2030) はERROR_DS_NO_SUCH_OBJECTを意味します。 これは、ディレクトリに特定のオブジェクトが見つからなかったことを示します。 このエラーは、次の 2 つの状況で発生する可能性があります。
状況 1: AD レプリケーション中
ソース ドメイン コントローラー上の Active Directory 内のオブジェクトに変更が発生すると、ソース ドメイン コントローラーは、この変更を取得するようにレプリケーション パートナーに通知することで、この変更を他のドメイン コントローラーに伝達します。 移行先ドメイン コントローラーは、変更通知を受け取ったときに、ソース ドメイン コントローラーから変更をプルします。 変更が取得されると、移行先ドメイン コントローラーは変更をローカル データベースに処理しようとします。
移行先ドメイン コントローラーは、変更をそのオブジェクトに適用できるように、ローカル データベースで変更されたオブジェクトを検索する必要があります。 何らかの理由でターゲット オブジェクトが見つからない場合、Active Directory はエラー 8240 を報告します。
このエラーは、次の状況で発生する可能性があります。
- ソース ドメイン コントローラー上のオブジェクトに変更が発生したが、このオブジェクトがガベージ コレクション プロセスによってクリーンアップされた場合
- 廃棄ストーンの有効期間 (TSL) を超える時間に失敗した後に AD レプリケーションが回復すると、廃棄ストーンがクリーンアップされる前に削除が反映されない可能性があります
- ドメイン コントローラーがそのドメインの書き込み可能なパーティションをホストする他のドメイン コントローラーに削除を反映する機会が得られ、その変更がグローバル カタログにレプリケートされる前に、変更元のドメイン コントローラーが Active Directory を削除した場合
状況 2: 1126 イベント (NTDS) で報告された 8240
ドメイン コントローラーは、ユニバーサル グループ メンバーシップ参照など、その機能のグローバル カタログの検索を試みます。 システムで使用可能なドメイン コントローラーが見つからない場合は、NTDS イベント ログにエラー 8240 と共にイベント 1126 が報告されます。
解決方法
状況 1: AD レプリケーション中
この問題をトラブルシューティングするには、次の手順に従います。
不整合なオブジェクトを持つ問題のあるドメイン コントローラーを特定します。 このエラーは、ローカル ドメイン コントローラーが、(特定のレプリケーション接続の) 受信パートナーに一貫性のないオブジェクトが存在し、ローカル AD データベースには存在しないことを意味します。
次のように、オブジェクトを削除するか、オブジェクトをそのままにするかを決定します。
オブジェクトを削除する場合は、removeLingeringObjects スイッチと共に Repadmin.exe コマンドを使用して、ソース ドメイン コントローラーからそれらの一貫性のないオブジェクトを削除できます。 詳細については、次の Microsoft TechNet Web サイトを参照してください。
注:
読み取り専用パーティションの場合は、 コマンドを使用
Repadmin /Rehost
する必要があります。これらのオブジェクトを保持する場合は、移行先ドメイン コントローラーで次のオブジェクトを作成できます。
サブキー:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters
値名: 厳密なレプリケーション整合性
値の種類: REG_DWORD
値データ: 0サブキー:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters
値名: 異なるパートナーと破損したパートナーとのレプリケーションを許可する
値の種類: REG_DWORD
値データ: 1サブキー:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters
値名: 不足しているオブジェクトを修正する
値の種類: REG_DWORD
値データ: 1注:
多くのドメイン コントローラーを含む大規模な環境では注意する必要があります。これらの一貫性のないオブジェクトを伝達すると、伝達が完了するまで、ドメイン コントローラーが 8240 エラーを報告する原因となる可能性があるためです。
もう 1 つのオプションは、一貫性のないオブジェクトを含むドメイン コントローラーから Active Directory を強制的に削除することです。 これを行うには、次の手順を実行します。
- Active Directory を強制的に削除する: Active Directory インストール ウィザード (Dcpromo.exe) /forceremoval。
- ドメイン コントローラーの降格が失敗した後に Active Directory のデータを削除する方法に関する 216498 に関する記事の手順に従って、ドメイン コントローラーのメタデータをクリーンアップします
- Dcpromo.exe を使用してドメイン コントローラーを再プロモートします。
状況 2: 1126 イベント (NTDS) で報告された 8240
GC が使用できないことを示すエラーについては、一般に GC の場所プロセスに従ってチェックできます。 これを行うには、次の手順を実行します。
フォレストに指定されたグローバル カタログがあるかどうかを確認します。 ない場合は、GC を構成します。
注:
ドメイン コントローラーを GC としてマークした後、KCC が新しいレプリケーション トポロジを計算し、グローバル カタログを構築し、GC 対応のお知らせを行うのに時間がかかる場合があります。 レプリケーション スケジュール、必要な読み取り専用 NC のレプリケートに使用される時間、KCC actvity の間隔によって異なります。
/DnsGetDC:<DomainName> /GC /Force lTest.exe コマンドを使用して、DNS からドメイン コントローラーを取得できるかどうかを確認します。 DNS で GC レコードを記録できない場合は、次の 2 つのアクションを実行します。
- 既存の GC での GC アナウンス: ldp.exe 使用して GC に接続し、isGlobalCatalogReady の値が true に設定されているかどうかをチェックします。
- DNS 登録: netdiag /fix を確認します。
TCP 3268 経由で ldp.exe 経由で GC に接続できるかどうかを確認します。
データ収集
Microsoft サポートからの支援が必要な場合は、「 Active Directory レプリケーションの問題に TSS を使用して情報を収集する」で説明されている手順に従って情報を収集することをお勧めします。
詳細
詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を表示します。
910204 グローバル カタログ サーバーへのドメイン コントローラーの昇格に関する問題のトラブルシューティング
フィードバック
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