オンプレミス Active Directory から削除されたオブジェクトが、ディレクトリ同期により Microsoft Online Services から削除されていない

適用対象: Azure Active DirectoryCloud Services (Web roles/Worker roles)Azure Backup

現象

以下のシナリオを想定します 。
  • オンプレミス Active Directory オブジェクトがあります。
  • ディレクトリ同期を使用して Active Directory オブジェクトを Microsoft Online Services に同期します。これにより、Microsoft Online Services にリンク オブジェクトが作成されます。
  • オンプレミス Active Directory オブジェクトを削除します。
このシナリオでは、リンク オブジェクトが Microsoft Online Services から削除されない場合を検討します。

原因


この問題は以下のいずれかに当てはまる場合に生じることがあります。
  • ディレクトリ同期がまだ実行されていない。
  • ディレクトリ同期で特定のクラウド オブジェクトが正常に削除されなかったため、Microsoft Online で孤立したオブジェクトとなった。

解決方法


この問題を解決するには、以下の手順に従ってください。
  1. ディレクトリ同期の更新を手動で更新します。この方法については、以下の Microsoft Web サイトを参照してください。

  2. ディレクトリ同期が正常に実行されたことを確認します。この方法については、以下の Microsoft Web サイトを参照してください。

  3. 同期が正常にされたにも関わらず AD オブジェクトが引き続き Microsoft Online に伝播されていない場合は、以下の Windows PowerShell 用 Microsoft Online モジュールのコマンドレットを使用して孤立したオブジェクトを手動で削除することができます。
    Remove-MsolContact

    Remove-MsolGroup

    Remove-MsolUser
    例えば、ディレクトリ同期によって作成された孤立したユーザー ID の john.doe@contoso.com を手動で削除するには、以下のコマンドレットを実行します。

    Remove-MsolUser –UserPrincipalName John.Doe@Contoso.com 

詳細


Windows PowerShell コマンドレットに関する詳細については、以下の Microsoft Web サイトを参照してください。 その他トピックは、Office 365 コミュニティ Web サイトを参照してください。または、Azure Active Directory フォーラム Web サイトを参照してください。