Outlook 2010 で同じメールアドレスのオートコンプリート情報が重複して表示される

現象

Outlook 2010 でオート コンプリート情報が追加される状況によっては、同じメール アドレスでも重複して表示される現象が発生します。

原因

この動作は Outlook 2010 の制限事項となります。

オート コンプリート情報にエントリーが追加される際、各エントリーには様々なプロパティ (ニックネーム、表示名、電子メール アドレス、表示用 SMTP アドレスなど) が設定されます。
そして、オート コンプリート情報にすでに同じエントリーが存在する場合には、古いエントリーが削除され、新しいエントリーが追加されるという動作になります。
この古いエントリーと新しいエントリーが同一であるかどうかの判定は、各エントリーに設定されているプロパティをもとに以下のようなロジックにより行われます。
  • ニックネームが一致し、かつ電子メール アドレスか表示用 SMTP アドレスが一致する
  • 表示名が一致し、かつ電子メール アドレスが一致する

古いエントリーと新しいエントリーの各プロパティの値を比較し、上記のいずれかの条件に合致する場合には、新しいエントリーのみが登録される動作となります。
ただし、オート コンプリート情報の登録状況によっては同じメール アドレスであっても設定されるプロパティの値が異なる可能性があるため、上記の条件に合致しないことがあります。
そしてこの場合には、別々のエントリーとして登録が行われるため、本現象のようにオート コンプリート情報が重複して表示される問題が発生します。

回避策

本現象が発生した場合には、重複している対象のオート コンプリート情報のエントリーを選択して削除するか、下記の手順にてオート コンプリート情報の初期化を実行します。

  1. Outlook 2010 を起動します。
  2. 上部に表示されたリボンの [ファイル] タブを選択します。
  3. 左ペインにて [オプション] を選択します。
  4. 左ペインにて [メール] を選択します。
  5. 右ペインに表示された [オートコンプリートのリストを空にする] を選択します。
  6. [はい] をクリックします。

関連情報

本現象が該当する製品:Outlook 2010
プロパティ

文書番号:2730443 - 最終更新日: 2016/09/29 - リビジョン: 1

フィードバック