Windows Search Service設定の結果、Outlook で一致が見つかりません

元の KB 番号: 2768662

現象

Microsoft Office Outlook でインスタント検索を使用すると、次のメッセージが表示されます。

一致が見つかりません。

これは、メールボックス内のアイテムと一致するアイテムの検索条件を含め、Windows デスクトップ検索 (WDS) が Outlook Data (.pst) ファイルまたはオフライン Outlook データ (.ost) ファイルのインデックスを作成するように構成されている場合でも発生します。

さらに、Outlook で [インデックス作成 の状態] ダイアログを 表示すると、次のいずれかのメッセージが表示されます。

インデックスが作成された項目が 0 個。

Outlook では現在、アイテムのインデックスが作成されています。
# インデックスが作成される残りの項目。

注:

このメッセージのプレースホルダーによって # 表されるインデックス付けされる残りの項目の数が減少することはありません。

Windows コントロール パネルで [インデックス作成オプション] を開くと、この同じメッセージが表示されます。

原因

Windows Search Serviceで [サービスとデスクトップの対話を許可する] オプションが有効になっています。

解決方法

この問題を解決するには、Windows Search Serviceで [サービスがデスクトップと対話することを許可する] オプションを無効にします。 これを行うには、次の手順を実行します。

  1. Outlook を終了します。

    注:

    実行中の場合は、Microsoft Lync または Communicator も終了します。

  2. services.msc を実行します。

  3. Windows Search サービスを右クリックし、[プロパティ] を選択します

  4. [ 停止] を選択し、サービスが停止するまで待ちます。

  5. [ログオン] タブを選択します。

  6. [ サービスがデスクトップと対話することを許可する ] オプションをオフにします。

  7. [適用] を選択します。

  8. [全般] タブを選択 します。

  9. [ 開始] を選択し、サービスが開始されるまで待ちます。

  10. [OK] を選択します。

  11. Outlook を起動します。

詳細

Windows Search Serviceが [サービスによるデスクトップとの対話を許可する] オプションを有効にするように構成されている場合は、次のエラー イベントもアプリケーション ログに記録されます。

ソース: Microsoft-Windows-Search
イベント ID: 3100
タスク カテゴリ: Gatherer
レベル: エラー
説明:
フィルター ホスト プロセスを初期化できません。 終了。
詳細:
タイムアウト期間が切れたため、この操作が返されました。 (0x800705b4)

Outlook 2010 以降のバージョンで [ インデックスの状態] ダイアログを表示するには、次の手順に従います。

  1. Ctrl キーを押しながら E キーを押すか、[検索] テキスト ボックスにカーソルを置いて 検索ツールを有効にします。
  2. [ 検索 ] タブで、[ 検索ツール ] ボタンを選択し、[ インデックス作成の状態] を選択します。

Outlook 2007 で [ インデックス作成の状態] ダイアログを 表示するには、[ ツール ] メニューの [ インスタント検索] を選択し、[ インデックス作成の状態] を選択します。