メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

DirectX プログラムを起動すると、次のエラー メッセージが表示される場合があります。

DirectSound の初期化エラー

原因

サウンド カードまたはコンピューターに現在インストールされているサウンド カードのデバイス ドライバーがサポートしない場合完全 DirectX ハードウェア アクセラレータの設定に、この現象が発生することができます。

解決方法

この問題を解決するには、サウンド カードのハードウェア アクセラレータの設定を減らします。

  1. [スタート] ボタンをクリックし、[設定] をポイントし、[コントロール パネル] をクリックします。

  2. [マルチメディア] をダブルクリックします。

  3. オーディオ] タブをクリックし、[再生] セクションで[詳細プロパティ] をクリックします。

  4. [パフォーマンス] タブをクリックし、ハードウェア アクセラレータ スライダー をフル (標準アクセラレータ設定) の左に 1 目盛り動かし、 [OK] をクリックし、再度 [ OK ] をクリックします。

問題が引き続き発生する場合は、 [なし] (基本アクセラレータ設定) の右側に、ハードウェア アクセラレータ スライダー 1 目盛りに移動するには、この手順を繰り返します。注: [なし]には、スライダーを移動しないでください。引き続きエラーが表示される場合は、サウンド カードが DirectSound アクセラレータをサポートしていることを確認します。サウンド カードが DirectSound アクセラレータをサポートしているかどうかは、次の手順に従います。

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。

  2. Dxdiag.exeを入力し、[ OK] をクリックします。

  3. サウンド] タブをクリックし、[ DirectSound のテスト] ボタンをクリックします。

テストが機能しない場合、サウンド カードの製造元に連絡して、お使いのサウンド カードのドライバーの最新バージョンを入手してインストールする方法について問い合わせてください。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×