現象
Windows Server 2012 のサーバー マネージャーでリモートサーバーを追加するとダッシュボードで Shell Hardware Detection サービスの警告が報告される場合があります。
原因
サーバー マネージャーでは管理対象のサーバーのサービスの状態をスタートアップの種類と現在のステータスで判断します。
既定ではスタートアップの種類が 自動 であるのにも関わらず開始していないサービスについて警告を報告します。
Shell Hardware Detection サービスはスタートアップが自動 ですが、ユーザーのログオン時にしか動作しないサービスです。
そのため、ユーザーがログオンしていない状態では、正常であるのにも関わらずサービスの警告が報告されます。
既定ではスタートアップの種類が 自動 であるのにも関わらず開始していないサービスについて警告を報告します。
Shell Hardware Detection サービスはスタートアップが自動 ですが、ユーザーのログオン時にしか動作しないサービスです。
そのため、ユーザーがログオンしていない状態では、正常であるのにも関わらずサービスの警告が報告されます。
回避策
ユーザーがログオンしていない場合は Shell Hardware Detection サービスの警告を無視しても問題はありません。
警告そのものを報告しないようにするためには、対象サーバーを常にログオン状態にするか、Shell Hardware Detection サービスを監視対象から除外する必要があります。
Shell Hardware Detection サービスを監視対象から除外する方法。
1. ダッシュボードの すべてのサーバー の サービス をクリックします
2. 条件欄の サービス のリストボックスを展開します
3. Shell Hardware Detection サービスのチェックボックスをオフにします
4. OK をクリックして条件設定を閉じます
5. 更新 をクリックして警告が消える事を確認します
警告そのものを報告しないようにするためには、対象サーバーを常にログオン状態にするか、Shell Hardware Detection サービスを監視対象から除外する必要があります。
Shell Hardware Detection サービスを監視対象から除外する方法。
1. ダッシュボードの すべてのサーバー の サービス をクリックします
2. 条件欄の サービス のリストボックスを展開します
3. Shell Hardware Detection サービスのチェックボックスをオフにします
4. OK をクリックして条件設定を閉じます
5. 更新 をクリックして警告が消える事を確認します