新しいテンプレートを使用した証明書の要求が失敗する

重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずシステムの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明

現象

エンタープライズ証明機関 (CA) に対して証明書を登録すると、以下のエラー メッセージのいずれかが表示されることがあります。


Web 登録
証明書の要求は拒否されました


証明書の要求は拒否されました。


詳細情報については管理者に問い合わせてください。

証明書の要求ウィザード
証明機関は要求を拒否しました。未定義のエラーです。

原因

この問題は、作成された直後の証明書テンプレートを証明書の登録要求で使用した場合に発生することがあります。新しいテンプレートが CA に追加されると、HKEY_CURRENT_USER キャッシュはすぐに更新されますが、HKEY_LOCAL_MACHINE キャッシュはすぐには更新されません。HKEY_LOCAL_MACHINE キャッシュの更新は、CA またはドメイン コントローラが同じコンピュータにある場合は 15 分以内、CA またはドメイン コントローラが分散構成である場合は 10 分以内です。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。


適用時間まで待てない場合に、この問題を解決するには、証明書テンプレートのキャッシュを手動で更新します。コンピュータ証明書に使われるキャッシュは HKEY_LOCAL_MACHINE にあり、ユーザー証明書に使われるキャッシュは HKEY_CURRENT_USER にあります。
  • ユーザー証明書の要求で強制的にキャッシュを更新するには、クライアントから次のレジストリ値を削除します。
    HKEY_CURRENT_USER\Software\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
コンピュータ証明書の要求で強制的にキャッシュを更新するには、以下の手順を実行します。
  1. クライアントから次のレジストリ値を削除します。
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  2. CA から次のレジストリ値を削除します。
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  3. CA の証明書サービスを再起動します。

詳細

前述のエラー メッセージに加えて、CA はプログラム ログに次のイベント メッセージを記録します。
プロパティ

文書番号:281260 - 最終更新日: 2008/01/13 - リビジョン: 1

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