AD RMSにより暗号化されたファイルを開く際に時間がかかる場合がある

適用対象: Microsoft Office 2010 Service Pack 2

現象


プロキシサーバーを経由して、インターネットに接続するコンピューターを使用しています。
このとき、IRM 機能 を利用して暗号化した ファイルを開く際に時間がかかる現象が発生する場合があります。
(文書が開かれるまでにかかる時間は環境によって異なります。)

例えば、Excel ファイルなどの Office アプリケーションのファイルや、PDF、XPS をはじめとした AD RMS による暗号化に対応したファイルを開く際に現象が発生します。

原因


アプリケーションが  AD RMS の機能を使用する際、使用する実行モジュール(DLL ファイル等)の署名を行った証明書の確認が行われます。
証明書を確認する際、Windows の暗号化サービスにて、証明書に記載された失効リスト配布ポイントにアクセスしますが、このとき失効リストの配布ポイントへアクセスできない場合は、接続タイムアウトとなります。
この接続のタイムアウトを待つために、文書を開く動作が遅延します。 

解決方法


Windows の暗号化サービスがプロキシサーバーを経由して、失効リストのダウンロードを行えるようにします。
これを行うには、管理者としてコマンドプロンプトを起動し、以下のコマンドを実行します。 

  netsh winhttp import proxy source=ie

このコマンド は、Internet Explorer のプロキシ設定を、 Windows の暗号化サービスが使用する WinHTTP コンポーネントにコピーするものです。
これにより、Windows の暗号化サービスが、失効リストのダウンロードができます。 

詳細


失効リストのダウンロードは、 AD RMSによる暗号化されたファイルを開く動作中、署名を行った証明書に失効リストの配布ポイントの URL が記載されていれば必ず行われます。
しかし、失効リストのダウンロードがタイムアウトとなり、失効リストが得られない場合でも、対象の証明書は無効とはみなされません。このため AD RMS の機能を利用するアプリケーションは動作を継続し、文書の復号が可能です。