Excel for Mac で個人用マクロ ブックを作成する方法

概要

この資料では、記録できない Microsoft Visual Basic for Applications (VBA) マクロの作成と編集を行うために、個人用マクロ ブックを作成する方法について説明します。

詳細

個人用マクロ ブックを作成する方法

個人用マクロ ブックを作成する一番簡単な方法は、"dummy" マクロを記録することです。この手順は次のとおりです。

  1. Excel を起動して、新しいブックだけを開きます。[ツール] メニューの [マクロ] をポイントし、[新しいマクロの記録] をクリックします。
  2. [マクロの記録] ダイアログ ボックスで、[マクロの保存先] ボックスの一覧の [個人用マクロ ブック] をクリックします。
  3. [OK] をクリックします。"dummy" マクロを作成するので、何も入力したりクリックしたりしないでください。
  4. 表示されるツール バーの [記録終了] ボタンをクリックします。
  5. [Excel] メニューの [Excel を終了] をクリックします。Excel X よりも前のバージョンでは、[ファイル] メニューの [終了] をクリックします。
  6. 変更を保存するかどうかを確認するメッセージが表示されたら、[保存] をクリックします。
Excel を起動すると、この個人用マクロ ブックは表示されないファイルとして開かれます。このファイルは、デフォルトでは Excel のバージョンに応じて、以下のパスに保存されます。


Excel 98 および Excel 2001
Microsoft Office folder:Office:Startup:Excel:個人用マクロ ブック
Excel X 以降のバージョン
Hard disk drive:アプリケーション:Microsoft Office version:Office:Startup:Excel:個人用マクロ ブック

個人用マクロ ブックを使用する方法

個人用マクロ ブック内の VBA コードを作成または編集するには、以下の手順を実行します。

  1. [ツール] メニューの [マクロ] をポイントし、[Visual Basic Editor] をクリックします。
  2. [プロジェクト - VBAProject] ウィンドウ (Excel X の場合は [プロジェクト]) で、[VBAProject (個人用マクロ ブック)] をダブルクリックして、[モジュール] フォルダを表示します。
  3. [モジュール] フォルダをダブルクリックしてこのプロジェクトのモジュールを表示し、モジュールをダブルクリックしてコードまたは空白のコード シートを表示します。


    このコード シートを使用して、VBA コードの作成および編集を行えます。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 288117 (最終更新日 2005-08-15) を基に作成したものです。
プロパティ

文書番号:288117 - 最終更新日: 2006/10/11 - リビジョン: 1

フィードバック