日本語のホスト名またはユーザー名の場合、RD ゲートウェイ サーバー経由での RDP 接続に失敗する事があります

適用対象: Windows Server 2008 R2 DatacenterWindows Server 2008 R2 EnterpriseWindows Server 2008 R2 Standard

現象


リモート デスクトップ ゲートウェイ サーバー 経由にて セッション ホスト サーバー に接続した際に、[このコンピューターはリモート コンピューターに接続できません。接続先のリモート コンピューター でエラー が発生しました。サポートが必要な場合は、ネットワーク管理者に問い合わせてください。]
とポップアップが表示され、接続できない場合があります。

また、 接続先のサーバーのイベント ログに以下のログが記録されます。

エラー,201,Microsoft-Windows-TerminalServices-Gateway,
"クライアント コンピュータ ""xxx.xxx.xxx.xxx"" 上のユーザー " "xxxxxxxxxx" は接続承認ポリシーの要件を満たしていないため、ゲートウェイ サーバーへのアクセスを承認されませんでした。
次の認証方法が試用されました: ""NTLM""。次のエラーが発生しました: ""122""。"

リモート デスクトップ ゲートウェイ サーバー の接続承認ポリシーを満たしていても、ホスト名または接続時に使用するユーザー名が、日本語等の MultiByte 文字のクライアントからの接続の場合、接続できない事があります。

原因


リモート デスクトップ ゲートウェイ サーバー では、接続元のホスト名や接続時に使用するユーザー名を変換する処理において、日本語等のアルファベット以外の MultiByte 文字が含まれている場合、正しく変換できず、接続に失敗する事があります。

解決方法


接続元クライアントのホスト名および接続時に使用するユーザー名を英語 (アルファベット) で設定します。

- 参考情報
Active Directory 内のコンピューター、ドメイン、サイト、および Ou の名前付け規則
http://support.microsoft.com/kb/909264/ja