For Mac、Word がマクロ ウイルスに感染している場合の対処方法

概要

この資料では、マクロ ウイルスとはどのような Word マクロ ウイルスがありますと思われる場合の対処方法と、ドキュメントの操作を行いますになるに感染していないマクロ ウイルスに感染することを確認する方法について説明します。

詳細

1995 年の夏に最初のマクロ ウイルスが発見されました。それ以来、その他のマクロ ウイルスが表示されています。

マクロ ウイルスは、Word などのプログラムのマクロ言語を使用して書き込まれる悪意のあるプログラムです。ウイルス自体をデータ ファイル間で伝達され、ファイルまたはコンピューターのオペレーティング システムに損害を与えることができます。

インターネットやその他のメディアで Word マクロ ウイルスが自由に送信されません。文書またはマクロ ウイルスが含まれるテンプレートを開いたときにだけ転送できます。

マクロ ウイルスは、影響を受けるドキュメントが電子メール メッセージに埋め込まれているし、受信者がドキュメントを開く場合を除き、電子メールで転送できません。

マクロ ウイルスの症状

Word と Word に影響を与えることがわかっている Word マクロ ウイルスのいくつかの現象は、次のドキュメント。
  • 文書を保存しようとすると、Word のみすることができます文書をテンプレートとして保存します。

    - または -
  • ファイルのアイコンは、ドキュメントではなく、テンプレートのように見えます。

    - または -
  • ドキュメントを開くと、数字の 1 を表示するダイアログ ボックスが表示されます。

    - または -
  • マクロユーザー設定のコマンドが [ツール] メニューに表示されません。

    - または -
  • 新しいマクロは、マクロの一覧に表示されます。FileSaveAs AutoOpen マクロが表示されることも。これらの名前で既にマクロが場合、は、マクロ ウイルスの内容を変更すること。

    - または -
  • Word 文書またはテンプレートを開くと、異常なまたは予期しないメッセージが表示されます。
注:
  • Word は、マクロ ウイルスを検索したりしないとテンプレートを既存のドキュメントからすべてのマクロ ウイルスを削除します。だけに警告が表示する開いているドキュメントにマクロが含まれているかどうか。作業中のマクロを含むドキュメントを開くか、マクロを無効にして開きます。開かないでくださいドキュメント、アクティブなマクロを含む文書に有害なマクロ ウイルスが含まれていないことを確認する場合を除いて、です。
  • サード ・ パーティ製ウイルス対策プログラムは、常に有効に頻繁に更新する必要があります。更新プログラムについてベンダーに問い合わせてください。

ウイルス対策プログラムをインストールします。

長期的な解決策をマクロ ウイルス、マクロ ウイルスの検出に特化したウイルス対策ソフトウェアをインストールします。ウイルス対策ソフトウェア ベンダーの詳細については、ソフトウェアを検出し、マクロ ウイルスを防止する機能を含むをクリックして、マイクロソフト サポート技術情報の資料を参照するのには次の文書番号:

ウイルス対策ソフトウェア ベンダーのリストを49500

他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、この連絡先情報は予告なしに変更される場合があります。マイクロソフトは、掲載されている情報に対して、いかなる責任も負わないものとします。

コンピューターがマクロ ウイルスに感染している恐れがあると思われる場合の対処方法

マクロ ウイルスを必要がありますだけのときは、コンピューターの一時的なソリューションとしては、以下の方法を使用します。

方法 1: マクロを無効にして、テキストを新しいドキュメントにコピーします。

この資料の前半で説明した現象は発生しません、マクロ ウイルスの影響を受けるにしたくない場合は、キーを押しながら、shift キーをマクロ ウイルスに感染した可能性があるファイルを開きます。Shift キーを押し、Word の自動マクロが実行されません。マクロ ウイルスが存在する場合、それが読み込まれていません。

方法 2: マクロを削除し、ドキュメントの回復

、この資料の前半で説明した現象が発生する場合、またはこの資料に記載されていないマクロ ウイルスがあることが疑われる場合は、疑いのあるマクロを削除し、影響を受けるドキュメントを修正するのには、次の手順に従います。

注: これは、一時的なソリューションだけです。新しいマクロが作成されているため新しいマクロで次の手順に機能しません。

  1. ] メニューの [Word] をクリックし、[終了] をクリックします。通常のファイルをデスクトップに移動します。これを行うには。
    1. すべての Microsoft プログラムを終了します。
    2. [Finder] メニューの [ホーム移動] をクリックします。
    3. [ライブラリ] フォルダーを開きます。
    4. アプリケーションのサポートフォルダーを開きます。
    5. Microsoft フォルダーを開きます。
    6. Officeフォルダーを開きます。
    7. ユーザー テンプレートフォルダーを開きます。
    8. 通常のファイルを右クリックします。[編集] をクリックし、"Normal.dotm"のコピー] を選択します。

  2. Word を起動します。[ファイル] メニューの [開く] をクリックします。
  3. 影響を受けるファイルを含むフォルダーに移動します。
  4. 影響を受けるファイルを選択] をクリックします。すぐにキーを押して SHIFT キーを押しし、し、[開く] をクリックします。影響を受けるファイルが Word で開くまで、SHIFT キーを押し続けます。

    注: ファイルを開くときに SHIFT キーを押し、Word の自動マクロが実行できなくなります。
  5. 疑いのあるマクロを削除するには、次の手順を使用します。
    1. [ツール] メニューで、マクロ] をポイントし、[マクロ] をクリックします。
    2. マクロの保存先ポップアップ メニューで、すべてのアクティブなテンプレートとドキュメントを選択します。
    3. 疑いのあるマクロを選択し、[削除] をクリックします。されたら [はい]をマクロを削除するかどうかをクリックします。
    4. 疑いのあるすべてのマクロに対して、手順 c. を繰り返します。
    5. [マクロ] ダイアログ ボックスを閉じますキャンセルをクリックします。
  6. ウイルスに感染したドキュメントのテキストを回復するには、以下の手順を実行します。
    1. コマンド キーを押しながら A キーを押すか、[編集] メニュー、 [すべて選択] をクリックして、文書全体を選択します。
    2. SHIFT + 左向き矢印キーを押し、選択範囲から文書の最後の段落記号を削除します。
    3. [編集] メニューの [コピー] をクリックします。
    4. [ファイル] メニューの [新規を] をクリックします。を使用するテンプレートを選択し、し、[ OK] をクリックします。
    5. [編集] メニューの [貼り付け] をクリックします。
    6. ウイルスを含むマクロがレプリケートされていないことを確認するのには手順 7 を繰り返します。
    7. ドキュメントを保存します。
  7. マクロ ウイルスが含まれている疑いがある任意のドキュメントには、この手順を繰り返します。
注: 方法 2 が動作しない場合は、方法 3 を実行してください。

方法 3: マクロ ウイルスを一時的にクリーンアップする構成内容変更を使用します。

マクロ ウイルスをクリーンアップするには、開催者を使用します。場合は、ウイルスに感染したファイルを開いた後でほかのファイルを開くと、これらのファイル可能性がありますが感染していることにも留意してください。

標準テンプレートからウイルスを削除するには、次の手順を実行します。
  1. すべてのドキュメントを閉じます。感染した文書が開かれている場合、簡単に再感染する可能性が標準のテンプレート。
  2. [ツール] メニューで、[テンプレートとアドイン] と、[構成内容変更] ボタンをクリックします。
  3. マクロ プロジェクト項目] タブをクリックしての名前を変更するか、以下のマクロをすべて削除します。
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • [Filesave]
    • FileSaveAs
    • マクロ
    • ToolsMacro
  4. [閉じる] をクリックします。
  5. Shift キーを押しながら、テンプレートを保存するのには [ファイル] メニューのすべてを保存をクリックします。
感染した文書からマクロ ウイルスを削除します。

ファイルが感染している場合、1 5 からの手順と同じ方法を使用してですが、標準のテンプレートの両方ともウイルスに感染した文書 (テンプレート) が、開催者の中に、マクロを削除します。完了したら、shift キーを押し、[ファイル] メニューの [すべてを保存] をクリックして次のファイルに移動中です。ウイルスに感染したファイルを開くたびに感染して、標準のテンプレートでは、標準テンプレートから繰り返しマクロを削除する必要がありますので注意してください。

方法 4: ウイルスに感染したファイルを新しい文書に挿入します。

このメソッドは、 [ツール] メニューからマクロユーザー設定が削除され、「キャップ」のマクロ ウイルスで特に便利です。

注: このような場合テンプレートとアドイン] 、[ツール] メニューの動作しません。

  1. ] メニューの [Word] をクリックし、[終了] をクリックします。標準テンプレートをデスクトップに移動します。これを行うには。
    1. すべての Microsoft プログラムを終了します。
    2. [Finder] メニューの [ホーム移動] をクリックします。
    3. [ライブラリ] フォルダーを開きます。
    4. アプリケーションのサポートフォルダーを開きます。
    5. Microsoft フォルダーを開きます。
    6. Officeフォルダーを開きます。
    7. ユーザー テンプレートフォルダーを開きます。
    8. 通常のファイルを右クリックします。[編集] をクリックし、"Normal.dotm"のコピー] を選択します。

  2. Word を起動し、確認し、そのマクロとユーザー設定[ツール] メニューが表示されます。
  3. 新しいドキュメントを開きます。[挿入] メニューの [ファイル] をクリックします。
  4. 影響を受けるファイルを含むフォルダーに移動します。
  5. 影響を受けるファイルを選択] をクリックします。
  6. SHIFT キーを押しし、[開く] をクリックします。影響を受けるファイルが Word で開くまで、SHIFT キーを押し続けます。
    注: SHIFT キーを押しながらファイルを開くときに Word の自動マクロが実行できなくなります。
  7. ([なし] が表示されます)、新しい文書ですべてのマクロが存在するかどうかを確認するのには、[ツール] メニューの [マクロ] をポイントし、[マクロ] をクリックします。マクロ ポップアップ ボックスの一覧すべてのアクティブなテンプレートとドキュメントをクリックします。[マクロ名] マクロは表示されません。[キャンセル] をクリックします。
  8. 別のファイル名でファイルを保存します。
  9. ウイルスに感染したファイルを削除します。

方法 5: rtf 形式の回避策を使用します。

A. では、標準 (テンプレート) ファイルを削除します。

これは、標準テンプレートに保存されているマクロを使用して問題です。

以下の手順では、標準テンプレートを削除します。標準テンプレートの特殊な書式設定セットを削除するとなるテンプレートは、既定の設定にリセットされます。
  1. すべての Microsoft プログラムを終了します。
  2. [Finder] メニューの [ホーム移動] をクリックします。
  3. [ライブラリ] フォルダーを開きます。
  4. アプリケーションのサポートフォルダーを開きます。
  5. Microsoft フォルダーを開きます。
  6. Officeフォルダーを開きます。
  7. ユーザー テンプレートフォルダーを開きます。
  8. という名前のファイルを検索する標準です。[ファイル] をクリックし、ごみ箱に移動] をクリックします。

B. は、マクロを無効にします。

ウイルス ファイルを開くし、マクロ警告が表示されるように各ファイルにマクロを無効にします。警告が表示されない場合は、マクロの警告を有効にする必要があります。これを行うには、以下の手順を実行します。
  1. クリックしてWord ] メニューの [設定します
  2. ナビゲーション ウィンドウでセキュリティ]をクリックし、マクロを含むファイルを開く前に警告する] チェック ボックスを選択し、します。

C. では、既存のファイルを保存します。

  1. [ファイル] メニューの [名前を付けて保存をクリックします。
  2. 形式] ボックスの一覧では、リッチ テキスト形式 (RTF)をクリックします。
  3. [保存] をクリックします。

RTF ファイルとしてファイルを保存した後 Word (.doc) 形式で文書を再度保存して、マクロ ウイルスに感染したファイルを上書き、新しいファイルとして文書を保存や、ウイルスを含む古いファイルを削除します。.Doc 形式で新しいファイルを保存した後は、rtf 形式のファイルを削除できます。いくつかの書式設定要素が word 文書 (.doc) 形式から RTF への移行で保持されません可能性があります注意してください。


プロパティ

文書番号:291824 - 最終更新日: 2017/02/01 - リビジョン: 1

Microsoft Word 2011 for Mac, Microsoft Word 2004 for Mac

フィードバック