メールボックスを Exchange Online から Exchange Server 2010 に移動するときの MigrationPermanentException エラー

元の KB 番号: 2932443

注:

Microsoft Exchange Server 2010 のExchange 管理コンソールに含まれるハイブリッド構成ウィザードはサポートされなくなりました。 そのため、古いハイブリッド構成ウィザードは使用しなくなります。 代わりに、 Microsoft 365 ハイブリッド構成ウィザードを使用します。 詳細については、「 Microsoft 365 ハイブリッド構成ウィザード for Exchange 2010」を参照してください。

現象

オンプレミスの Exchange 2010 サーバーを含む Exchange ハイブリッド展開があるとします。 Exchange Onlineからオンプレミス環境の Exchange 2010 サーバーにメールボックスをオフボードまたは移動しようとすると、次のエラー メッセージが表示されます。

エラー: MigrationPermanentException:

ユーザーのインスタント メッセージング連絡先リストが Exchange に保存されている間は、メールボックス '<username>' を Exchange 2010 以前のバージョンに移行しないでください。 その場合、ユーザーはインスタント メッセージング連絡先リストへのアクセスを完全に失う可能性があり、これにより重大なデータ損失が発生します。 Exchange のコピーは、このユーザーの連絡先リストの唯一のコピーである可能性があります。 続行するには、インスタント メッセージング管理者に問い合わせて、ユーザーの連絡先リストがインスタント メッセージング サーバーに戻っていることを確認してください。 これが完了すると、この移行を完了できます。 データ損失の可能性があるにもかかわらずメールボックスを移行する必要がある場合は、'Set-UMMailbox mailboxID -ImListMigrationCompleted $false' を実行します。

ただし、エラー メッセージに Set-UMMailbox mailboxID -ImListMigrationCompleted $false 記載されているコマンドレットを実行すると、次のエラー メッセージが表示されます。

メールボックス <ユーザー名>@contoso.com は、ユニファイド メッセージングでは有効になっていません。

原因

これは、メールボックスに関連付けられているユーザーの Lync 2013 連絡先が Exchange の統合連絡先ストアに格納されている場合に発生します。 既定では、ユーザーが Lync 2013 にサインインした場合、そのユーザーに対して統合連絡先ストアが有効になります。 さらに、ユーザーの Lync 連絡先は Lync サーバーから Exchange に移行されます。

解決方法

重要

現在、ImListMigrationCompletedパラメーターは Exchange Server (オンプレミス) でのみ使用できます。 PST ファイルをExchange Onlineメールボックスにインポートする方法の詳細については、organizationの PST ファイルのインポートの概要に関するページを参照してください。

コマンドレットの代わりに、 Set-Mailbox コマンドレットを ImListMigrationCompleted パラメーターと共に Set-UMMailbox 使用します。 たとえば、次のコマンドレットを実行します。

Set-Mailbox John@contoso.com -ImListMigrationCompleted $false

コマンドレットを実行した後、メールボックスの移動要求を実行します。

注:

パラメーターのImListMigrationCompleted設定は$false、連絡先リストを保持するためにユーザーの連絡先が Lync に移行されていないことを示します。 このセクションのソリューションでは、データが失われる可能性があることに注意してください。 Exchange Server 2010 では、Lync 2013 の統合連絡先ストア機能はサポートされていません。 そのため、ユーザーの Lync 連絡先が統合連絡先ストアに格納されている間にメールボックスを 2010 Exchange Serverに戻すと、ユーザーは Lync 連絡先にアクセスできなくなる可能性があります。 メールボックスを 2010 年Exchange Serverに移動する前に、まずユーザーの Lync 連絡先が Lync サーバーに戻っていることを確認する必要があります。

詳細

Microsoft 365 のExchange Onlineにメールボックスを移動するときに問題が発生した場合は、Microsoft 365 メールボックス移行のトラブルシューティング ツールを実行できます。 この診断は、自動化されたトラブルシューティング ツールです。 既知の問題が発生している場合は、問題が発生したことを示すメッセージが表示されます。 メッセージには、ソリューションを含むアーティクルへのリンクが含まれています。 現在、このツールはインターネット エクスプローラーでのみサポートされています。

さらにヘルプが必要ですか? 「Microsoft コミュニティ」または「Microsoft Q&A」にアクセスしてください。