MAPI over HTTP を使用すると、Outlook 2010、2013、2016 で Exchange に正しく接続できない

適用対象: Exchange Server 2016 Enterprise EditionExchange Server 2016 Standard EditionExchange Server 2013 Service Pack 1

現象


次のような状況を想定します。
  • Microsoft Outlook 2010 を使用しています。
  • Microsoft Outlook 2013 Service Pack 1 (SP1) またはそれ以降のバージョンを使用しています。
  • Microsoft Exchange Server 2013 Service Pack 1 (SP1) または Microsoft Exchange Server 2016 のメールボックスに接続しています。
  • 接続しているすべての Exchange メールボックスおよびクライアント アクセス サーバー (CAS) には、Exchange Server 2013 SP1 またはそれ以降のバージョンか、Microsoft Exchange Server 2016 がインストールされています。
  • MapiHttp 接続の確立に必要なサーバー設定は正しく構成されています。
このような状況では、[Outlook の接続状態] ダイアログ ボックスの [プロトコル] 列には、Outlook 2013 が MAPI over HTTP 以外の方法で Exchange Server に接続していることが示されています。 たとえば、次の図では、RPC over HTTP を使用して接続していることを示しています。

注: MAPI over HTTP 接続を使用している場合は、[プロトコル] 列に "HTTP" の文字列が表示されていまする。 

さらに、MAPI over HTTP 接続が無効になっている場合は、先進認証ではなく、基本認証のプロンプトが Office 365 ユーザーに表示されます。

原因


この問題が発生する可能性があるのは、次のレジストリ キー値を使用して Outlook クライアントで MapiHttp 機能が無効化されている場合です。
キー: HKEY_CURRENT_USER\Software\Microsoft\Exchange
DWORD: MapiHttpDisabled
: 1

解決方法


この問題を解決するには、MapiHttpDisabled の値を 0 (ゼロ) に変更するか、MapiHttpDisabled の DWORD 値を削除します。 このレジストリ データは検証のみを目的とするものです。
  1. Outlook を終了します。
  2. レジストリ エディターを開きます。 それには、使用している Windows のバージョンに応じて、以下のいずれかの方法を使用します。
    • Windows 10、Windows 8.1、Windows 8 の場合: Windows キーを押しながら R キーを押して [ファイル名を指定して実行] ダイアログ ボックスを開きます。 「regedit.exe」と入力し、[OK] をクリックします。
    • Windows 7 の場合: [スタート] ボタンをクリックし、検索ボックスに「regedit.exe」と入力し、Enter キーを押します。

  3. レジストリで、次のキーを見つけて選択します。

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
  4. [MapiHttpDisabled] を右クリックし、[修正] をクリックします。
  5. [値のデータ] を 0 に変更し、[OK] をクリックします。
  6. レジストリ エディターを終了します。
  7. Outlook を起動します。

詳細情報


MAPI over HTTP 接続の要件の詳細については、次のマイクロソフト TechNet Web サイトを参照してください。