Exchange Online の他ユーザーの予定表で空き時間情報を確認できない

適用対象: Exchange OnlineOutlook 2016Outlook 2019

問題


Exchange Online で特定ユーザーの空き時間情報を確認できません。 この問題は Outlook Web App および Microsoft Outlook (Outlook for Mac 2011 を含む) で発生しています。 具体的には、以下の現象が発生します。
  • Outlook から、あるユーザーの予定表を確認しようとすると以下のエラー メッセージが表示されます。
    更新できませんでした

    ユーザーのカレンダーのスクリーン ショット "">
  • 同じく Outlook Web App から確認しようとすると、感嘆符付きの赤い三角が表示されます。 
    感嘆符付きの赤い三角を表示するユーザーのカレンダーのスクリーン ショット

原因


この問題は、1,000 を超えるアイテムが入力されたタイム スロットが予定表に存在する場合に発生します。 

解決方法


不要なアイテムを削除し、1 つのタイム スロットへの入力アイテム数を 1,000 以下にします。

詳細


この問題に該当するか否かを確認するには、以下の手順を実行してください (Outlook 2010 または Outlook 2007 を使用中の場合)。
  1. Outlook のトラブルシューティングのログ記録を有効にします。 方法は以下の Microsoft Knowledge Base 資料で確認してください。
    831053 トラブルシューティング Outlook のメールのログ記録を有効にするオプションをオンにする方法
  2. %temp%\OLkAS フォルダーで、ファイル名が “<date>-<time>-AS.log” または “<date>-<time>-fb.log” の空き時間情報サービスのログを検索します。
  3. 次のような入力があるログ ファイルを検索します。
    <MessageResponseClass="Error"><MessageText>Microsoft.Exchange.InfoWorker.Common.Availability. ResultSetTooBigException: The result set contains too many calendar entries. The allowed size = 1000; the actual size = <xxxx>
    <xxxx> プレースホルダに表示された数字を控えます。 発生中の現象が本問題に該当する場合は、この数字が 1,000 より大きくなります。 
さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。