Visio 図面を他の Office プログラムに貼り付けるまたは挿入する方法

はじめに

この資料では、Microsoft Visio 図面からオブジェクトをコピーして、他のプログラムに貼り付ける複数の方法について説明します。



オブジェクトを Visio から別のプログラムにコピーするには、状況に応じて以下のいずれかの方法を使用します。



先頭に戻る

方法 1 : [種類によって選択] または [種類を指定して選択] を使用する

Microsoft Office Visio 2007、Microsoft Office Visio 2003、および Microsoft Visio 2002 では、[種類によって選択] を使用できます。Microsoft Visio 2000 では、[種類を指定して選択] を使用できます。[種類によって選択] または [種類を指定して選択] を使用するには、次の手順を実行します。

  1. Visio を起動して、図面を開きます。

  2. Visio 2007、Visio 2003、または Visio 2002 では、[編集] メニューの [種類によって選択] をクリックします。Visio 2000 の場合は、[種類を指定して選択] をクリックします。

  3. [種類によって選択] ダイアログ ボックスまたは [種類を指定して選択] ダイアログ ボックスで、次のいずれかの手順を実行します。

    • [図形の種類] をクリックします。次に、以下のチェック ボックスをオンまたはオフにします。

      • 図形
      • グループ

      • ガイド

      • OLE オブジェクト

      • メタファイル
      • ビットマップ
      Visio 2003 では、次の図形の種類も利用できます。

      • インク オブジェクト

    • [レイヤ] をクリックしてから、レイヤの隣にある必要なチェック ボックスをオンにします (またはレイヤ名をクリックします)。

  4. [OK] をクリックします。

  5. [編集] メニューの [コピー] をクリックします。

  6. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。



    たとえば、Visio オブジェクトを Microsoft Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。

  7. [編集] メニューの [貼り付け] または [形式を選択して貼り付け] をクリックし、Visio オブジェクトを挿入します。

先頭に戻る

方法 2 : [すべて選択] を使用する

[すべて選択] を使用するには、次の手順を実行します。

  1. Visio を起動して、図面を開きます。

  2. [編集] メニューの [すべて選択] (または、[すべてを選択]) をクリックします。

  3. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。



    たとえば、Visio オブジェクトを Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。

  4. [編集] メニューの [貼り付け] または [形式を選択して貼り付け] をクリックし、Visio オブジェクトを挿入します。

先頭に戻る

方法 3 : [図面のコピー] を使用する

[図面のコピー] を使用するには、次の手順を実行します。

  1. Visio を起動して、図面を開きます。

  2. Visio で何も選択されていないことを確認します。

  3. [編集] メニューの [図面のコピー] をクリックします。



    これによって、表示している図面のページがコピーされます。

  4. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。


    たとえば、Visio オブジェクトを Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。

  5. [編集] メニューの [貼り付け] または [形式を選択して貼り付け] をクリックし、Visio オブジェクトを挿入します。

先頭に戻る

方法 4 : Visio 図面をグラフィック ファイルとして保存する

Visio 図面をグラフィック ファイルとして保存するには、次の手順を実行します。

  1. Visio を起動して、図面を開きます。

  2. コピーするオブジェクトを選択します。



    : 図面のページ全体をコピーする場合は、Visio の図面でオブジェクトが何も選択されていないことを確認します。図面のオブジェクトを選択すると、選択したオブジェクトだけが結果のグラフィック ファイルに表示されます。

  3. [ファイル] メニューの [名前を付けて保存] をクリックします。

  4. [ファイルの種類] ボックスの一覧から、保存するグラフィック ファイルの種類をクリックし、[保存] をクリックします。次に示すグラフィック ファイルの種類は、Visio 2007、Visio 2003、Visio 2002、および Visio 2000 で共通のものです。これら共通のグラフィック ファイルの種類が [ファイルの種類] ボックスに表示されます。

    • 拡張メタファイル (*.emf)
    • グラフィックス インターチェンジ形式 (*.gif)
    • JPEG ファイル インタージェンジ形式 (*.jpg)
    • ポータブル ネットワーク グラフィックス (*.png)
    • TIFF (*.tif)
    • 拡張圧縮メタファイル (*.emz)
    • Windows ビットマップ (*.bmp、*.dib)
    • Windows メタファイル (*.wmf)
    Visio 2007 および Visio 2003 の場合、共通のグラフィック ファイルの種類の他に次のグラフィック ファイルの種類も表示されます。

    • スケーラブル ベクタ グラフィックス - 圧縮 (*.svgz)
    • スケーラブル ベクタ グラフィックス (*.svg)
    Visio 2002 および Visio 2000 の場合、共通のグラフィック ファイルの種類の他に次のグラフィック ファイルの種類も表示されます。

    • Macintosh PICT Format (*.pct)
    • Zsoft PC Paintbrush Bitmap (*.pcx)
    • Adobe Illustrator File (*.ai)
    • Computer Graphics Metafile (*.cgm)
    • Encapsulated PostScript File (*.eps)
    • Postscript File (*.ps)
    • IGES Drawing File Format (*.igs)
    : [名前を付けて保存] ダイアログ ボックスを使用して図形または図面オブジェクトをエクスポートすると、[出力オプション] ダイアログ ボックスが表示されることがあります。このダイアログ ボックスでは、エクスポート先のファイルの設定を指定できます。[出力オプション] ダイアログ ボックスに表示されるオプションは、使用するグラフィック ファイルの形式によって異なります。

  5. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。



    たとえば、Visio オブジェクトを Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。

  6. [挿入] メニューの [図] をポイントし、[ファイルから] をクリックします。

  7. Visio から保存したグラフィック ファイルを選択して、[挿入] をクリックします。



    : この方法では、図形、テキスト、塗りつぶしの書式は保持されます。ただし、レイヤ プロパティは維持されません。たとえば、図形が非表示レイヤに指定された場合、グラフィック ファイルを挿入すると、その図形は表示されなくなります。

先頭に戻る

方法 5 : Visio 2000 で [Visio 図面を挿入] ボタンを使用する

この方法は、Visio 2000 のみに適用されます。[Visio 図面を挿入] をインストールして使用するには、次の手順を実行します。

  1. Microsoft Word、Microsoft Excel、および Microsoft PowerPoint のツール バーに [Visio 図面を挿入] をインストールするには、"Visio ボタンを挿入" プログラムを実行します。通常、このプログラムは次のフォルダにあります。

    C:\Program Files\Visio\System\Custom
  2. [Visio 図面を挿入] を使用するには、[Visio 図面を挿入] ボタンをクリックしてから、[図面の種類の選択] ダイアログ ボックスの [テンプレートの参照] をクリックします。

  3. [テンプレートの選択] ダイアログ ボックスで、[ファイルの種類] ボックスの一覧の [図面 (*.vsd)] をクリックします。インポートする図面をクリックしてから [開く] をクリックします。



    : レイヤがロックされている場合や、非表示になっている場合は、まず、レイヤの非表示やロックを解除して、図面のすべての要素を取り込むようにします。

先頭に戻る

関連情報

Visio 2007 での Visio の図形や図面のエクスポートに使用できる形式の詳細については、Visio 2007 のヘルプを参照してください。これを行うには、[ヘルプ] メニューの [Microsoft Office Visio ヘルプ] をクリックして、[検索] ボックスに図形のエクスポート可能な形式と入力し、Enter キーを押してトピックの内容を表示します。

Visio 2003 での Visio の図形や図面のエクスポートに使用できる形式の詳細については、Visio 2003 のヘルプを参照してください。これを行うには、[ヘルプ] メニューの [Microsoft Office Visio ヘルプ] をクリックして、[検索] ボックスに図形のエクスポート可能な形式と入力し、Enter キーを押してトピックの内容を表示します。



Visio 2002 での Visio の図形や図面のエクスポートに使用できる形式の詳細については、Visio 2002 のヘルプを参照してください。これを行うには、[ヘルプ] メニューの [Microsoft Visio ヘルプ] をクリックして、アンサー ウィザードの [何について調べますか] ボックスに図形のエクスポートと入力し、Enter キーを押してトピックの内容を表示します。



図形を Visio 2000 から他のプログラムにコピーする方法の詳細については、[ヘルプ] メニューの [Visio ヘルプ] をクリックし、[検索] タブの [キーワードを入力してください] ボックスにコピー コマンドと入力し、[検索] をクリックして表示されるトピックを参照してください。



先頭に戻る
プロパティ

文書番号:296826 - 最終更新日: 2008/08/11 - リビジョン: 1

フィードバック