コンピュータを再起動するたびに、新しいハードウェアの検出ウィザードでプリンタ デバイスが検出される

重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明

現象

コンピュータを再起動するたびに、以前インストールしたプリンタが (新しくインストールしたプリンタではないにもかかわらず) 新しいハードウェアの検出ウィザードによって検出されることがあります。

原因

この問題は、以下の条件のいずれかに該当する場合に発生することがあります。
  • プリンタ ドライバがインストールにプラグ アンド プレイを使用しません。
  • 次のレジストリ キーが破損しています。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM

回避策

この問題を回避するには、新しいハードウェアの検出ウィザードが新しいプリンタを検出できない場合でも、ウィザードのすべての手順を完了します。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。


この問題を解決するには、更新されたドライバの入手、または使用しているプリンタで新しいハードウェアの検出ウィザードを完了するための具体的な手順について、プリンタの製造元にお問い合わせください。


たとえば、ヒューレット・パッカード社のプリンタを使用している場合は、以下のヒューレット・パッカード社の Web サイトを参照してください。
レジストリ エディタを使用して、破損したレジストリ キーを削除するには、以下の手順を実行します。
  1. 管理者のアカウントを使用してコンピュータにログオンします。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  3. [名前] ボックスに regedit と入力し、[OK] をクリックします。
  4. 次のレジストリ キーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM
  5. レジストリ キーを右クリックし、[削除] をクリックします。
  6. [キーの削除の確認] で、[はい] をクリックします。
  7. レジストリ エディタを終了し、コンピュータを再起動します。
Windows XP の再起動時に、プリンタが検出され、それに対するサポート ファイルがインストールされます。プリンタがインストールされると、Windows XP を起動してもプリンタは検出されません。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。



他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 298370 (最終更新日 2005-06-10) を基に作成したものです。
プロパティ

文書番号:298370 - 最終更新日: 2007/11/30 - リビジョン: 1

フィードバック