リモート カウンタを表示しようとしたときに、エラー メッセージ "コンピュータに接続できません" が表示される

現象

システム モニタを使用して、リモート コンピュータ上のパフォーマンス カウンタを表示しようとすると、次のエラー メッセージが表示されることがあります。
コンピュータに接続できません

原因

この問題は、リモート コンピュータに対して、パフォーマンス カウンタを表示するための適切なアクセス許可を持たない場合に発生する可能性があります。

解決方法

リモート コンピュータ上でパフォーマンス カウンタを表示できるようにするには、監視するリモート コンピュータに対して、次のアクセス許可を持つ必要があります。
  • SystemRoot が NTFS パーティション上にある場合、少なくとも次の 2 つのファイルに対する読み取りアクセス許可が必要です。
    • SystemRoot\System32\Perfc009.dat
    • SystemRoot\System32\Perfh009.dat
  • リモート コンピュータ上の次のレジストリ キーに対して、少なくとも読み取りアクセス許可が必要です。
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib
  • リモート コンピュータ上の次のレジストリ キーに対して、フル アクセスのアクセス許可が必要です。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\servicename\performance
    servicename は、監視するリモート コンピュータ上のサービス名です。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

詳細

リモート コンピュータに対して管理者権限を持つユーザーは、既にリモート カウンタを表示できます。
プロパティ

文書番号:300702 - 最終更新日: 2008/01/13 - リビジョン: 1

フィードバック