共有フォルダーにアクセスしようとすると、"アクセス拒否" エラーが発生する
現象
次のような状況で問題が発生します。
- SharePoint サイトまたは OneDrive サイトがあります。
- サイトには、 アクセス制限付きユーザーアクセス許可ロックダウン モード のサイト コレクション機能がアクティブ化されています。
- 特定のフォルダーを別のユーザーと共有します。
- 他のユーザーは、共有フォルダーへのアクセスを試みます。
この scanario では、他のユーザーは次のいずれかのエラー メッセージを受け取ります。
- アクセスが拒否されました。
- このリソースにアクセスするには、アクセス許可が必要です
原因
親フォルダーまたはサイトにアクセスできないユーザーとフォルダーを共有すると、SharePoint は親アイテムにユーザーの 制限付きアクセス 権を割り当てます。 具体的には、SharePoint を使用すると、ユーザーは親フォルダーやその他のアイテム (アクセス制限以外) へのアクセス許可を取得せずにフォルダーにアクセスできます。 ただし、 アクセス制限付きユーザーアクセス許可ロックダウン モード が有効になっている場合、他のアイテムに対して必要な制限付きアクセス許可が正しく機能しなくなったため、ユーザーはフォルダーにアクセスできません。
回避策
この問題を回避するには、状況に応じて、次のいずれかのオプションを使用します。
個々のファイルを共有するが、フォルダは共有しない。
サイト コレクションまたはサブサイト全体を共有します。
サイトで アクセス制限付きユーザーアクセス許可ロックダウン モードが必要ない場合は、 このサイト コレクション機能を無効にします。
メモ: 発行などのその他の機能では、この機能が正しく動作することが必要な場合があります。
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