一部の Android デバイスは、Exchange Onlineにリダイレクトされません

元の KB 番号: 3035227

現象

一部の Android デバイスでは、ユーザーのメールボックスがExchange Onlineに移動された後、新しいメッセージの受信が停止します。

原因

これは、Android デバイスが MobileSyncRedirectBypass 機能をサポートしていない場合に発生します。

Exchange Server 2010 SP3 RU9、Exchange Server 2013 CU8、Exchange Server 2016 以降、Android デバイスの自動検出サービスで MobileSyncRedirectBypass の新しい機能が導入されました。

既定では、この機能は、次のプレフィックスを持つデバイスで有効になっています。

Acer,ADR9,Ally,Amazon,Android,ASUS,EasClient,FUJITSU,HTC,HUAWEI,LG,LS,Moto,Mozilla,NEC,Nokia,Palm,PANASONIC,PANTECH,Remoba,Samsung,SEMC,SHARP,SONY-,TOSHIBA,Vortex,VS,ZTE

この機能を理解している既知の Android デバイスの最新の一覧は、自動検出 web.config ファイルの MobileSyncRedirectBypassClientPrefixes 設定にあります。 このファイルは、 %ExchangeInstallPath%\ClientAccess\自動検出 フォルダーにあります。

注:

MobileSyncRedirectBypass 機能は、一般に 451 リダイレクトと呼ばれます。 詳細については、「 3.1.5.2.2 HTTP エラー 451」を参照してください。

回避策

自動検出 web.config ファイルの MobileSyncRedirectBypassClientPrefixes 設定にデバイスがない場合は、次のいずれかの操作を行います。

  • メールボックスを Microsoft 365 に移動した後、Exchange ActiveSync (EAS) プロファイルのサーバー値を手動で編集します。
  • デバイスが MobileSyncRedirectBypass 機能をサポートしているかどうかをテストして判断します。 デバイスでこの機能がサポートされている場合は、環境内のすべての Exchange サーバーで MobileSyncRedirectBypassClientPrefixes 設定を編集します。

詳細については、「microsoft 365 へのオンボードExchange ActiveSync」を参照してください。