リモート デスクトップ サービスの概要が表示されない

現象

ドメイン環境で [リモート デスクトップ サービスのインストール] から構築したリモートデスクトップ サービス環境において、サーバーマネージャーの [リモート デスクトップ サービス] - [概要] を選択すると、以下のメッセージが表示され、概要が表示されない事象が発生します。

エラー :
リモートデスクトップサービスの展開がサーバープールに存在しません。
展開を作成するには、役割と機能の追加ウィザードを実行し、
リモート デスクトップ サービスのインストールオプションを選択してください。

原因

リモート デスクトップ デスクトップ環境にて、プロキシ サーバーを指定されている環境にて発生します。
サーバー マネージャー (ServerManager.exe) の処理では、内部的にWinRM (Windows リモート管理) を使用しており、プロキシサーバーの設定を読み取ります。
プロキシサーバーにおいて認証処理を求められる場合、認証に失敗し、事象が発生します。

解決方法

回避策 1 : プロキシ設定を解除する


プロキシ設定を解除することによって、現象が回避されます。

プロキシ設定を解除するには、以下のコマンドをRD 接続ブローカーで実行します。

> netsh winhttp reset proxy


回避策 2 : プロキシ設定に除外リストを設定する。

プロキシ サーバーの設定を実施している状態にて、環境内のサーバーを除外リストとして設定いただく事で、事象が回避されます。

対象のサーバーにて、コマンド プロンプトを開き、以下のコマンドを入力し、実行します。

> netsh winttp set proxy proxy-server =<プロキシ サーバー> bypass-list=<バイパス リスト>

* <プロキシ サーバー> は、使用するプロキシ サーバー名とポート番号です。
* <バイパス リスト> は、プロキシ サーバーを介さずにアクセスさせるサーバーの一覧です。
* プロキシサーバー、バイパスリストいずれも複数を列挙する場合は 区切り文字 ; をはさみ全体を "" で囲みます。

- 実行例:

> netsh winhttp set proxy proxy-server="myProxyServer:8080" bypass-list="<local>;*.microsoft.com;*.foo.ne"



バイパス リストに、RDS 環境で接続されるサーバーを列挙いただくか、ワイルド カード (*) を使用して、設定します。

設定に関しては、ホスト名、IP アドレス、FQDN 名のいずれでも問題ありません。

詳細

プロキシサーバーにおいての認証失敗は、リモート デスクトップ サービス以外にもサーバー マネージャーで管理されている他サービスの表示に影響を及ぼすこともあります。
プロパティ

文書番号:3046144 - 最終更新日: 2016/09/29 - リビジョン: 1

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