Windows ストア アプリが開かず、イベント ID 5973 がアプリケーション ログに記録される
この記事では、Windows ストア アプリを開くことができないときにログに記録されるイベント ID 5973 を修正するソリューションを提供します。
適用対象: Windows 8.1
元の KB 番号: 3064045
現象
Windows 8.1を実行しているデバイスでは、すべての Windows ストア アプリが開かず、次のようなエラーがアプリケーション ログに記録されます。
ログ名: アプリケーション
ソース: Microsoft-Windows-Immersive-Shell
日付: 日付と時刻
イベント ID: 5973
タスク カテゴリ: (5973)
レベル: エラー
キーワード:
ユーザー: ユーザー ID
コンピューター: コンピューター名
説明:
アプリ AppID のアクティブ化がエラーで失敗しました:このアプリは、指定されたコントラクトをサポートしていないか、インストールされていません。 詳細については、Microsoft-Windows-TWinUI/運用ログを参照してください。
原因
異常なシャットダウンでは、 のユーザー アプリケーション キャッシュ C:\Users\<username>\AppData\Local\Packages
が破損する可能性があります。
解決方法
問題があるかどうかをテストするには、 新しいユーザー アカウントを作成し、新しい アカウントにサインインします。 問題が消えた場合は、ユーザー プロファイルを再作成して問題を解決します。
古いユーザー アカウントのユーザー プロファイル データ ファイルをバックアップします。
画面の右端から中央にスワイプし、[検索] をタップします。 (マウスを使用している場合は、画面の右下隅をポイントし、マウス ポインターを上に移動し、[ 検索] をクリックします)。
[ 検索 ] ボックスに「 隠しファイルとフォルダーを表示する」と入力し 、Enter キーを押します。
[ フォルダー オプション] ダイアログの [ 表示 ] タブで、[ 詳細設定] の下を見て、次の設定を設定します。
- [非表示のファイル、フォルダー、ドライブを表示 する] ボタンを選択する必要があります。
- 既知のファイルの種類の拡張子を非表示にするには 、オフにする必要があります。
- 保護されたオペレーティング システム ファイルを非表示にする (推奨) はオフにする必要があります。
エクスプローラーで、フォルダーを
C:\Users\Old_Username
探します。ここで、C は Windows がインストールされているドライブであり、Old_Usernameはバックアップするプロファイルの名前です。このフォルダー内のすべてのファイルとフォルダーを選択してコピーします。次のファイルが必要です。
- Ntuser.dat
- NtUser.ini
- NtUser.log (または存在しない場合は、ntuser.dat.log1 と ntuser.dat.log2 という 2 つのログ ファイルを除外します)
選択したバックアップ場所にファイルを貼り付けます。 必要に応じて、このバックアップの場所から古いユーザー アカウント プロファイルを取得できますが、その下
C:\Users\<Old_Username>\AppData\Local\Packages
にあるファイルが破損している可能性があり、他のファイルも破損している可能性があることに注意してください。
古いユーザー アカウントからサインアウトします。 電子メール プログラムに電子メール メッセージがある場合は、古いプロファイルを削除する前に、電子メール メッセージとアドレスを新しいユーザー プロファイルにインポートする必要があります。 すべてが正常に動作している場合は、古いプロファイルを削除できます。
フィードバック
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