DFSR を使用して SYSVOL をレプリケートすると、DCDiag VerifyReferences テストが失敗する

この記事では、分散ファイル システム レプリケーション (DFSR) サービスを使用して sysvol フォルダーをレプリケートするときに発生するエラーの解決策について説明します。

適用対象: Windows Server 2012 R2
元の KB 番号: 3110032

現象

次のような状況で問題が発生します。

  • 分散ファイル システム レプリケーション (DFSR) サービスを使用して、sysvol フォルダーをレプリケートします。
  • すべてのドメイン コントローラー (DC) で Windows Server 2008 R2 以降のバージョンが実行されています。
  • ドメイン コントローラー診断ツール (DCDiag) を実行して、レプリケーションに関するレポートを生成します。

このシナリオでは、DCDiag は次のエラー メッセージを返します。

失敗したテスト VerifyReferences

DCDiag レポートには、次のエントリが含まれています。

Problem: Missing Expected Value
Base Object: CN=<DCNAME>,OU=Domain Controllers,DC=<DOMAIN>,DC=<COM>
Base Object Description: "DC Account Object"
Value Object Attribute Name: frsComputerReferenceBL
Value Object Description: "SYSVOL FRS Member Object"
Recommended Action: See Knowledge Base Article: Q312862

この問題が発生すると、DCDiag は DFSR の参照オブジェクトを検証します。 また、NT ファイル レプリケーション サービス (NTFRS) は停止します。

原因

この問題は、DFSR が sysvol レプリケーションに使用されている場合、ドメイン コントローラー オブジェクトの下に Active Directory データベースにファイル レプリケーション サービス (FRS) 参照がないために発生します。 代わりに、DFSR のオブジェクトのみが存在します。

このロジックは、Windows Server 2008 の DCDiag や、Windows Server 2003 サポート ツールと共にインストールされた DCDiag など、以前のバージョンの DCDiag には含まれていません。 そのため、これらのバージョンでは FRS メンバー参照が検索され、DCDiag で false エラーが生成されます。

解決方法

この問題を解決するには、 から %windir%\System32Dcdiag.exe を実行します。 このフォルダーには、Windows 2008 および Windows 2008 R2 の DCDiag の最新バージョンが含まれています。 最新バージョンの DCDiag を実行すると、sysvol レプリケーションは VerifyReferences テストに合格します。

代わりに、Windows サポート ツール スイートが Windows Server 2008 R2 にインストールされている場合は、アンインストールします。 これにより問題が解決され、任意の場所から Dcdiag.exe を実行できます。

詳細

最新の DCDiag リリースを使用している場合でも、「現象」セクションに記載されているエラーは、DCDiag エントリの CN=DCNAME>、OU=<Domain Controllers、DC=<DOMAIN>、DC=<COM> 行の msDFSR-Flags 属性が見つからないか、次のいずれかのフラグと一致しない場合に発生する可能性があります。

  • リダイレクトされたフェーズ: CN=dfsr-LocalSettings の msDFSR-Flags が0x20 (32 dez)
  • 排除されたフェーズ: CN=dfsr-LocalSettings の msDFSR-Flags が0x30 (48 dez)

この場合、DCDiag は、ファイル レプリケーション サービス (FRS) がまだ SYSVOL 用に構成されていると誤って想定し、存在しない Active Directory データベース内の FRS オブジェクトと属性の検証を試みます。 そのため、検証が失敗することが予想されます。

データ収集

Microsoft サポートからの支援が必要な場合は、「 Active Directory レプリケーションの問題に TSS を使用して情報を収集する」で説明されている手順に従って情報を収集することをお勧めします。