Azure AD で B2C のディレクトリを削除しようとすると、「削除することはできません」エラー

適用対象: Azure Active Directory

現象


Azure Active Directory 環境で B2C のディレクトリを設定して、それを削除しようとします。 ただし、次のエラー メッセージが表示されます。
'< Contoso >' を削除できません。次の問題を解決では、ディレクトリの削除を禁止します。ディレクトリには、ユーザーまたは管理者によって追加された 1 つまたは複数のアプリケーションが含まれています。

原因


B2C アプリケーション サービス プリンシパル (たとえば、CPIM、Ibiza のポータルと SSPR) を既存の削除をブロックしている場合、この問題が発生します。 

解決方法


この問題を解決するには、Azure ポータルを使用します。

Azure AD B2C のダッシュ ボードに表示されているすべてのアプリケーションを削除する手順 1。

これを行うには、以下の手順を実行します。
  1. Http://portal.azure.comで Azure AD B2C ディレクトリへのアクセス権を持つ管理者としてサインインします。
  2. 右上隅で、[表示名をクリックし、B2C のディレクトリは、ディレクトリを選択します。 注: 1 つのディレクトリがあれば、既に、Azure AD B2C ディレクトリが選択されます。
  3. Azure AD B2C のブレードを見つけるには、左下に複数のサービス(>)ボタンをクリックして「B2C」を検索して。
  4. Azure AD B2Cを選択します。
  5. すべての設定] をクリックし、[アプリケーション] をクリックします。
    ステップ 1(5)
  6. すべてのアプリケーションを削除します。 これを行うには、アプリケーションを選択し、プロパティ] をクリックし、 [削除] ボタンをクリックします。
    Delete an app
     

Azure AD B2C のテナントを削除する手順 2。

それには、以下の手順を実行します。

  1. Azure AD B2C のディレクトリに見つけて Azure ポータルのAzure Active Directoryのブレードを選択します。
  2. [概要] メニューには、ディレクトリの削除を選択します。
    ステップ 2(2)
  3. ポータルに表示される指示に従います。