メールボックスをオンプレミス環境から Office 365 へ移動しようとすると、"An extension number can‎'t be generated for the user" エラーが表示される

適用対象: Exchange OnlineExchange Server 2016 Enterprise EditionExchange Server 2016 Standard Edition

現象


ハイブリッド展開をしている環境において、オンプレミスの Exchange Server から Office 365 の Exchange Online へメールボックスを移動しようとすると、検証処理段階でエラーが生じます。以下のようなエラー メッセージが表示されます。
"MigrationPermanentException:
Mailbox '<UserName>' in the source forest is currently enabled for Unified Messaging but it can‎'t be enabled for Unified Messaging in the target forest for the following reason: An extension number can‎'t be generated for the user. To configure an extension number, use the -Extensions parameter with one or more valid extension numbers. Please fix the problem or disable the mailbox for Unified Messaging before you try the operation again."

(MigrationPermanentException:
ソース フォレストのメールボックス '<ユーザー名>' は、ユニファイド メッセージングが現在有効になっていますが、以下の理由から、移動先のフォレストでは有効にできません: ユーザーの内線番号が作成されていません。内線番号を構成するには、1 つ以上の有効な内線番号と共に –Extensions パラメーターを使用してください。問題を解決するか、操作を再び行う前にユニファイド メッセージングを無効にしてください。)

原因


この問題は、メールボックスからプライマリの Exchange ユニファイド メッセージング (EUM) アドレスが抜けている場合に生じます。 

メールボックスの移動に使用する New-MoveRequest コマンドレットにより、本事象を一部検証できます。検証処理の 1 つとして、移動元のメールボックスでユニファイド メッセージングが有効化されているか確認する処理があります。この問題が生じているかを確認するには、以下の手順に従い、オンプレミスにおける移動元のメールボックスに "EUM" (大文字) プレフィックスが含まれているプロキシ アドレスが存在しているかを確認します。
  1. Exchange 管理シェルを開き、以下のコマンドを実行します。
    1. Get-mailbox user@contoso.com |select -expand EMailAddresses 
    2. Get-UMMailbox user@contoso.com |fl 
  2. 出力結果を確認します。当該メールボックスでセッション開始プロトコル (SIP) が有効化されている場合、当該メールボックスにはプライマリの "EUM" (大文字) プロキシ アドレスおよびセカンダリの "eum" (小文字) プロキシ アドレスが存在しています。プライマリの EUM アドレスが抜けている場合、これが問題であると確認できます。

解決方法


プライマリの EUM アドレスを手動で追加します。たとえば、当該メールボックスで SIP が有効化されている場合、以下のような 2 つのエントリが存在します。

EUM:firstname.surname@<domain>.com;phone-context=DialPlanName.global.loc
eum:<phone extension>;phone-context=DialPlanName.global.loc
EUM アドレスの追加方法の詳細については、「ユーザー メールボックスの管理」 (英語) を参照してください。

追加情報


その他トピックは、Office 365 コミュニティ Web サイトまたは Exchange TechNet フォーラムを参照してください。