ADAL (別名現代認証) を有効にした後ビジネス用の Skype にサインインするときに複数の認証が求められます

適用対象: Skype for Business

現象


Azure AD 認証ライブラリ (ADAL) を有効にすると、ビジネス クライアント用 Skype にサインインしようとしたときに資格情報を入力するのには複数のセキュリティ プロンプトがユーザーに表示されます。

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原因


ビジネス サーバーでは、Skype の ADAL の認証が有効になっているが、セキュリティ トークン サービス (STS) URL に対する認証に統合 Windows 認証が設定されていないために、この問題が発生します。

解決策


この問題を解決するには、次の操作を行います。

  • STS URL を Internet Explorer のイントラネット ゾーンに追加します。
  • 統合 Windows 認証を有効にする] チェック ボックスを [セキュリティ]を選択するのには、Internet Explorer の既定の詳細セキュリティ設定が構成されていることを確認します。
  • イントラネット ゾーンでのみ自動ログオンオプションを選択するのには、イントラネット ゾーンでのユーザー認証のログオン設定が構成されていることを確認します。

詳細


ADAL、高レベルのセキュリティを提供することができます。会社のサービスに対して多要素認証を使用することできます。この追加のセキュリティ層では、ユーザーに認証要求が行われたときに認証が必要です。統合 Windows 認証を有効にすると、ユーザーのユーザーのキャッシュされた NTLM 資格情報が自動的に提供します。統合 Windows 認証が有効になっていない場合、ユーザーが表示されたら、それらの資格情報を入力する必要があります。

注: 外部ユーザーの認証は、コンピューターが企業の内部ドメインに接続されている場合にのみこのプロセスが動作するため統合 Windows 認証は使用されません。このような状況では、ユーザーは通常、Skype ビジネス認証ダイアログが表示されるを表示していました。

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