ネットワーク プロバイダーの設定は、Windows 10 へのインプレース アップグレード中に削除されます

この記事では、Windows 10へのインプレース アップグレード中にネットワーク プロバイダーの設定が削除される問題の回避策について説明します。

適用対象: Windows 10 Version 1809、Windows 10、バージョン 1709、Windows 10、バージョン 1703、Windows 10、バージョン 1607
元の KB 番号: 4013822

現象

Windows 10 Version 1809、バージョン 1709、バージョン 1703、またはバージョン 1607 へのインプレース アップグレードを実行すると、サード パーティのネットワーク プロバイダー設定がコンピューターから削除されます。

原因

これは、Windows 10 アップグレード プロセスの既知の問題です。 アップグレード後、プロバイダーの一覧 (HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider) がリセットされ、サード パーティのプロバイダー レジストリ設定 (の下 HKLM\System\CurrentControlSet\Services\) が削除されます。

回避策

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、次の Microsoft サポート技術情報の記事を参照してください。
322756 Windows でレジストリをバックアップおよび復元する方法

この問題を回避するには、以下のいずれかの方法を使用します。

方法 1

  1. アップグレードする前に、プロバイダーの一覧の内容と、それぞれのサード パーティのプロバイダー設定 (の下) を手動でHKLM\SYSTEM\CurrentControlSet\Control\NetworkProviderHKLM\System\CurrentControlSet\Services\バックアップします。
  2. アップグレードを実行します。
  3. アップグレードが完了したら、手順 1 でバックアップしたレジストリ設定を復元します。

方法 2

アップグレード後にサードパーティのネットワーク プロバイダー設定に影響する問題が発生した場合は、インストーラーによって削除されたレジストリ キーを手動で復元します。

詳細

ネットワーク プロバイダーの一覧を確認するには、次の手順に従います。

  1. [ 実行 ] ボックスを開きます。 これを行うには、Windows ロゴ キー ( )+ R キーを押します。

  2. ncpa.cplと入力し、Enter キーを押します。

  3. Alt キーを押してメニュー バーを開きます。

  4. [ 詳細設定] を選択し、[ 詳細設定] をクリックします。

    [詳細設定] ダイアログのスクリーンショット。

このサード パーティのネットワーク プロバイダーの一覧は、次のレジストリの場所に格納されます。
HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder
既定値: RDPNP、LanmanWorkstation、webclient
HKLM\System\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder
既定値: RDPNP、LanmanWorkstation、webclient

注:

各文字列値には、 の下 HKLM\System\CurrentControlSet\Servicesに独自の設定があります。
たとえば、既定のネットワーク プロバイダーを次に示します。

  • HKLM\System\CurrentControlSet\Services\RDPNP\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\LanmanWorkstation\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\WebClient\NetworkProvider

プロバイダー名が一覧から削除され、追加されたすべてのレジストリ キーが削除されます。

データ収集

Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。