ネットワーク プロバイダーの設定は、Windows 10 へのインプレース アップグレード中に削除されます。

適用対象: Windows 10, version 1809Windows 10, version 1709Windows 10, version 1703

現象


Windows 10、1809 のバージョン、バージョン 1709、1703 のバージョンまたはバージョン 1607 へのインプレース アップグレードを実行すると、サードパーティ製のネットワーク プロバイダーの設定は、コンピューターから削除されます。

原因


これは、Windows の 10 のアップグレード ・ プロセスでの既知の問題です。 アップグレード後、プロバイダーの一覧 (HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider) がリセットされ、(HKLM\System\CurrentControlSet\Services\) の下のサード パーティ プロバイダーのレジストリ設定が削除されます。

回避策


重要 このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 万一に備えて、編集の前にレジストリをバックアップしてください。 問題が発生した場合でも、レジストリを復元できます。 バックアップし、レジストリを復元する方法の詳細については、次のマイクロソフト サポート技術情報資料を参照してください。
322756 Windows でレジストリをバックアップおよび復元する方法
この問題を回避するには、以下のいずれかの方法を使用します。 

方法 1

  1. アップグレードする前に、HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider と、それぞれのサードパーティのプロバイダーの設定 (HKLM\System\CurrentControlSet\Services\) の下で [プロバイダー] 一覧の内容を手動でバックアップします。
  2. アップグレードを実行します。
  3. アップグレードが完了したら、手順 1 でバックアップされたレジストリ設定を復元します。  

方法 2

アップグレードした後、サードパーティ製のネットワーク プロバイダーの設定に影響する問題が発生している場合は、インストーラーによって削除されたレジストリ キーを手動で復元します。 

詳細情報


ネットワーク プロバイダーの一覧を確認するには、次の手順を実行します。
  1. 実行する] ボックスを開きます。 これを行うには、Windows ロゴ キーを押します (Windows logo key + R)。
  2. Ncpa.cplと入力し、Enter キーを押します。
  3. メニュー バーを表示するのには Alt キーを押します。
  4. 詳細設定] を選択し、[詳細設定] をクリックします。  
    4013822_NetworkProvidersList
     
このサードパーティ製のネットワーク プロバイダーの一覧は、次のレジストリ位置に格納されます。
HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder既定値: RDPNP、LanmanWorkstation、webclient
HKLM\System\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder既定値: RDPNP、LanmanWorkstation、webclient
注: 各文字列値] の下の独自の設定にはHKLM\System\CurrentControlSet\Services です
などの既定のネットワーク プロバイダーは次のように。 
  • HKLM\System\CurrentControlSet\Services\RDPNP\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\LanmanWorkstation\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\WebClient\NetworkProvider

プロバイダー名は、ボックスの一覧から削除され、すべての追加のレジストリ キーが削除されます。