Azure で Windows を実行しているサポートされている VM のインプレース アップグレード

注意

この記事のプロセスに従うと、データ プレーンと仮想マシン (VM) の コントロール プレーン の間で切断が発生します。 自動ゲスト パッチ適用自動 OS イメージのアップグレードホットパッチAzure Update Managerなどの Azure 機能は使用できません。 これらの機能を利用するには、インプレース アップグレードを実行するのではなく、優先オペレーティング システムを使用して新しい VM を作成することをお勧めします。

この記事では、サポートされている Windows 10 ベースの Azure VM のインプレース システム アップグレードを実行する方法について説明します。 この記事では、インプレース システムアップグレードでサポートされていない Azure VM の回避策についても説明します。 Windows Server を実行している Azure VM については、「 サポートされている Windows Server VM のインプレース アップグレード」を参照してください

注:

Windows Server をお探しですか?
Windows Server を実行している VM のインプレース システム アップグレード手順については、「Azure で Windows Server を 実行している VM のインプレース アップグレード」を参照してください。

元の製品バージョン: Windows 10、バージョン 1803、すべてのエディション、Windows 10、バージョン 1709、すべてのエディション、Windows を実行している仮想マシン、Windows 10、Windows 8.1、Windows 7 Enterprise
元の KB 番号: 4014997

現象

次のような状況で問題が発生します。

  • Microsoft Azure 環境で Windows を実行している VM があります。
  • VM を新しいバージョンのオペレーティング システムにインプレース アップグレードします。

このシナリオでは、アップグレードが失敗するか、ブロックされ、直接コンソール アクセスが必要になることがあります。

原因

インプレース システムアップグレードは、特定のバージョンの Azure Windows VM でサポートされています。 間もなく、(機能更新プログラムとして) インプレース システムアップグレードのサポートを他のバージョンに拡大する予定です。

インプレース システムアップグレードでサポートされる Windows バージョン

  • シングル セッション、すべてのエディション、すべてのバージョンWindows 10

  • マルチセッションWindows 10 Enterprise、すべてのバージョン

    注:

    • 現在、Professional または Enterprise Windows 10実行されている既存の VM をマルチセッションWindows 10 Enterpriseアップグレードすることはできません。
    • Windows 10からWindows 11に移行する場合は、新しい VM をデプロイしてベスト プラクティスに従ってください。 この方法では、潜在的な互換性の問題を回避し、構成を最適化します。

インプレース システムアップグレードでまだサポートされていない Windows バージョン (回避策の使用を検討してください)

  • Windows 8.1
  • Windows 7 Enterprise

Windows 10 VM のインプレース システム アップグレード プロセス

このプロセスを完了するには、VM の再起動に 45 分から 60 分かかります。 インプレース システム アップグレードを実行するには、次の手順に従います。

  1. Windows 10 VM がエフェメラル OS ディスクを使用していないことを確認します。 この機能は現在サポートされていません。

  2. Windows 10 VM に少なくとも 2 GB の RAM とシステム ディスク上の 12 GB の空きディスク領域があることを確認します。

  3. データの損失を防ぐには、Azure Backupを使用してWindows 10 VM をバックアップします。 または、Azure Marketplace Backup & Recovery からサードパーティのバックアップ ソリューションを使用します

  4. バックアップが成功したかどうかを確認します。 これを行うには、元のWindows 10 VM をオフにします。 バックアップから新しい VM を正常に復元できることと、すべてのアプリケーションが正常に実行されていることを確認します。

    注:

    元の Windows 10 VM または復元された VM は、インプレース システム アップグレードのソースとして使用できます。 ただし、VM のシステム名といずれかの VM の IP アドレスが競合を防ぐために変更されていない限り、両方の VM を同時に実行することはできません。

  5. Windows 10 VM に接続し、設定>Updates &セキュリティ>Windows Updateに移動します。

  6. Windows Updateで、[更新プログラムの確認] を選択します。

  7. [機能更新プログラム] 項目が表示されたら、[ 今すぐダウンロードしてインストール] を選択します。

  8. 更新プログラムがダウンロードされ、インストールされます。 ユーザー設定とデータは保持され、VM は自動的に再起動されます。

この手順に関する一般的な質問がある場合は、 Microsoft Q&A に投稿し、質問にタグを azure-virtual-machines 追加します。

回避策

この問題を回避するには、サポートされているバージョンを実行している Azure VM を作成します。 VM の VHD をダウンロードしてアップグレードします。

データの損失を防ぐには、Azure Backupを使用してWindows 10 VM をバックアップします。 または、Azure Marketplace Backup & Recovery からサードパーティのバックアップ ソリューションを使用します

VHD をダウンロードしてアップグレードする

手順 1: ローカル Hyper-V VM でインプレース アップグレードを実行する

  1. VM の VHD をダウンロードします
  2. VHD をローカル Hyper-V VM にアタッチします。
  3. VM を起動します。
  4. インプレース アップグレードを実行します。

手順 2: VHD を Azure にアップロードする

次の記事の手順に従って、VHD を Azure にアップロードし、VM をデプロイします。

一般化された VHD をアップロードし、それを使用して Azure に新しい VM を作成する

関連情報

Microsoft Azure 仮想マシンに対する Microsoft サーバー ソフトウェアのサポート

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