Windows Server 2012 R2 および Server 2016 コンピューターで、iSCSI が接続されているターゲットとの接続が切断する問題が発生している場合、他の多数の現象が発生している可能性があります。 たとえば、次のような現象です。
- オペレーティング システムが応答しない。
- Stop エラー (Bugcheck エラー) 0x80、0x111、0x1C8、0xE2、0x161、0x00、0xF4、0xEF、0xEA、0x101、0x133、または 0xDEADDEAD が発生する。
- ユーザー ログオン エラーと共に "使用可能なログオン サーバーがない" エラーが発生する。
- 使用できるエフェメラル ポートがないため、アプリケーションとサービスのエラーが発生する
- システム プロセスによって、非常に多くのエフェメラル ポートが使用されている。
- システム プロセスによって、非常に多くのスレッドが使用されている。
原因
この問題は、Windows Server 2012 R2 および Windows Server 2016 RS1 コンピューターでロックの問題が発生し、iSCSI ターゲットへの接続の問題が発生することが原因です。 この問題は、以下のいずれかの更新プログラムをインストールした後に発生する可能性があります。
Windows Server 2012 R2
リリース日 | KB | 資料のタイトル |
2017 年 5 月 17 日 | KB 4015553 | 2017 年 4 月 19 日 — KB4015553 (マンスリー ロールアップのプレビュー) |
2017 年 5 月 10 日 | KB 4019215 | 2017 年 5 月 10 日 — KB4019215 (マンスリー ロールアップ) |
2017 年 5 月 10 日 | KB 4019213 | 2017 年 5 月 10 日 — KB4019213 (セキュリティのみの更新プログラム) |
2017 年 4 月 19 日 | KB 4015553 | 2017 年 4 月 19 日 — KB4015553 (マンスリー ロールアップのプレビュー) |
2017 年 4 月 12 日 | KB 4015550 | 2017 年 4 月 12 日 — KB4015550 (マンスリー ロールアップ) |
2017 年 4 月 12 日 | KB 4015547 | 2017 年 4 月 12 日 — KB4015547 (セキュリティのみの更新プログラム) |
2017 年 3 月 22 日 | KB 4012219 | 2017 年 3 月 Windows 8.1 および Windows Server 2012 R2 用の月例品質ロールアップのプレビュー |
Windows Server 2016 RTM (RS1)
リリース日 | KB | 資料のタイトル |
2017 年 5 月 17 日 | KB 4023680 | 2017 年 5 月 27 日 — KB4023680 (OS ビルド 14393.1230) |
2017 年 5 月 10 日 | KB 4019472 | 2017 年 5 月 10 日 — KB4019472 (OS ビルド 14393.1198) |
2017 年 4 月 12 日 | KB 4015217 | 2017 年 4 月 12日 — KB4015217 (OS ビルド 14393.1066 および 14393.1083) |
確認
- システム上にある次の MSISCSI ドライバーのバージョンを確認します。
c:\windows\system32\drivers\msiscsi.sys
この動作になるバージョンは、Windows Server 2012 R2 の場合は 6.3.9600.18624、Windows Server 2016 の場合は 10.0.14393.1066 です。 - 次のイベントがシステム ログに記録されます。
イベント ソース | ID | テキスト |
iScsiPrt | 34 | A connection to the target was lost, but the Initiator successfully reconnected to the target. Dump data contains the target name. |
iScsiPrt | 39 | The Initiator sent a task management command to reset the target. The target name is given in the dump data. |
iScsiPrt | 9 | Target did not respond in time for a SCSI request. The CDB is given in the dump data. |
- システム プロセスで実行されているスレッド数を確認し、通常の作業時の基準と比較します。
- システム プロセスで現在開かれているハンドル数を確認し、通常の作業時の基準と比較します。
- システム プロセスによって使用されているエフェメラル ポート数を確認します。
- 管理 PowerShell から次のコマンドを実行します。
Get-NetTCPConnection | Group-Object -Property State, OwningProcess | Sort Count
または、管理コマンド プロンプトから、"Q" スイッチを使用して次の NETSTAT コマンドを実行します。 その結果、接続されていない "バインドされている" ポートが表示されます。
NETSTAT –ANOQ
システム プロセスが所有しているポートに注目します。
上記の 3 つの点について 12,000 を超える数値があれば、そこが問題の可能性があります。 SCSI ターゲットがコンピューターにある場合、この問題が発生する可能性が高くなります。
解決策
多数の再接続が発生していることがイベント ログに記録されている場合は、iSCSI およびネットワーク ファブリック ベンダーに相談し、エラーの理由を診断して解決し、iSCSI ターゲットへの接続を維持してください。 また、現在のネットワーク ファブリックで iSCSI ターゲットにアクセスできることを確認してください。 更新された修正プログラムがリリースされた場合はインストールします。 修正プログラムがリリースされた場合はこの資料の内容を更新し、インストールする修正プログラムのサポート技術情報番号も修正する予定です。
注: 3 月、4 月、5 月、または 6 月のセキュリティ ロールアップをアンインストールすることは推奨されません。 アンインストールすると、マンスリー更新プログラムで軽減されている既知のセキュリティの脆弱性や他のバグの影響を受けることになります。 まず iSCSI ターゲットおよびネットワーク ベンダーに相談し、ターゲットの再接続をトリガーしている接続の問題を解決することをお勧めします。